14:59:44 <farheen_cefalu_a> #startmeeting architecture committee
14:59:44 <collabot`> Meeting started Thu Jan 31 14:59:44 2019 UTC.  The chair is farheen_cefalu_a. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:44 <collabot`> The meeting name has been set to 'architecture_committee'
15:05:12 <farheen_cefalu_a> #topic Agenda Licensing and Training.
15:05:27 <farheen_cefalu_a> #action PTLs assign user stories to sprint 2
15:07:04 <farheen_cefalu_a> #action Adi and Sayee provide user stories and scope
15:09:22 <farheen_cefalu_a> #info Add federation to the agenda and add independent ms generation.  Ken wants federation, Guy wants independent user and Bryan wants K8 from platform deployment and system integration. Ken what is the fed topic?  The federation of catalogs and fucntionality of the gateway is blocking federation.
15:09:43 <farheen_cefalu_a> #topic Licensing Michelle Martens AT&T
15:12:12 <farheen_cefalu_a> #info M: I'm review MVP with boreas.  We put in the jira user stories.  A few may need to be tweeked.  I'm going to go through the table for impact.  From a model owner perspective we are enabling association of model license when onboarding or publishing a model.  A human readable text file.  There is ability to upload the license.  The publisher will be able to check for license before publishing to public.  Compo
15:15:33 <farheen_cefalu_a> #info not mixed licenses for composite solutions.  When federating the license will be included.  LUM License usage manager won't be ready for Boreas but will be delivered in Clio.  Reviewed LUM diagram.  Manoop: If LUM is not available or will the ETE flow be functional?  Yes, we will have ETE flow functional but will have minimal complexity.  From supplier perspective the publisher approves the model license exist
15:17:26 <farheen_cefalu_a> #info license is what the model owner uses for the model.  A user that wants to use the model they will find a model and review the terms and conditions for that model and will purchase the entitlement  It's a text file that gets communicated through the catatlog.  From user perspective they find a model they will have to go through their existing asset management and purchase the license in order to use the model.
15:19:57 <farheen_cefalu_a> #info details for use with model.  We're going to support a presence of that entitlement.  Security verfication will check that license exists in order to download or deploy the model.  Security verification will handle the actions requested.  They will call LUM.  Right to use will be a list stored in CVS.  LUM will call the API does this license exist.  If it does exist allow download or deploy to exist.  Question:
15:22:07 <farheen_cefalu_a> #info will not allow a limit to the entitlements.  For Boreas we are only validating the exists or not.  There are jira user stories already established for these.  Manoop:  Download and deploy jira issues have to be assigned to a sprint.  That will help release management plan for demos.  Is this impact to security deployment team committed? and portal?  Michelle: we are targeting for sprint 2.  We're having meetin
15:23:54 <farheen_cefalu_a> #info ELK logging will be tracking.  There is no impact from the License management team.  Bryan: That will be an item we will put in jira.  Michelle: Next item Ericsson is providing API tracking of their model.  We are looking for Orange contribution to define the text file for the model license and entitlements and user stories.
15:25:43 <farheen_cefalu_a> #info Anwar: is API specific to model or generic?  They will come up with any model.  We are going to be talking about those details today and tomorrow with Guy. Manoop: Wen Ting may be on the call will they be using the 5G use case?  Yes but I don't know the details yet. Bryan: We support the ability to onboard docker images so the vendors have opportunity to embed models for tracking.
15:28:03 <farheen_cefalu_a> #info Michelle: Showing the wiki.acumos.org Boreas MVP Outline shows the details of getting started.  Bryan: There is no api we are going to build in this release.  Just an interface between lum and security library.  The only API will be the usage tracking api and we haven't figured out which component will deliver this.
15:29:47 <farheen_cefalu_a> #info Anwar: MVP is listed as set points for the main features? Yes plus the onboarding text file for the catalog.  The other thing that's missing is the actual creation of the license manager library.  Bryan: that's implied. Michelle: This should map to the table I was just showing.
15:30:31 <farheen_cefalu_a> #info Michelle: Allowing for the model license to be associated with the model and the right to use associated with user and the right to download and deploy.
15:34:09 <farheen_cefalu_a> #info Michelle: Everyone should have their internal procurement process.  Supplier Mgmt. processes is outside the scope of acumos.  Asset mgmt happen outside of acumos. Anwar: Let's make sure that we can display a use case that shows how it works when it is working.  We don't have sprint plans for this development cycle.  We're having meetings today and tomorrow.  Manoop: I see under release planning you have sprint
15:34:28 <farheen_cefalu_a> #topic Training
15:34:52 <farheen_cefalu_a> #info Manoop: We captured users stories that have been committed for Boreas.  There are user stories mapped to sprint two.
15:35:51 <farheen_cefalu_a> #action Kazi and Mukesh start mapping your user stories to sprints.  Are you still working on finding the resources.  Mukesh we are going to review the wireframes.  Committed resources? My management will get back to Anwar.
15:36:43 <farheen_cefalu_a> #info Bryan: We have a plan and we're starting in this sprint with the integration of components.  Some aspects are unsettled.  for example how do you manage the artifacts?  We have to test out the space of options to find what's feasible in this release.  That's where I am.
15:37:01 <farheen_cefalu_a> #info Manoop: any serious blockers on training.
15:38:23 <farheen_cefalu_a> #action Nat get resources re-allocated from other components to the training models on the TechM side.  We all agree in terms of priority and associate the resources there first.  There are 40 resources on TechM side.  AT&T can assist to reallocate. Mukesh: there was an internal discussion and my mgmt will get back to them.
15:39:12 <farheen_cefalu_a> #info CMLP side will have resources on the training module and there are already resources that will assist.
15:41:22 <farheen_cefalu_a> #info Kazi: ML workbench UI and the ML workbench backend.  When the call is made what is the implementation details of that call.  Each of the API calls is what I am doing now.  Right now I am working on the implementation action business logic.  Just as I have documented for DS earlier.  I am working on create update delete project, notebook, and pipeline.  I have found hickups that I have to review with the CMLP a
15:42:28 <farheen_cefalu_a> #info L workbench.  Manoop: As long as your user stories are components, epics, and sprints. My concern is I know your team has done development but is now showing up here in the release management list.
15:43:13 <farheen_cefalu_a> #action Nat update release notes to reflect.
15:44:53 <farheen_cefalu_a> #topic Status
15:45:27 <farheen_cefalu_a> #info Portal keep at 85% Onboarding is on track and 100% including dependencies.
15:45:56 <farheen_cefalu_a> #action PTLs review APIs that are provided by other PTLs.
15:47:08 <farheen_cefalu_a> #info Chris Lott: I have no update to the percentage Kazi's team have identified the licensing needs.  Michelle's team has not defined the data needs.  Michelle: I hope to discuss it today or tomorrow.  Chris: No progress.
15:49:06 <farheen_cefalu_a> #info Manoop: For training we have the functionality that has been covered for MVP?  Are we still trying to close gaps.  We are clear on what can be developed.  functionality has been extensively discussed.  Manoop: We can increase to 50% because we have MVP functionality and design.
15:50:42 <farheen_cefalu_a> #info Bryan: If we restrict this measure to what we know we are committed to delivereing it's somewhere in the realm of 50%.  If we still have ambitions that include the project teams it gets fuzzier.  Are we going to accomodate the new workbench under the existing CDS model or are we going to create a new  super set data model?  IF we don't settle on that question I'm less confident that its 50%.
15:53:13 <farheen_cefalu_a> #info Kazi: What are the backend artifacts that manage their lifecycles. We will be able to incorporate the project, pipeline, and notebook.  Data sources data sets and predictors no.  It requires a lot of changes in the nifi UI.  Project, pipeline, notebook is MVP.  Only projects owned by a different user.  We have a little bit of dta model work.  If it's a slight enhancement to the data model.
15:55:31 <farheen_cefalu_a> #info Anwar: I'm assuming the design work is in progress and should not be checked off.  Notebooks and Nifi are not designed yet.  We are in the design state we have done the design of the data model and apis.  Now we are doing the design behavior and business logic.  I will keep it at 60%.
15:57:49 <farheen_cefalu_a> #info For deployment the design is there.  The dependencies have to be worked out with Mukesh and Chris.  At the moment the white box is looking less possible in this release.  I don't have committed resources.  I'm less confident.  Model lifecycle management is a medium.  Not a high priority.  Deploy start, stop we don't have a set of goals.  That's been dropped down.  Kubeflow is clio.  Security is the same.
15:58:24 <farheen_cefalu_a> #info Guy: 90% Dependencies are left.  We have a few jira items that are going to be done in the later sprints.
16:00:06 <farheen_cefalu_a> #info We reviewed MVP for licensing. Michelle: Keep it at 80.  Do we know the overall design.  M: I want it confirmed.  APIs are being defined at this point.
16:03:00 <talasila> #link #info https://wiki.acumos.org/display/CS/Impacts+of+Independent+Microservice+Creation
16:03:05 <farheen_cefalu_a> #info Guy: Sharing Impacts of Independent MS creation (wiki.acumos.org). I've listed the biggest changes to portal.  I have place holders for jira items.  I'm wondering if the component owners want to build them.  We need to replace the build for ONAP button with build for MS button.  Design Studio needs to be able to deal with the fact that not everything is composable.  Currently DS requires the URL that will be i
16:04:39 <farheen_cefalu_a> #info This lives under boreas release under common services.  Component owners may be happier.  I posted this link in the meeting.
16:05:03 <talasila> https://wiki.acumos.org/display/OAM/Supported+Platform+Deployment+Approaches
16:05:04 <farheen_cefalu_a> #link https://wiki.acumos.org/display/OAM/Supported+Platform+Deployment+Approaches
16:05:08 <farheen_cefalu_a> #endmeeting