#acumos-meeting: Architecture Committee

Meeting started by farheen_att at 14:04:24 UTC (full logs).

Meeting summary

  1. Agenda (farheen_att, 14:04:34)
    1. we will cover the architecture diagram changes. (farheen_att, 14:06:08)
    2. release status and defects by Murali (farheen_att, 14:06:21)
    3. https://wiki.acumos.org/display/AR/Demeter+Architecture (farheen_att, 14:07:34)
    4. Manoop sharing the power point slide (farheen_att, 14:07:52)
    5. added Jenkins Engine to On-boarding which will enable security verification and license checks. (farheen_att, 14:09:09)
    6. Ken: we found because Jenkins has file share jobs running we had to put the jenkins on the same where all the dockers are running. (farheen_att, 14:11:03)
    7. Ken: we found because of ms drop in certain prepped file to be run they had to be running on the same core. I have not crossed that yet with Kubernetes but that is what we found in docker. (farheen_att, 14:11:59)
    8. Manoop yes, these issues have to be addressed to see how it can be commonly used vs. placing restrictions. This slide represents a general reliance on the Jenkins engine. (farheen_att, 14:12:53)
    9. Nat: Suggestion: Instead of putting Jenkins in validation is it possible to put it on the rectangle 7 e1 - e7 to encompass the whole platform. (farheen_att, 14:13:36)
    10. Manoop: Good suggestion. Rather than putting on the outer rim of the external api we will choose it as an internal api, internal engine used by this module. (farheen_att, 14:14:16)
    11. The only services using Jenkins is License check and ms. (farheen_att, 14:15:45)
    12. ACTION: Manoop update the architecture slide to spread Jenkins across all components. (farheen_att, 14:16:27)
    13. Ken: is there a reason why you changed Acu-Compose to Drag and Drop canvas? (farheen_att, 14:18:28)
    14. Manoop yes, because the name changed. (farheen_att, 14:19:22)
    15. Reuben: Why is Indigo on the diagram? (farheen_att, 14:19:36)
    16. Manoop: It was an old project. (farheen_att, 14:19:59)
    17. Reuben: Indigo is not open source. (farheen_att, 14:20:19)
    18. Manoop: Guy should we wait to add O-RAN? B or C release? (farheen_att, 14:21:34)
    19. We have O-RAN SC software contributions that we will after they have been released on O-RAN. (farheen_att, 14:23:21)
    20. Manoop: I have reviewed the Licensing User,Proxy, LUM and have them positioned accordingly. (farheen_att, 14:25:44)
    21. Michelle the LUM Proxy is the gateway to LUM. (farheen_att, 14:26:23)
    22. Michelle: The LUM proxy should be renamed. LMCL License Manager Client Library. (farheen_att, 14:27:01)
    23. Michelle: Call it LM License Library. It should not be represented as a database. It's a server and doesn't store information. (farheen_att, 14:27:49)
    24. Michelle: What is the rationale for E7 because I don't reference them. (farheen_att, 14:33:56)
    25. Manoop: These are for the REST APIs that Justin exposed. (farheen_att, 14:34:12)
    26. Manoop: The E are external interface. (farheen_att, 14:34:58)
    27. Reuben: If the LUM requires it's own set of APIs then we could start to add L1, L2,... specific to the LUM. (farheen_att, 14:36:17)
    28. Michelle: Yes, we need to work on that to update this diagram because we have started using them. (farheen_att, 14:36:53)
    29. ACTION: Michelle work with Reuben to incorporate the L interfaces specfiic to licensing and LUM into the overall architecture diagram. (farheen_att, 14:37:49)
    30. Ken: asterick needs a key or removed. (farheen_att, 14:38:53)
    31. Manoop: Simulator and Test was something I need clarity on. (farheen_att, 14:39:14)
    32. Reuben: Training environment One for running and one for testing. You need a component that deploys the model into test, kicks off the testing, collects the results and then re-onboards the predictor or trained model. (farheen_att, 14:40:15)
    33. Manoop: Viabhav from ML Workbench have a contribution towards predictors. Where they want to deploy a test model and evaluate the results and show those evaluated results. (farheen_att, 14:41:49)
    34. ACTION: Manoop follow up with Vaibhav regarding the Simulator/Tester ** (farheen_att, 14:42:29)
    35. ACTION: Nat and Murali request Viabhav to join this architecture call because he is the temporary ML workbench representative. (farheen_att, 14:43:07)

  2. Release (farheen_att, 14:43:19)
    1. we are in the ETE sprint. (farheen_att, 14:44:45)
    2. Manoop: our plan was to wrap up with Acumos- 3791. (farheen_att, 14:45:37)
    3. ACTION: Murali schedule a meeting between Manoop, Sanjay, Vaibhav. (farheen_att, 14:46:33)
    4. moving on to Licensing: Michelle: Shylender is working on 4084 is the new license manager screen. (farheen_att, 14:56:58)
    5. Murali reviewed project status https://jira.acumos.org/secure/Dashboard.jspa Choose Demeter release dashboard. (farheen_att, 14:58:17)


Meeting ended at 14:58:21 UTC (full logs).

Action items

  1. Manoop update the architecture slide to spread Jenkins across all components.
  2. Michelle work with Reuben to incorporate the L interfaces specfiic to licensing and LUM into the overall architecture diagram.
  3. Manoop follow up with Vaibhav regarding the Simulator/Tester **
  4. Nat and Murali request Viabhav to join this architecture call because he is the temporary ML workbench representative.
  5. Murali schedule a meeting between Manoop, Sanjay, Vaibhav.


People present (lines said)

  1. farheen_att (44)
  2. collabot` (3)


Generated by MeetBot 0.1.4.