15:03:32 <aimeeu> #startmeeting Platform OA&M Weekly Meeting
15:03:32 <collabot> Meeting started Thu Jul 26 15:03:32 2018 UTC.  The chair is aimeeu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:32 <collabot> The meeting name has been set to 'platform_oa_m_weekly_meeting'
15:05:01 <aimeeu> #Roll Call
15:05:15 <aimeeu> #info attendees Spondon, Parichay, Amit, Bryan, Aimee
15:07:45 <aimeeu> #link https://wiki.acumos.org/display/OAM/Meetings
15:08:26 <aimeeu> Zoom meeting:  #link https://zoom.us/j/4906631713
15:09:06 <aimeeu> #info attendees: Mukesh Mantan
15:09:11 <aimeeu> #topic Agenda Bashing
15:10:30 <aimeeu> #topic Review of Committed Features (Jira Items)
15:11:02 <aimeeu> #info attendees Lorraine Welch, Nat Subramanian, Sanjay Agraharam
15:12:43 <aimeeu> #info Bryan covers release plan checklist
15:12:58 <aimeeu> #link https://wiki.acumos.org/display/OAM/Release+Planning
15:14:27 <aimeeu> #topic Log Standards
15:14:54 <aimeeu> #info define log standards and implement in all components - Bryan has asked Spondon to lead this effort
15:15:20 <aimeeu> #link https://jira.acumos.org/browse/ACUMOS-710
15:16:21 <aimeeu> #info Acumos-710 is the old implementation and needs to be updated; PTLs need to know exactly what needs to be implemented to comply with the new standard
15:16:41 <aimeeu> #action Spondon will update Acumos-710
15:18:41 <aimeeu> #info Bryan created a 'logging' label in Jira and added the label to relevant Jira items; asks everyone to add the label when creating logging-related items
15:19:02 <aimeeu> #link https://jira.acumos.org/browse/ACUMOS-622
15:19:17 <aimeeu> #info Spondon asks about ^
15:20:37 <aimeeu> #info Nat: suggests creating an Epic for updating logging in components to comply with new standard
15:22:26 <aimeeu> #action Bryan will optimize the Jira items
15:23:04 <aimeeu> #info O&AM Support for ELK Kibana - Single logging system across components and generating usage reports #link https://jira.acumos.org/browse/ACUMOS-1091
15:25:23 <aimeeu> #info log standardization and consistency design studio  #link https://jira.acumos.org/browse/ACUMOS-624
15:25:45 <aimeeu> #info team needs to create logging subtasks for the other components
15:28:39 <aimeeu> #info Aimee: what is the new logging standard, how will it be implemented?
15:29:25 <aimeeu> #info EELF is going away and Acumos will be using the Logging Service that has been developed in ONAP
15:30:08 <aimeeu> #info question: how will the ONAP logging service be used within Acumos?
15:30:53 <aimeeu> #info Parichay: we need to copy the ONAP code and customize it for Acumos
15:36:26 <aimeeu> #info need a clear example of the old way of logging and how to move to the new way of logging
15:37:34 <aimeeu> #info Michael O'Brien: upgrading to the new logging standard will break the old logging, so the logs will not be able to be consumed in ELK stack
15:37:54 <aimeeu> #info solution: provide 2 logback.xml files for backwards compatiblity
15:39:31 <aimeeu> #info 1) adapt ONAP logging library for Acumos; 2) components must switch to new logging library; 3) ELK Stack - configuration update
15:40:22 <aimeeu> #info elasticsearch config needs to be updated for new logging standards
15:46:08 <aimeeu> #info Mukesh has specific implementation questions
15:46:27 <aimeeu> #info components must implement AOP
15:46:44 <aimeeu> #action Michael O'Brien will describe exactly how to use the logging library
15:47:58 <aimeeu> #info Lorraine: acumos will have a different set of MDCs - so if components pull the logging library from ONAP, who will this work?
15:48:22 <aimeeu> #info Michael: it is doable but ELK stack needs to be modified
15:49:26 <aimeeu> #info Aimee: some of our components are Python - how will they use the new logging library?
15:50:03 <aimeeu> #info Micheal: there is a Python library in the ONAP loggging library: pylog (which needs to be updated)
15:50:19 <aimeeu> #info will need an example of how to use pylog
15:52:10 <aimeeu> #info Michael: will OA&M provide a logging wrapper?
15:52:25 <aimeeu> #info yes - we should minimize components copying code
15:52:56 <aimeeu> #info inplement this in OA&M, then components reference the library in OA&M
15:53:39 <aimeeu> #action Bryan and Spondon will update Jira
15:54:40 <aimeeu> #info Spondon: is there a workaround in terms of what we can implement if we don't leverage the ONAP logging library?
15:55:24 <aimeeu> #info Michael: yes, a number of ways but the logging library is meant to make life easier
15:56:44 <aimeeu> #info Nat: suggestion: bring in key component leads for quick conversation about the ONAP logging library
15:58:01 <aimeeu> #info get their input on complexity so OAM can decide how to implement in this release
16:06:09 <aimeeu> #action Michael and Spondon will join next week's PTL meeting to present the new logging spec and options
16:06:14 <aimeeu> #endmeeting