14:02:54 <skobza> #startmeeting Weekly FD.io csit project meeting
14:02:54 <collabot`> Meeting started Wed Apr 27 14:02:54 2016 UTC.  The chair is skobza. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:54 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:54 <collabot`> The meeting name has been set to 'weekly_fd_io_csit_project_meeting'
14:03:07 <skobza> #chair mackonstan1
14:03:07 <collabot`> Current chairs: mackonstan1 skobza
14:03:16 <skobza> #chair mmiklus
14:03:16 <collabot`> Current chairs: mackonstan1 mmiklus skobza
14:03:23 <skobza> #chair cj
14:03:23 <collabot`> Current chairs: cj mackonstan1 mmiklus skobza
14:03:39 <skobza> #topic agenda bashing
14:04:19 <skobza> #info list of jobs has been updated
14:04:35 <skobza> #topic Jenkins jobs failures
14:04:52 <skobza> #info Jan reports vpp build failures causing vpp-csit jobs (vpp verify jobs)
14:06:16 <skobza> #info Carsten did some tcpdump on VIRL host, to see if the only expected_failing test (vxlan over dot1q) is due to vpp or the infra (VIRL host)
14:06:56 <skobza> #info Carsten mentions that the vlan tagged vxlan packet is received on VIRL, is forwarded to dest DUT, but further investigation is requried
14:07:12 <skobza> #action Carsten to further debug vxlan-over-dot1q on VIRL
14:08:06 <skobza> #info Peter working on ipv6 perf tests
14:08:18 <skobza> #info Peter working on 4 core and 2 core configs
14:08:33 <skobza> #info Peter also working on stability of TREX related tests
14:09:33 <skobza> #info Miro vpp-csti-verify-perf-short got stuck in a weird loop. Looks like it was a ZUUL issue (between jenkins and gerrit). CJ restarted jenkins, slaves, and currently we are re-trying the failing job.
14:10:19 <skobza> #action https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-perf-short/
14:10:23 <skobza> #link https://jenkins.fd.io/view/vpp/job/vpp-csit-verify-perf-short/
14:11:03 <skobza> #info renaming a job in Jenkins causes removal of job runs history.
14:11:39 <skobza> #info Miro & Peter are going to re-test perf jobs in vpp to verify they are working
14:13:55 <skobza> #info functional-jobs failures: jobs started failing on VIRL after VIRL topology change - disabling of IPv6. VPP took all interfaces including mgmt interface. Newer version of VPP from nexus behaves correctly.
14:15:20 <skobza> #info despite quite a few failing jobs, all issues were and are addressed. Important thing is, all problems are related to integration, vpp, or combination, not really CSIT code.
14:15:55 <skobza> #topic Jira task and issue tracking
14:16:09 <skobza> #info Miro worked out operational Kanban board
14:16:32 <skobza> #info we are filling the Jira dashbord with bugs, tasks - all are aligned with the plan on the wiki posted two weeks ago
14:17:27 <skobza> #link https://jira.fd.io/secure/RapidBoard.jspa?rapidView=1&projectKey=CSIT
14:20:00 <skobza> #action mackonstan1: describe the proposed use of Jira - priorities, plan alignment, etc.
14:23:08 <skobza> #action Peter is going to look into, and then propose a mechanism of storing data into different server than jenkins.
14:25:39 <skobza> #action cj & Peter: develop mechanism how to store data on nexus (disk images, tarballs)
14:26:52 <skobza> #link https://wiki.fd.io/view/CSIT/Jobs list of csit jobs with documentation
14:27:38 <skobza> #topic CSIT Jobs
14:30:20 <skobza> #info job #5 - identifying vpp-master-verified vpp build for csit-* jobs. Proposal is to run this twice a week. All tests have to be run against a VPP version: functional AND performance.
14:30:49 <skobza> #action mackonstan1 will send out information on open e-mail mailing list to solicit review the list of jobs
14:31:59 <skobza> #info for vpp-master verify weekly has issue with tagging (there's arelready a helpdesk ticket for that)
14:33:03 <skobza> #info Jan confirms the problem with git tag is still not resolved
14:35:16 <skobza> #info CJ: packaging taking his time. Will prioritize this item.
14:35:48 <skobza> #topic reorg of wiki pages
14:37:55 <skobza> #info aim is to implement all the must-haves [p0-r1] items
14:39:40 <skobza> #info on Kanban all p0-r1 are stored in Jira as high priority
14:39:55 <skobza> #info ... what is planned to be done by end of May is stored as medium prio
14:42:17 <skobza> #info CSIT will add pX-R1 tags to issues in CSIT jira to help tracking/pairing against wiki
14:43:52 <skobza> #topic CSIT usability
14:49:28 <skobza> #info DPDK folks that reached out to CSIT over e-mail last week didn't reach out again after initial e-mail.
14:50:45 <skobza> #info VPP dev is looking into gcov usability in VPP
14:51:14 <skobza> #info Andrej works on LISP testcases for CSIT
14:53:50 <skobza> #action mackonstan1: go after indirect adj and glean adj functionality, in form of vpp-dev (Damjan?), to help adding testcases to CSIT for these features
14:54:07 <skobza> #action mackonstan1: ask vpp-dev how to verify adjacencies
14:54:30 <skobza> #topic Documentation
14:54:47 <skobza> #info ... is linked, is alive for two weeks. It requries more work - everybody is encouraged to help with doc.
14:55:08 <skobza> #action mackonstan1: to send feedback to skobza on documentaiton
14:55:22 <skobza> #topic CSIT release strategy
14:56:00 <skobza> #info we decided to run CSIT jobs on weekly basis, and that is csit-verify* jobs. We are going to be releasing CSIT code on weekly basis
14:56:40 <skobza> #info additions to CSIT release is going to be documented by both Jira and gerrit logs
14:58:52 <skobza> #info trying to keep the overhead of releasing to minimum.
15:01:21 <skobza> #info release strategy is going to be done at TSC meeting. mackonstan1 is going to write something to TSC e-mail to solicit comments on CSIT release planning
15:01:45 <skobza> #topic pressing issues
15:01:54 <skobza> #info mackonstan1  still don't have access to rt helpdesk
15:02:21 <skobza> #action cj is going to follow up on reported inaccessibility of RT
15:02:33 <skobza> #endmeeting