#fdio-csit: CSIT meeting

Meeting started by mackonstan1 at 14:02:02 UTC (full logs).

Meeting summary

  1. agenda bashing (skobza, 14:03:05)
  2. operational status (skobza, 14:04:23)
    1. func tests jenkins jobs: no issues spotted. One problem is still with vlan sub-interfaces, and some packets were not making it thru to VPP. Damjan asked for more information, Carsten working on it. Issue exists for more than 3 weeks (skobza, 14:06:41)
    2. it was unknown whether the problem was due to VPP problem, CSIT, or VIRL (skobza, 14:07:51)
    3. Carsten: at this stage it is a VPP bug, and CSIT is providing data as requested (skobza, 14:08:41)
    4. csit-verify is still not working (skobza, 14:11:02)
    5. csit-vpp-verify-weekly patch is in review (skobza, 14:12:31)
    6. perf test cases update: vpp csit jobs are running, some are in review. Work on tb1 and tb3 in progress. (skobza, 14:13:53)
    7. perf jobs are not heavily used by vpp devs. (skobza, 14:14:43)
    8. no feedback from vpp-devs why they are not using them. (skobza, 14:14:55)

  3. jira tasks and issues tracking (skobza, 14:16:37)
    1. CSIT review queue had been reduced. (skobza, 14:16:57)
    2. iacl, SHG tests are in (skobza, 14:17:33)
    3. FDS team has sent us their test plan. We are working with that test plan to capture the scenarios. (skobza, 14:18:06)
    4. Zdenko looking into the FDS test cases. (skobza, 14:18:31)
    5. FDS: we have to add VXLAN and VLAN tests w/ and w/out vhost-user test cases. (skobza, 14:19:13)
    6. 2 more items in pipeline, the rest of the Jira issues will get prioritized later (skobza, 14:20:04)
    7. ACTION: mackonstan1 Jan: walk thru the list of Jira CSIT issues, and mark down items that are VPP code not ready (skobza, 14:21:38)
    8. https://jira.fd.io/projects/VPP/issues/VPP-40 VLAN-tagged ingress packets discarded by VPP on VIRL (skobza, 14:22:21)

  4. VPP performance results - analysis (skobza, 14:23:36)
    1. On vpp call some people believed to be low, but also there were some inconsistency in the results. (skobza, 14:24:51)
    2. some vpp devs commented that the perf numbers are low, becuase of external factors - setup, traff gen, and so on (skobza, 14:25:48)
    3. CSIT perf has to work out what telemetry data should we collect and report while test run. (skobza, 14:26:33)
    4. Peter states that CSIT should add host environment data to the perf results. Our LF based testing infra is a little bit different from vpp-dev folks. (skobza, 14:27:53)
    5. ... we should consider how to normalize test environment to share and compare test results (skobza, 14:28:26)
    6. ... CSIT should publish the test bed setup doc. (skobza, 14:30:06)
    7. ... NDR testing for zero packet loss vs. non-zero loss tolerance difference. (skobza, 14:32:01)
    8. ... Peter to look into implement one place for zero packet loss and non-zero loss tolerance (skobza, 14:33:25)
    9. ... request to track the perf test results anomalies in Jira (skobza, 14:36:13)
    10. ACTION: mackonstan1 to create Jira issues to track the perf test anomalies (multi-core) (skobza, 14:36:30)

  5. test results readability (skobza, 14:38:05)
    1. log and report files are still not viewable - have to be downloaded (skobza, 14:38:24)
    2. https://wiki.fd.io/view/Infra/tickets <- prioritization of tickets (edwarnicke, 14:38:56)
    3. still can't read in-browser RF log.html and report.html (mackonstan1, 14:39:22)
    4. example (mackonstan1, 14:39:30)
    5. https://jenkins.fd.io/view/csit/job/csit-vpp-perf-hw-all/78/robot/report/log.html (mackonstan1, 14:39:35)
    6. perf team to write down perf TB configs: HW, bios, grub, vpp startup config (skobza, 14:47:54)
    7. all perf doc going to go to wiki (skobza, 14:49:00)

  6. dev work plan (skobza, 14:50:50)
    1. Michal confirmed he updated the links at wiki.fd.io (skobza, 14:51:04)
    2. vnet virl - two virl machines are operational since weekend. The only thing that needs to be resolved, is some configs have to be committed to git. Next item is test the nested virtualization env in LF (skobza, 14:51:54)
    3. VIRL monitoring to be looked at too. (skobza, 14:52:26)

  7. CSIT usability (skobza, 14:54:59)
    1. LISP the only project to submit test cases to CSIT (skobza, 14:55:25)
    2. LISP willing to write perf tests, if not really different than func tests. (skobza, 14:57:01)
    3. ACTION: mackonstan1 Florin: Look at potential LISP perf tests (skobza, 14:57:19)

  8. documentation (skobza, 14:58:12)
    1. additions to wiki: writing a test case, near finish. Some comments exists. (skobza, 14:58:26)
    2. https://atlas.hashicorp.com/bento/boxes/ubuntu-16.04 (skobza, 15:02:33)


Meeting ended at 15:02:35 UTC (full logs).

Action items

  1. mackonstan1 Jan: walk thru the list of Jira CSIT issues, and mark down items that are VPP code not ready
  2. mackonstan1 to create Jira issues to track the perf test anomalies (multi-core)
  3. mackonstan1 Florin: Look at potential LISP perf tests


Action items, by person

  1. mackonstan1
    1. mackonstan1 Jan: walk thru the list of Jira CSIT issues, and mark down items that are VPP code not ready
    2. mackonstan1 to create Jira issues to track the perf test anomalies (multi-core)
    3. mackonstan1 Florin: Look at potential LISP perf tests


People present (lines said)

  1. skobza (55)
  2. edwarnicke (8)
  3. mackonstan1 (5)
  4. collabot` (5)


Generated by MeetBot 0.1.4.