14:02:19 <mackonstan1> #startmeeting CSIT-weekly-160803
14:02:19 <collabot> Meeting started Wed Aug  3 14:02:19 2016 UTC.  The chair is mackonstan1. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:19 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:19 <collabot> The meeting name has been set to 'csit_weekly_160803'
14:03:16 <mackonstan1> #chair mackonstan mmiklus
14:03:16 <collabot> Warning: Nick not in channel: mackonstan
14:03:16 <collabot> Current chairs: mackonstan mackonstan1 mmiklus
14:03:50 <dwallacelf> #info dwallacelf
14:03:53 <mackonstan1> #info Dave Wallace
14:04:00 <mackonstan1> #info Jan Gelety
14:04:07 <mackonstan1> #info Peter Mikus
14:04:17 <mackonstan1> #info Samuel Elias
14:04:25 <mackonstan1> #info Vladimir Holly
14:05:39 <mackonstan1> #info Hung Pham
14:07:53 <mmiklus> #topic Inputs from FD.io projects - vpp, hc, ...
14:08:44 <mmiklus> #info vpp migration to 16.07 dpdk
14:09:09 <mackonstan1> #topic FD.io CSIT operational status.
14:09:36 <mackonstan1> #info weekly and semi-weekly jobs runing OK
14:14:15 <mackonstan1> #info currently functional tests taking long time - 42-to-45min, in addition to all environment setup
14:19:43 <mackonstan1> #action Jan to send duration breakdown per test case, as well as environment setup times
14:20:18 <mackonstan1> #action CSIT committers - review the time distribution, agree on the resolution options to reduce the overall execution time, make a proposal.
14:23:39 <mackonstan1> #info new nightly job for performance verification - Miro opened Jira ticket
14:24:41 <mmiklus> #link https://jira.fd.io/browse/CIMANAGE-14 <- nightly build waiting for review
14:26:58 <mackonstan1> #topic Adding new test cases - TLDK
14:29:15 <mackonstan1> #info Anna - asking for guidance on how to add TLDK test cases to CSIT
14:29:46 <mackonstan1> #action Maciek - will provide links for intro new test cases into CSIT
14:30:52 <mackonstan1> #action Anna - provide description of TLDK tests to be added to CSIT, email to csit-dev
14:35:26 <mackonstan1> #topic VPP 16.09 release readiness
14:35:58 <mackonstan1> #info dpdk 16.07 intro - performance issues based on this patch https://gerrit.fd.io/r/#/c/2196/
14:36:38 <mackonstan1> #info observing throughput drop after moving from dpdk 16.04 to 16.07
14:46:09 <mmiklus> #info Long IPv4 baseline PDR 64B 1 core, #2196 patch: 2*3.3Mpps, nexus build(dpdk 16.04): 2*4.4Mpps
14:54:20 <mortderire> https://git.fd.io/cgit/vpp/tree/dpdk/dpdk-16.04_patches/0013-Revert-ixgbe-fix-packet-type-from-vector-Rx.patch
14:55:39 <mackonstan> #link https://git.fd.io/cgit/vpp/tree/dpdk/dpdk-16.04_patches/0013-Revert-ixgbe-fix-packet-type-from-vector-Rx.patch
14:57:15 <mackonstan> #info Ray confirmed that above patch is missing from both dpdk 16.07 and vpp 16.09, and should be added to address CSIT performance issues observed
15:04:14 <mackonstan> #action Peter Mikus to send summary of performance comparison between dpdk1607 and dpdk1604, following testing of patch https://gerrit.fd.io/r/#/c/2196/
15:04:31 <mackonstan> #info for baseline tests: ip4, ip6, l2xc, l2bd.
15:07:55 <mmiklus> #endmeeting