#fdio-csit: CSIT-weekly-160907

Meeting started by mackonstan at 14:04:21 UTC (full logs).

Meeting summary

  1. agenda bashing (mackonstan, 14:04:49)
  2. Inputs from FD.io projects (mackonstan, 14:06:05)
    1. VPP update from yday call - next vpp release - Keith Burns proposal for Damjan Marion to drive the release (mackonstan, 14:07:02)

  3. DPDK+VPP focused pre-integration testing - Waterman Cao. (mackonstan, 14:08:00)
    1. open action pending - Waterman proposal: start with opt-1 as step1 for Intel team to get familiar with CSIT code and VPP environment. (mackonstan, 14:08:21)
    2. ACTION: Waterman to review this high-level plan with Ray Kinsella, and come back with the strawman plan (mackonstan, 14:08:32)

  4. TLDK test cases - Anna (Qun Wan). (mackonstan, 14:08:55)
    1. review done by mmiklus, Anna posted patches based on feedback (mackonstan, 14:09:49)
    2. updated patch in review (mackonstan, 14:10:06)
    3. TBD: agreee on jenkins job creation/triggers for tldk test cases (mmiklus, 14:11:23)

  5. FD.io CSIT operational status (mackonstan, 14:13:18)
    1. jenkins slaves capacity issues are gone for now (mackonstan, 14:13:47)
    2. some issues starting vpp1206 images in perf testbed (mackonstan, 14:14:39)
    3. this issue reported by Peter Mikus (mackonstan, 14:15:38)
    4. https://jira.fd.io/browse/CSIT-400 (mackonstan, 14:15:41)
    5. link to monitor fd.io jenkins slaves status (mackonstan, 14:16:50)
    6. https://jenkins.fd.io/computer/ (mackonstan, 14:16:54)
    7. Build Queue should be empty or small (mackonstan, 14:17:46)

  6. CSIT exec time reduction (mackonstan, 14:19:11)
    1. from jgelety - no progress on splitting the TCs into separate jobs, will work on it in coming week (mackonstan, 14:19:32)

  7. csit1609 release readiness (mackonstan, 14:19:52)
  8. • CSIT 16.09 jenkins jobs (mackonstan, 14:22:02)
    1. perf numbers into report from csit-vpp-perf-1609-all (mackonstan, 14:23:34)
    2. to generate the graphs, run csit-vpp-perf-1609-all manually multiple times (mackonstan, 14:25:52)
    3. ACTION: Peter to run csit-vpp-perf-1609-all manually, report issues, auto-produce very nice graphs :) (mackonstan, 14:26:51)

  9. Status - https://jira.fd.io/issues/?filter=10667. (mackonstan, 14:31:03)
  10. Status - CSIT Jira 1609-p0. (mackonstan, 14:31:25)
    1. https://jira.fd.io/issues/?filter=10667 (mackonstan, 14:32:07)
    2. candidates for cherry-picking for csit1609: csit-384, 383, 27 (mackonstan, 14:33:41)

  11. Status - performance tests (mackonstan, 14:34:56)
    1. comparing NDR, PDR results of vpp1609 vs. vpp1606 (mackonstan, 14:36:39)
    2. ACTION: Maciek, Miro - comparing NDR, PDR results of vpp1609 vs. vpp1606, aim to identify code changes responsible (mackonstan, 14:38:30)

  12. VM-virtio, VPP-vhost-user numbers. (mackonstan, 14:40:16)
    1. current NDR, PDR results much lower than expected, and observed in non-CSIT testbeds (mackonstan, 14:40:51)
    2. ACTION: Peter, Maciek working on resolution to identify root cause and fix perf issues in csit testbeds for vpp vhost-user with guest-VM running test-pmd (mackonstan, 14:41:35)

  13. Latency measurements. (mackonstan, 14:42:01)
    1. latency results require further scrutiny and analysis, as using brand new trex functionality with separate latency measurements streams (mackonstan, 14:43:16)
    2. ACTION: Miro, Maciek, dwallacelf - work with trex dev team (Yaroslav?) to drive conclusions on latency measurements by trex in csit (mackonstan, 14:44:55)

  14. Review failing tests CSIT Jira 1609-fail (mackonstan, 14:46:41)
    1. csit1609 report will list failed test cases in a separate section with explanations (mackonstan, 14:55:21)
    2. explanation will be pulled from csit JIRA for tickets marked with 1609-fail label (mackonstan, 14:55:46)
    3. https://jira.fd.io/issues/?filter=10667&jql=project%20%3D%20CSIT%20AND%20resolution%20%3D%20Unresolved%20AND%20labels%20%3D%201609-fail%20ORDER%20BY%20priority%20DESC%2C%20updated%20DESC (mackonstan, 14:56:03)

  15. • Tickets Blocked, Stuck In Review state, Red Flag Tickets, Yellow Flag Tickets. - redundant, already discussed (mackonstan, 14:57:05)
  16. Test report generation (mackonstan, 14:59:08)
    1. Peter updated parser, fixed text rendering (mackonstan, 14:59:24)
    2. need to add performance graphs (mackonstan, 14:59:32)

  17. CSIT dev work plan - wiki plan, jira tracking (mackonstan, 15:00:08)
    1. next week fd.io TWS call will discuss vpp1612 release plan - Tue 13-Sep, 09:15 (mackonstan, 15:01:04)

  18. vpp1609 test gap analysis (mackonstan, 15:02:03)
  19. vpp test gap analysis (mackonstan, 15:02:52)
    1. followup required with Erin once back from PTO (mackonstan, 15:03:06)


Meeting ended at 15:03:35 UTC (full logs).

Action items

  1. Waterman to review this high-level plan with Ray Kinsella, and come back with the strawman plan
  2. Peter to run csit-vpp-perf-1609-all manually, report issues, auto-produce very nice graphs :)
  3. Maciek, Miro - comparing NDR, PDR results of vpp1609 vs. vpp1606, aim to identify code changes responsible
  4. Peter, Maciek working on resolution to identify root cause and fix perf issues in csit testbeds for vpp vhost-user with guest-VM running test-pmd
  5. Miro, Maciek, dwallacelf - work with trex dev team (Yaroslav?) to drive conclusions on latency measurements by trex in csit


People present (lines said)

  1. mackonstan (55)
  2. collabot (5)
  3. mmiklus (1)


Generated by MeetBot 0.1.4.