13:59:39 <mackonstan> #startmeeting csit weekly 160928
13:59:39 <collabot> Meeting started Wed Sep 28 13:59:39 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:39 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:39 <collabot> The meeting name has been set to 'csit_weekly_160928'
13:59:51 <mackonstan> #chair mackonstan
13:59:51 <collabot> Current chairs: mackonstan
14:01:50 <mackonstan> topic: Inputs from FD.io projects
14:05:06 <mackonstan> #topic: Inputs from FD.io projects
14:05:16 <mackonstan> #topic: VPP
14:06:57 <mackonstan> #info: mackonstan - need to drive closer collaboration and interaction with vpp project, specifically on what vpp-dev would like to see from csit-dev on performance a.o.
14:07:34 <mackonstan> #topic DPDK+VPP focused pre-integration testing - Waterman Cao.
14:07:56 <mackonstan> #info no update from Waterman
14:08:22 <mackonstan> #topic TLDK test cases - Anna (Qun Wan)
14:08:45 <mackonstan> #info mmiklus - some progress on tldk patches for csit, moving forward, slowly ….
14:09:15 <mackonstan> #info mmiklus - tldk team are also looking at performance tests, fighting with TRex at the moment …
14:10:42 <mackonstan> #topic FD.io CSIT operational status
14:11:17 <mackonstan> #topic jenkins jobs - csit-vpp, vpp-csit.
14:11:47 <mackonstan> #info performance scale ip4 and ip6 tests failing due to fib2.0 vpp patch
14:12:48 <mackonstan> #info vpp vhost multiqueue patch failing - Jan, Peter assisting
14:13:06 <mackonstan> #topic jenkins slaves, capacity issues, job queue length.
14:13:57 <mackonstan> #info no connectivity issues, after tcp timeout correction by LF IT team
14:15:22 <mackonstan> #topic CSIT exec time reduction update - use experience
14:16:16 <mackonstan> #info now it's merged and operational in csit branch oper-160925 and used by all vpp-csit-verify jobs
14:16:45 <dwallacelf> #info JVPP random build failure was fixed by the following link
14:16:49 <dwallacelf> #link https://gerrit.fd.io/r/#/c/3131/
14:23:37 <mackonstan> #topic CSIT/VPP-16.09_Test_Report
14:24:49 <mackonstan> #topic Performance tests - going forward
14:26:03 <mackonstan> #topic upgrade to ubuntu 16.04
14:26:38 <mackonstan> #info dwallacelf - working on documentation for upgrading the perf testbeds based on past Carsten TOIs
14:29:55 <mackonstan> #info need another volunteer to help
14:38:17 <mackonstan> #info Peter, Dave, Maciek - itemized work proposal to move csit virl and perf testbeds to ubuntu 16.04 - share on csit-dev. coordinate the timeline.
14:38:39 <mackonstan> #topic Latency
14:40:56 <mackonstan> #info mmiklus - should analyse the latency measurement results across TCs, pick up the slow ones, and propose to vpp-dev for optimization
14:43:03 <mackonstan> #info mackonstan, mmiklus - ask TRex to add 1588 PTP based latency mesurement to TRex sw
14:44:34 <mmiklus> #info mmiklus - to look at the X170 loopback connection in LF and create tests to measure latency on a stream going from TG directly to TG
14:46:06 <mackonstan> #topic vhost-user
14:47:07 <mackonstan> #topic Multi-thread
14:47:25 <mackonstan> #info xl710 multi-thread results look low and weird
14:48:06 <mackonstan> #info mmiklus investigating
14:48:31 <mackonstan> #topic dpdk rls baseline
14:49:26 <mackonstan> #info mackonstan dpdk performance trending is a MUST for csit1701
14:50:49 <mackonstan> #agreed integrating dpdk performance trending in csit is the highest priority
14:51:14 <mackonstan> #action mackonstan - reach out to dpdk guys (waterman, ray kinsella) and ask for direct assistance
14:57:24 <mackonstan> #topic Functional tests - going forward
15:05:26 <mackonstan> #info new vpp-dev make test framework - status, initial code
15:05:26 <mackonstan> #link https://github.com/vpp-dev/vpp/tree/test-infra
15:05:26 <mackonstan> #info csit virl functional test framework - status - need upgrade to ubuntu 16.04
15:05:26 <mackonstan> #info functional test cases - splitting proposal - all pure functional tc's into vpp-dev make test, fallout tc's (eg vhost) into csit virl functional
15:05:26 <mackonstan> #info performance test case continue as per today in csit perf
15:05:43 <mackonstan> #topic CSIT dev work plan - review, discuss
15:06:59 <mackonstan> #info jira csit-func-1701
15:06:59 <mackonstan> #link https://jira.fd.io/issues/?filter=10718
15:06:59 <mackonstan> #info jira csit-perf-1701
15:06:59 <mackonstan> #link https://jira.fd.io/issues/?filter=10719
15:06:59 <mackonstan> #info jira csit-infra-1701
15:07:00 <mackonstan> #link https://jira.fd.io/issues/?filter=10720
15:07:08 <mackonstan> #endmeeting