14:04:49 <mackonstan> #startmeeting csit weekly 161012
14:04:49 <collabot> Meeting started Wed Oct 12 14:04:49 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:49 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:49 <collabot> The meeting name has been set to 'csit_weekly_161012'
14:04:59 <mackonstan> #chair mackonstan
14:04:59 <collabot> Current chairs: mackonstan
14:05:24 <dwallacelf> #info Dave Wallace
14:05:38 <mackonstan> #topic Agenda bashing
14:05:53 <mackonstan> #topic Inputs from FD.io projects
14:06:54 <mackonstan> #topic TLDK
14:07:41 <mackonstan> #info Peter - re csit patch for TLDK functional - updates sent over by Ana, addressing review comments
14:08:45 <mackonstan> #info dwallacelf - update from TLDK meeting last week - TLDK folks are using google test framework for unit tests, detail to be posted on TLDK project wiki
14:10:26 <mackonstan> #info keith burns talking about csit in the context of nsh - but no further details is forthcoming
14:12:26 <mackonstan> #topic VPP
14:12:47 <mackonstan> #info need to summarize to VPP the csit1701 plan
14:13:36 <mackonstan> #action Maciek - summarize what's done in csit1609, and then summarize proposal for csit1701 across - i) virl-functional, ii) phy-performance, iii) vpp-test.
14:14:18 <mackonstan> #info send it to csit-dev, review by ALL csit folks; and then fwd to vpp-dev.
14:14:51 <mackonstan> #topic FD.io CSIT operational status
14:15:15 <mackonstan> #info jobs for 1609 stopped
14:16:25 <jgelety> 3link: https://gerrit.fd.io/r/#/c/3350/
14:16:56 <jgelety> #link: https://gerrit.fd.io/r/#/c/3350/
14:19:25 <mackonstan> #info virl machines outage yesterday due to garbage accumulated over the LF infra outages - see email thread on csit-dev
14:21:37 <mackonstan> #action Peter Mikus to summarize work required to prevent this happening in the future
14:21:58 <mackonstan> #topic Testbeds upgrade to Ubuntu 16.04
14:22:29 <mackonstan> #info Peter Mikus status update - VIRL Image 1.4 (Ubuntu Xenial) is now produced and operational. Simulation is working and nodes are brought up.
14:23:05 <mackonstan> irc://barjavel.freenode.net:6697/#infoeter Mikus - Physical TB3 is reinstalled and working properly. The rest of TBs are waiting for successful VIRL run so we can switch.
14:23:51 <mackonstan> #info Peter Mikus - Physical TB3 is reinstalled and working properly. The rest of TBs are waiting for successful VIRL run so we can switch.
14:27:29 <mackonstan> #info currently blocked by PIP and setuptools not compatible with TrafficScriptExecutor - wip
14:27:36 <mackonstan> #link https://gerrit.fd.io/r/#/c/3290/
14:32:10 <mackonstan> #info Next step after fixing above issues with CSIT code - need to adjust ci-management so VPP jobs will work.
14:33:22 <mackonstan> #topic Performance tests - csit1701 plan
14:34:57 <mackonstan> #info 	•	dpdk rls baseline
14:36:59 <mackonstan> #info Maciek update - working with dpdk folks on addressing it, next update after dpdk userspace summit next week
14:37:14 <mackonstan> #info 	•	Latency - path to further improve accuracy - work with TRex project
14:40:35 <mackonstan> #info Maciek update - TRex lead confirmed that improving latency measurement accuracy is possible by using PTP/ieee1588 supprt in xl710 nics. looking for volunteers to help it code in TRex. right now no plan.
14:41:07 <mackonstan> #topic TLDK update - Anna
14:41:34 <mackonstan> #info TLDK functional test cases added - thanks to Peter and Miro for good reviews.
14:45:19 <mackonstan> #info DPDK baseline tests - started to work on the plan to integrate into CSIT - l2fwd, l3fwd, maybe testpmd.
14:49:07 <mackonstan> #topic Functional tests - csit1701 plan
14:49:34 <mackonstan> #info new vpp test infra framework - status - framework changes tracked on gerrit
14:49:45 <mackonstan> #link https://gerrit.fd.io/r/#/c/3345/
14:50:40 <mackonstan> #link https://gerrit.fd.io/r/#/c/3237/
14:55:53 <mackonstan> #topic CSIT dev work plan - review, discuss
14:55:57 <mackonstan> #info see jira tickets
14:56:57 <mackonstan> #topic CSIT HC tests
14:57:23 <mackonstan> #info CSIT HC tests ready to go production
14:57:44 <mackonstan> #link https://gerrit.fd.io/r/3018
14:58:47 <mackonstan> #endmeeting