#fdio-csit: csit weekly 161019

Meeting started by mackonstan at 14:03:36 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 14:03:56)

  1. agenda bashing (mackonstan, 14:04:01)
  2. Inputs from FD.io projects (mackonstan, 14:04:25)
  3. VPP project (mackonstan, 14:05:26)
    1. VPP agreed to move the "make test" into operational verify jobs as soon as practicable. (dwallacelf, 14:07:16)
    2. ACTION: Maciek and Dave to raise issue of having VPP Release Manager attend CSIT weekly meeting to share 17.01 VPP milestone status and/or changes. (dwallacelf, 14:16:43)
    3. VPP rep to help us drive the retrofit testing areas (mackonstan, 14:17:23)

  4. DPDK+VPP focused pre-integration testing (mackonstan, 14:20:06)
    1. Waterman + Anna working on DPDK testpmd in host baseline tests, right now getting familiar trex (mackonstan, 14:21:10)
    2. putting in place a regular csit tws call on Friday's to drive progress (mackonstan, 14:21:34)

  5. TLDK test cases (mackonstan, 14:21:47)
    1. functional tests - patch review almost complete, but bootstrap logic needs to be split up (mackonstan, 14:22:40)

  6. Testbeds upgrade to Ubuntu 16.04 (mackonstan, 14:30:27)
    1. confusion about vpp hugepage configuration at init - what, where, how - long saga - many patches (mackonstan, 14:30:50)
    2. relevant patches (mackonstan, 14:31:01)
    3. vpp hugepages patch: https://gerrit.fd.io/r/#/c/3170/ (pmikus, 14:31:31)
    4. https://gerrit.fd.io/r/#/c/3170/ (mackonstan, 14:32:00)
    5. here patches impacting ubuntu1604 operation (mackonstan, 14:32:30)
    6. https://gerrit.fd.io/r/#/c/3460/ (mackonstan, 14:32:35)
    7. https://gerrit.fd.io/r/#/c/3481/ (mackonstan, 14:32:58)
    8. dwallacelf will test 3481 on virl servers (mackonstan, 14:38:57)

  7. Performance tests - csit1701 plan (mackonstan, 14:43:29)
    1. fib2.0 cvg test development in progress - tibor (mackonstan, 14:43:59)
    2. xl710 - ip4, l2bd - added. ip6 - in review. (mackonstan, 14:45:37)
    3. Complete XL710 baseline tests - see fallout from csit1609 (mackonstan, 14:46:14)
    4. plan: other NICs: x710, vic1385, vic1227 (mackonstan, 14:46:38)
    5. plan: Thorough review of ubuntu1604 perf results - NDR, PDR, latency, compare to ubuntu14.04 (mackonstan, 14:47:56)
    6. plan: compare to non-LF hosted lab results - Cisco, Intel, others? (mackonstan, 14:48:19)
    7. : share findings on csit-dev and vpp-dev (mackonstan, 14:49:01)
    8. : Enhance vhost tests - per csit1609 report note (mackonstan, 14:50:35)
    9. : Enhance multi-threaded tests (mackonstan, 14:51:38)

  8. Functional tests - csit1701 plan (mackonstan, 14:53:44)
    1. Jan - last set of ipsec / ikev2 TCs in review (mackonstan, 14:54:06)
    2. lisp test cases - still a long list todo - need to reduce based on usability and applicability - all lisp2lisp to be reduced in priority (mackonstan, 14:56:14)
    3. : tests descriptions should be sent to csit-dev for review, and to vpp-dev owner if known (mackonstan, 14:59:14)

  9. new vpp test infra framework - status (mackonstan, 15:04:10)
    1. work ongoing on finishing test infra updates and initial test cases https://gerrit.fd.io/r/#/c/3345/ (mackonstan, 15:04:49)
    2. https://gerrit.fd.io/r/#/c/3345/ (mackonstan, 15:04:52)

  10. CSIT HC tests (mackonstan, 15:05:03)
    1. Sam - Honeycomb integration job patch stuck in review in ci-management - need help !! (mackonstan, 15:05:38)
    2. emails already sent to ci-management-dev to no avail (mackonstan, 15:06:03)
    3. Maciek resent them adding Ed and CJ for their direct attention (mackonstan, 15:06:22)
    4. https://gerrit.fd.io/r/3018 (mackonstan, 15:06:30)


Meeting ended at 15:06:33 UTC (full logs).

Action items

  1. Maciek and Dave to raise issue of having VPP Release Manager attend CSIT weekly meeting to share 17.01 VPP milestone status and/or changes.


People present (lines said)

  1. mackonstan (42)
  2. collabot (4)
  3. dwallacelf (3)
  4. pmikus (1)


Generated by MeetBot 0.1.4.