14:00:46 <mackonstan> #startmeeting csit weekly 161026
14:00:46 <collabot> Meeting started Wed Oct 26 14:00:46 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:46 <collabot> The meeting name has been set to 'csit_weekly_161026'
14:00:55 <mackonstan> #chair mackonstan
14:00:55 <collabot> Current chairs: mackonstan
14:03:25 <mackonstan> #topic: Inputs from FD.io projects - VPP
14:04:09 <mackonstan> #info Damjan providing update - new features: snat, security groups
14:12:51 <mackonstan> #info Maciek, Dave proposal - use the new make test infra, once merged with initial baseline tests, to execute per patch verify jobs for functional tests.
14:13:35 <mackonstan> #info use that as a main functional verification test framework going framework, incl. as an acceptance criteria for any new VPP node code
14:21:30 <mackonstan> #info Dave Wallace and Jan Gelety to provide oversight of make test framework and tests, and updates on vpp and csit calls
14:22:01 <mackonstan> #info Dave Wallace and Jan Gelety also agreed to review all patches into vpp make test, and +1 once kosher
14:24:14 <mackonstan> #topic DPDK+VPP focused pre-integration testing.
14:24:51 <mackonstan> #info some work in the background - some progress.
14:24:59 <mackonstan> #topic TLDK - no update.
14:25:33 <mackonstan> #topic FD.io CSIT operational status - VIRL testing jobs - csit-vpp, vpp-csit.
14:26:30 <mackonstan> #info issues with vpp restart - brute force solution - https://gerrit.fd.io/r/#/c/3572/
14:27:36 <mackonstan> #info 3572 is short-term and going into csit oper branch now
14:30:18 <mackonstan> #info proper fix is to increase http://dut_setup.sh/ execution timeout to 100s +
14:31:39 <mackonstan> #info this is due to as of ubuntu16.04 we're using systemd to drive vpp restart, and systemd has 90sec timeout
14:31:59 <jgelety> #info brute force solution cherry-picked to oper-161024 branch: https://gerrit.fd.io/r/#/c/3598/
14:41:11 <mackonstan> #topic Perf testing jobs - csit-vpp, vpp-csit.
14:42:16 <mackonstan> #info Jan reporting occasionally qemu report error after parsing output of /proc/memory for hugepages variables
14:48:19 <mackonstan> #topic Performance tests
14:48:40 <mackonstan> #info dpdk rls baseline - work in progress
14:50:34 <mackonstan> #info trending baseline tests - https://jenkins.fd.io/view/csit/job/csit-vpp-perf-master-long/plot/RFC2544%3ANDR/
14:52:12 <mackonstan> #info multi-core - non-repeatable results - needs investigation - Peter, Maciek to lead, all others to chip in
14:54:51 <mackonstan> #topic Functional tests - vpp make test framework
15:00:17 <mackonstan> #info initial test infra and sample test cases patches - to be merged after rebase and code-review
15:00:22 <mackonstan> #link https://gerrit.fd.io/r/#/c/3345/
15:00:30 <mackonstan> #info Functional tests - csit virl
15:00:41 <mackonstan> #topic Functional tests - csit virl
15:01:38 <mackonstan> #info all tests that need driver functionality stay in csit virl functional e.g. vhost, SPAN, dpdk, af_packet, tuntap.
15:03:15 <mackonstan> #info need to update jira
15:04:02 <mackonstan> #topic CSIT HC tests
15:05:18 <mackonstan> #info Samuel relaying request from OPNFV/FDS team to test HC+VPP running on Centos
15:06:36 <mackonstan> #info this requires onboarding of Centos 7.2 into VIRL, so that HC CSIT tests described at links below can be executed in the environment desired for FDS
15:06:51 <mackonstan> #link https://wiki.fd.io/view/CSIT/Honeycomb/Summary
15:07:35 <mackonstan> #action Samuel to email description to csit-dev of what's needed from VIRL Centos VM to conduct HC tests
15:08:00 <mackonstan> #info let's cover it from now on as part of HC project update at the beginning of csit calls
15:08:20 <mackonstan> #endmeeting