#fdio-csit: csit weekly 161109

Meeting started by mackonstan at 15:00:37 UTC (full logs).

Meeting summary

  1. : agenda bashing (mackonstan, 15:00:59)
  2. Inputs from FD.io projects - vpp (mackonstan, 15:03:39)
    1. Dave Wallace (dwallacelf, 15:04:19)
    2. vhost test requirements discussion in email thread: "[vpp-dev] [csit-dev] vHost user test scenarios for CSIT" (mackonstan, 15:04:55)
    3. vhost tests today in perf testbed are with testpmd in ubuntu1604 guest, and in virl testbed with linux-bridge in ubuntu1604 guest. (mackonstan, 15:07:00)
    4. Tom Herbert (tfherbert, 15:07:04)
    5. integrating vpp make test into verify jobs (mackonstan, 15:12:06)
    6. https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-* jobs to using 'make test' (which also builds vpp-lite) (mackonstan, 15:12:22)
    7. https://gerrit.fd.io/r/#/c/3737 - renames vpp-lite-* jobs to vpp-test-* jobs (mackonstan, 15:12:32)
    8. need to test drive this properly (mackonstan, 15:12:53)

  3. HoneyComb (mackonstan, 15:13:35)
    1. no update (mackonstan, 15:13:58)
    2. waiting for CentOS in VIRL testbed (mackonstan, 15:14:10)

  4. Peter - few patches (mackonstan, 15:15:11)
    1. https://gerrit.fd.io/r/#/c/3620/ (mackonstan, 15:15:18)
    2. https://gerrit.fd.io/r/#/c/3743/ (mackonstan, 15:15:25)

  5. DPDK+VPP focused pre-integration testing (mackonstan, 15:16:01)
    1. no update (mackonstan, 15:16:40)
    2. expecting commit from Anna, Waterman this week (mackonstan, 15:16:52)

  6. TLDK (mackonstan, 15:16:57)
    1. two blocker issues in Jira (mackonstan, 15:17:06)

  7. FD.io CSIT operational status (mackonstan, 15:19:31)
    1. would be good to split trend graphs and make them less crowded (mackonstan, 15:22:38)

  8. Test environment infra topics (mackonstan, 15:24:49)
    1. Adding Centos - func VIRL, perf phy testbeds, https://wiki.fd.io/view/CSIT/CSIT_Update_Testbed (mackonstan, 15:25:35)
    2. https://wiki.fd.io/view/CSIT/CSIT_Update_Testbed (mackonstan, 15:26:19)
    3. CSIT Testbeds - Adding CentOS - version to be decided based on vpp users with CentOS - currently mainly (only?) OPNFV/FDS, hence requirement for CentOS Linux release 7.2.1511 (Core) (mackonstan, 15:34:26)
    4. ACTION: Maciek to clarify with OPNFV/FDS situation re vhost reconnect (mackonstan, 15:36:56)
    5. CSIT VIRL Testbed (mackonstan, 15:37:43)
    6. ACTION: tfherbert, dwallacelf - Create CentOS VIRL image (CSIT) (mackonstan, 15:38:20)
    7. dwallacelf to provide pointerst to CSIT TOI sessions (mackonstan, 15:38:55)
    8. ACTION: tfherbert, edwarnicke - Create new set of verify jobs with CentOS executor (CI-MAN) (mackonstan, 15:40:52)
    9. ACTION: tfherbert, pmikus - Create CentOS bootstrap script (CSIT) (mackonstan, 15:42:47)
    10. Verify CSIT Framework - then it's integration time … (mackonstan, 15:43:56)

  9. Performance tests (mackonstan, 15:46:37)
  10. vhost-user - test requirements (mackonstan, 15:47:31)
    1. Tom - still collecting feedback from ovscon (mackonstan, 15:47:42)
    2. Tom - proposal to see if it makes sense to integrate OPNFV/VSPERF tests into CSIT .. or the other way round … to be followed up (mackonstan, 15:50:10)

  11. Performance tests (mackonstan, 15:51:27)
    1. dpdk rls baseline - dpdk16.11rc1 tests started (mackonstan, 15:53:16)

  12. - generating online docs - sphinx, RF (mackonstan, 15:53:51)
    1. - Tibor to send sphinx auto-generated sample (mackonstan, 15:57:52)

  13. Functional tests - vpp make test framework (mackonstan, 15:59:57)
    1. user guide now available (mackonstan, 16:00:11)
    2. https://git.fd.io/cgit/vpp/tree/test/doc/index.rst (mackonstan, 16:00:24)
    3. integrating vpp make test into verify jobs (mackonstan, 16:00:46)
    4. ewarnicke - patches proposed to run them for ubuntu and centos (mackonstan, 16:01:24)
    5. irc://barjavel.freenode.net:6697/#link https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-* jobs to using 'make test' (which also builds vpp-lite) (mackonstan, 16:01:33)
    6. https://gerrit.fd.io/r/#/c/3736 - transitions the vpp-lite-* jobs to using 'make test' (which also builds vpp-lite) (mackonstan, 16:01:57)
    7. https://gerrit.fd.io/r/#/c/3737 - renames vpp-lite-* jobs to vpp-test-* jobs (mackonstan, 16:02:10)
    8. dwallacelf, mackonstan - create a new wiki page describing the e2e vpp test architecture, covering vpp make test, csit virl, cist perf physical testbed (mackonstan, 16:03:44)

  14. Functional tests - csit virl (mackonstan, 16:04:05)
    1. all action in jira (mackonstan, 16:04:13)

  15. CSIT HC tests (mackonstan, 16:04:37)
    1. no updates (mackonstan, 16:05:03)


Meeting ended at 16:09:42 UTC (full logs).

Action items

  1. Maciek to clarify with OPNFV/FDS situation re vhost reconnect
  2. tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
  3. tfherbert, edwarnicke - Create new set of verify jobs with CentOS executor (CI-MAN)
  4. tfherbert, pmikus - Create CentOS bootstrap script (CSIT)


Action items, by person

  1. dwallacelf
    1. tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
  2. tfherbert
    1. tfherbert, dwallacelf - Create CentOS VIRL image (CSIT)
    2. tfherbert, edwarnicke - Create new set of verify jobs with CentOS executor (CI-MAN)
    3. tfherbert, pmikus - Create CentOS bootstrap script (CSIT)


People present (lines said)

  1. mackonstan (57)
  2. collabot` (4)
  3. tfherbert (1)
  4. dwallacelf (1)


Generated by MeetBot 0.1.4.