14:59:21 <mackonstan> #startmeeting csit weekly 161123
14:59:21 <collabot`> Meeting started Wed Nov 23 14:59:21 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:21 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:21 <collabot`> The meeting name has been set to 'csit_weekly_161123'
14:59:30 <mackonstan> #chair mackonstan
14:59:30 <collabot`> Current chairs: mackonstan
15:01:52 <jgelety> #info jgelety = Jan Gelety
15:02:32 <pmikus> #info Peter Mikus
15:02:35 <mackonstan> #topic Inputs from FD.io projects
15:02:46 <mackonstan> #topic VPP
15:03:39 <mackonstan> #info no updates, apart from progressing with adding vpp make test into verify job
15:03:46 <mackonstan> #topic HC
15:04:47 <mackonstan> #info HC split into projects: i) the generic agent part (Honeycomb), ii) vpp use case (Hc2vpp)
15:05:36 <mackonstan> #topic DPDK perf baseline pre VPP integration
15:06:34 <mackonstan> #info no update. ETA is still unknown..
15:06:47 <mackonstan> #topic TLDK
15:06:59 <mackonstan> #info no update
15:07:16 <mackonstan> #topic vppsb
15:09:02 <mackonstan> #info Pierre posted script to auto configure and test vhost environment
15:09:10 <mackonstan> #info vppsb/vhost-test$ ls conf.sh.default  README.md  vhost.sh
15:09:42 <mackonstan> #info may be relevant to csit vhost use case discussion
15:10:04 <tfherbert> #info +1
15:11:14 <mackonstan> #topic FD.io CSIT operational status
15:12:47 <mackonstan> #info Peter reported LF infra glitch this morning CET time, but fixed now
15:13:47 <mackonstan> #info Jan still observing connectivity issues to Jenkins slaves - #ticket?
15:15:42 <mackonstan> #info oper-161120 branch operational for vpp-csit-verify jobs
15:16:05 <mackonstan> #topic Test environment infra topics
15:16:31 <jgelety> #info connectivity issue ticket: FD.io Helpdesk #32787
15:16:37 <mackonstan> #topic vhost NDR results still low per csit1609 report note - need to address CPU jitter
15:17:48 <mackonstan> #info Peter working on applying kernel CFS parameters to CSIT vhost code for perf testbeds
15:18:27 <mackonstan> #info currently observing issues with getting it working reliably with vpp worker threads
15:18:46 <mackonstan> #topic Adding Centos - func VIRL
15:19:34 <mackonstan> #info Thomas - centos7.1 image build done
15:20:29 <mackonstan> #link https://gerrit.fd.io/r/#/c/3860/
15:22:38 <mackonstan> #info pls add Dave Wallace, Carsten Koster, Peter Mikus, Jan Gelety as reviewers to the patch
15:27:08 <mackonstan> #topic Performance tests
15:27:38 <mackonstan> #topic dpdk rls baseline - with testpmd
15:28:12 <mackonstan> #info Anna is splitting the current giantic patch with testpmd+tldk+.., into separate ones
15:30:28 <mackonstan> #topic trending baseline tests  - one-core, multi-core
15:30:53 <mackonstan> #action Tibor and Maciek - prepare an analysis report for next call
15:31:31 <mackonstan> #topic quad-loop code on ip4-lookup
15:32:12 <mackonstan> #info work in progress by Tibor
15:32:25 <mackonstan> #topic online documentation
15:33:18 <mackonstan> #info sphinx generates static html
15:33:36 <mackonstan> #action Maciek/mackonstan to ping Ed Warnicke to find home for it
15:34:28 <mackonstan> #topic Functional tests - vpp make test framework
15:34:55 <mackonstan> #topic integrating vpp make test into verify jobs
15:35:15 <mackonstan> #info need to confirm when and how they're getting integrated
15:35:30 <mackonstan> #action Maciek/mackonstan to check with Ed and Damjan
15:36:26 <mackonstan> #topic auto-generating online docs - sphinx - in place
15:36:43 <mackonstan> #info posting on LF FD.io VPP project site - need to find out logistics
15:37:02 <mackonstan> #action Maciek/mackonstan to check with Ed and find home for it
15:37:17 <mackonstan> #topic vhost use cases - see thread on csit-dev
15:40:21 <mackonstan> #info Thomas - some comments apply to long-term and some can be done now
15:40:59 <mackonstan> #action Maciek to start the compilation based on email thread inputs
15:41:10 <mackonstan> #action Thomas, Maciek - let's convert it then into the documented use cases and then followed by test cases - and track it on fd.io csit wiki
15:41:31 <mackonstan> #topic Functional tests - csit virl
15:45:12 <mackonstan> #HoneyComb tests
15:45:18 <mackonstan> #topic HoneyComb tests
15:45:29 <mackonstan> #info already testing in Ubuntu
15:45:49 <mackonstan> #info need to run them on Centos to align with OPNFV/FDS use cases
15:47:52 <mackonstan> #info would be good to get a jira link to filter showing HC test dev progress
15:49:41 <mackonstan> #endmeeting