15:00:52 <mackonstan> #startmeeting csit weekly 161221
15:00:52 <collabot> Meeting started Wed Dec 21 15:00:52 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:52 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:52 <collabot> The meeting name has been set to 'csit_weekly_161221'
15:00:57 <mackonstan> #chair mackonstan
15:00:58 <collabot> Current chairs: mackonstan
15:01:14 <mackonstan> #topic Agenda bashing
15:02:12 <jgelety1> #info Jan Gelety
15:02:19 <pmikus> #info Peter Mikus
15:02:51 <mklotton1> #info Matej Klotton
15:10:14 <mackonstan> #topic Inputs from FD.io projects
15:10:25 <mackonstan> #topic vpp
15:10:38 <mackonstan> #topic HoneyComb
15:10:52 <mackonstan> #topic TLDK
15:12:36 <mackonstan> #info pmikus - reviews done, bootstraps merged, perf tests looking good +1ed, missing the actual job. pmikus to send status summary, highlight open action re jjb definition.
15:13:01 <mackonstan> #topic dpdk-testpmd separate test - same status as for TLDK.
15:13:18 <mackonstan> #info pmikus - dpdk-testpmd separate test - same status as for TLDK.
15:13:37 <mackonstan> #topic TSC - Sending embassies to neighboring projects CSITs
15:15:42 <mackonstan> #topic Request for CSIT to share an update on the CSIT activities and what your priorities are from CSIT perspective for 2017
15:18:23 <mackonstan> #info mackonstan - will work on CSIT readout for LF board, will have draft for review on the csit weekly call in January
15:18:48 <mackonstan> #info mackonstan - request to confirm the level of IT support in place for csit perf lab setup
15:21:58 <mackonstan> #topic FD.io CSIT operational status
15:24:41 <mackonstan> #info most if not all vpp-csit-verify-virl jobs failing today due to infra issues …
15:25:53 <mackonstan> #info edwarnicke - issue with image building subsystem - fix applied at 14:50 utc:
15:26:16 <edwarnicke> #link https://gerrit.fd.io/r/#/c/4451/ <- CSIT image fix
15:26:21 <edwarnicke> #undo
15:26:35 <edwarnicke> #link https://gerrit.fd.io/r/#/c/4451/ <- Jenkins image fix
15:27:02 <mackonstan> #topic vpp1701 and csit1701 readiness
15:35:42 <mackonstan> #topic CSIT proposed actions:
15:36:17 <mackonstan> #info stick to using csit master branch to test vpp stable/1701, create csit stable/1701 in January
15:38:44 <mackonstan> #topic csit1701 release plan
15:40:47 <mackonstan> #topic deliverables:
15:41:06 <mackonstan> #info generic: csit-perf, csit-func, contributions to vpp-make-test, csit bug fixes, sphinx rtd docs
15:41:26 <mackonstan> #info specific perf: more NICs, vhost, crypto-SW, crypto-HW(?), dpdk16.11 testpmd standalone, TLDK(?)
15:41:40 <mackonstan> #info specific func virl: crypto, NAT, SPAN, IPFIX, CentOS
15:42:12 <mackonstan> #info sgmonroy - crypto test update - some delay, but code should be published in gerrit today 21-Dec
15:46:45 <mackonstan> #action mackonstan - send email to LF infra team (Konstantiin) to request crypto HW card placement in fd.io csit performance testbed tb3.
15:49:24 <mackonstan> #topic Test environment infra topics
15:49:38 <mackonstan> #topic vhost NDR results still low per csit1609 report note - CPU jitter fixes with CFS settings - status
15:49:58 <mackonstan> #info - pmikus - all work completed, and trending graphs are reflecting thput perf as per manual tests
15:50:41 <mackonstan> #topic Adding Centos - func VIRL
15:51:16 <mackonstan> #info dwallacelf, pmikus - thferbert reported on vpp call yday that this is still wip. no known blockers. eta is tbc.
15:51:34 <mackonstan> #topic optimizing VPP environment build infrastructure for testing
15:52:05 <mackonstan> #info consider using a shared Packer infra for CSIT, VPP, ci-management projects
15:55:39 <mackonstan> #action dwallacelf - make a proposal for a shared Packer infra
15:57:51 <mackonstan> #topic Performance tests
15:58:26 <mackonstan> #topic trending baseline tests - one-core, multi-core
15:58:34 <mackonstan> #info 	•	trending plots must be cleaned up as current plugin generated views are impossible to read
15:58:54 <mackonstan> #info edwarnicke - great if individual graphs linked via specific urls
15:59:03 <edwarnicke> mackonstan: Many thanks :)
16:08:42 <mackonstan> #topic vhost use cases
16:09:05 <mackonstan> #info mackonstan - wiki page updated with proposed list of priority vhost test cases
16:09:13 <mackonstan> #link https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios
16:09:35 <mackonstan> #info mackonstan - note this is still work in progress, as more discussion is taking place on csit-dev thread
16:09:44 <mackonstan> #link https://lists.fd.io/pipermail/csit-dev/2016-November/001192.html
16:11:12 <mackonstan> #link https://lists.fd.io/pipermail/csit-dev/2016-December/001274.html
16:12:16 <mackonstan> #topic CSIT perf test case renaming proposal to align with use cases
16:13:33 <mackonstan> #info mackonstan - proposal to normalize naming for all csit perf and functional test cases, driven by growing number of test cases and test topology combinations, including vhost use cases per fd.io csit consultation
16:14:19 <mackonstan> #info - idea is to encode test topologies and functions using tree notation with physical ports and NIC on the left (underlay), followed by outer most frame header, then other stacked headers up to the header processed by vSwitch-VPP, then VPP forwarding function, then encap on vhost interface, number of vhost interfaces, number of VMs.
16:14:33 <mackonstan> #info see description at the wiki link below
16:14:40 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change
16:15:49 <mackonstan> #info gerrit patch tracking this is #3856
16:15:52 <mackonstan> #link https://gerrit.fd.io/r/#/c/3856/
16:16:58 <mackonstan> #topic next csit call 4-Jan-2017 - skipping next week as most people offline during Xmas and NY week.
16:17:13 <mackonstan> #info Happy Christmas and Happy New Year to Everyone !
16:17:17 <mackonstan> #endmeeting