15:05:24 <mackonstan> #startmeeting csit weekly 170111
15:05:24 <collabot> Meeting started Wed Jan 11 15:05:24 2017 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:24 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:24 <collabot> The meeting name has been set to 'csit_weekly_170111'
15:05:27 <dwallacelf> #info Dave Wallace
15:05:30 <jgelety> #info Jan Gelety
15:05:32 <mackonstan> #chair mackonstan
15:05:32 <collabot> Current chairs: mackonstan
15:05:38 <selias> #info Samuel Elias
15:05:40 <sgmonroy> #info Sergio Gonzalez Monroy
15:05:56 <tifrank> #info Tibor Frank
15:06:01 <tfherbert> #info Tom Herbert
15:07:13 <mackonstan> #topic VPP project inputs
15:08:16 <mackonstan> #info new email thread to resolve issue with inclusion of cryptodev libraries in csit
15:10:56 <mackonstan> #info Sergio, Damjan, Jan+Peter - drive this to conclusion
15:13:06 <mackonstan> #info VPP17.01 on target for rls on 18-Jan.
15:13:22 <mackonstan> #topic HoneyComb inputs
15:13:25 <mackonstan> #info no inputs
15:13:35 <mackonstan> #topic TLDK
15:15:09 <mackonstan> #info no inputs on a call - mackonstan to ask ray kinsella to provide summary readout
15:16:04 <mackonstan> #topic FD.io CSIT operational status
15:16:42 <mackonstan> #info all good
15:16:51 <mackonstan> #topic vpp1701 and csit1701 readiness
15:19:06 <mackonstan> #topic DPDK CryptoDev - csit-perf, csit-func - dependency on incl. external libraries
15:20:05 <mackonstan> #topic SNAT44 - make test - need to check if there, or remove.
15:20:36 <mackonstan> #topic DPDK16.11 standalone - testpmd tests are running on x520 - remove "?" :)
15:21:25 <mackonstan> #topic SPAN?
15:21:38 <mackonstan> #action jgelety - to check status in csit-virl
15:21:47 <mackonstan> #topic IPFIX?
15:21:56 <mackonstan> #action  jgelety - to check status in csit-virl
15:22:09 <mackonstan> #topic Centos tests
15:23:02 <tfherbert> #info Submitted ci-man patch new series.
15:23:19 <tfherbert> #info working on csit patch for parallel repositories for centos.
15:28:34 <mackonstan> #topic csit branch creation: rls1701, use this gerrit patch
15:28:41 <mackonstan> #link https://gerrit.fd.io/r/#/c/4448/
15:29:04 <mackonstan> #topic csit1701 report data
15:30:49 <mackonstan> #info use Peter's script to generate the report
15:32:26 <mackonstan> #topic Test environment infra topics
15:32:59 <tfherbert> #info next series of ci-man patch waiting for review. -- Fin al step working on csit patch to access parallel nexus repo to ubuntu for centos as recommended by Jan. Not sure of Nexus repo name for Centos.
15:32:59 <mackonstan> #topic Adding Centos - func VIRL - Thomas F. Herbert
15:36:23 <tfherbert> #info I took out wekly doc verify job from ci-man patch based on Jan's review for now.
15:36:36 <tfherbert> #info is that a new ci-man patch then?
15:37:18 <tfherbert> #nfo don't understand why separate branch is needed?
15:38:37 <mackonstan> #info +1 - don't think we need a separate csit branch
15:39:46 <tfherbert> #info Need help understanding how to implement meta-test as described by Dave?
15:40:10 <tfherbert> #action can we work this out offline.
15:43:03 <mackonstan> #topic CSIT test case renaming proposal to align with use cases
15:43:17 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change
15:43:44 <mackonstan> #topic Performance tests - adding cryptodev tests: ip4 - onboarding wip
15:44:17 <mackonstan> #info Sergio - current results look bogus - likely due to broken build process i.e. no inclusion of external libraries
15:45:52 <mackonstan> #action sgmonroy, Peter, Kirill, Maciek - connect offline to clarify the status, and work out resolution
15:46:24 <mackonstan> #topic DPDK perf baseline in CSIT - testpmd in host user-mode
15:46:44 <mackonstan> #info  DPDK16.11 standalone - testpmd tests are running on x520
15:46:53 <mackonstan> #info need to add xl710
15:47:07 <mackonstan> #info and add other nics - x710, vic1227, vic1385
15:47:27 <mackonstan> #action Peter, testpmd team (Anna)
15:48:13 <mackonstan> #topic online docs
15:48:36 <mackonstan> #info posting on LF FD.io CSIT project site - need to posted to nexus, gerrit patch for ci-mgmt in place
15:48:46 <tifrank> #link https://gerrit.fd.io/r/#/c/4598/
15:48:49 <mackonstan> #action edwrnicke - to merge this patch
15:49:08 <mackonstan> #action edwarnicke - pls merge this patch https://gerrit.fd.io/r/#/c/4598/
15:49:39 <mackonstan> #topic new csit-perf tests
15:49:49 <mackonstan> #info vxlan, vxlan-vhost tests
15:50:51 <mackonstan> #topic Functional tests - csit virl
15:51:07 <tifrank> 10ge2p1x520-ethip4vxlan-l2bdbasemaclrn-eth-2vhost-1vm-ndrdisc.robot - https://gerrit.fd.io/r/#/c/4570/
15:51:16 <mackonstan> #info vxlan+l2bd, vxlan-vhost tests
15:51:24 <jgelety> #link https://gerrit.fd.io/r/#/c/4603/
15:51:32 <tifrank> 10ge2p1x520-ethip4vxlan-l2bdbasemaclrn-ndrdisc.robot - https://gerrit.fd.io/r/#/c/4510/
15:55:04 <mackonstan> #topic CSIT test case renaming proposal to align with use cases
15:55:31 <mackonstan> #info agreed to update just filenames, no splitting of TCs into separate files
15:55:40 <mackonstan> #info in csit1701 report include full mapping
15:55:58 <mackonstan> #info update the wiki to reflect that: https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change
15:56:01 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit-perf-tc-naming-change
15:56:15 <mackonstan> #action jgelety, mackonstan - to execute this ASAP
15:56:30 <mackonstan> #topic Use case tests
15:57:10 <mackonstan> #info top-level use cases added as new TCs into csit-func virl and csit-perf
15:57:30 <mackonstan> #info need to work on the next set of TCs with contributors to vhost use case discussion and csit
15:58:07 <mackonstan> #topic Functional tests - vpp make test framework
15:59:02 <mackonstan> #info still not part of vpp verify job
15:59:11 <mackonstan> #info and it was not discussed on vpp call yday :(
16:01:31 <mackonstan> #topic vhost use cases
16:01:50 <mackonstan> #info finalize the consensus on vhost test cases
16:02:01 <mackonstan> #info https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios
16:02:07 <mackonstan> #info complete the review on email thread
16:02:23 <mackonstan> #info translate agreed vhost TCs into csit jira
16:02:41 <mackonstan> #action mackonstan ping into email thread - refer to wiki link
16:02:46 <tfherbert> #info +1 on Jira
16:03:26 <mackonstan> #topic Centos next steps
16:04:02 <tfherbert> #action We have agreement on pursuing discusion on next steps in email.
16:04:15 <mackonstan> #info tfherbert to provide inputs in irc or email to csit-dev
16:04:24 <mackonstan> #endmeeting