#fdio-csit: 13-Sep FD.io CSIT Project Meeting

Meeting started by mackonstan1 at 14:03:30 UTC (full logs).

Meeting summary

    1. Samuel Elias (selias, 14:03:38)
    2. Dave Wallace (dwallacelf, 14:03:39)

  1. agenda bashing (mackonstan1, 14:03:51)
    1. Peter Mikus (pmikus1, 14:03:53)
    2. Tom Herbert (tfherbert, 14:03:57)

  2. Inputs from LF and FD.io projects (mackonstan1, 14:06:00)
    1. vpp F0 rls date today (mackonstan1, 14:06:49)
    2. goVPP - Peter reporting - demo working with FDio goVPP, Ligato vnf_agent, Ligato SFC_controller, Kubernetes (mackonstan1, 14:08:00)
    3. https://github.com/ligato/vpp-agent/tree/master/k8s/perf-demo (mackonstan1, 14:08:40)
    4. VPP project: reporting higher than expected number of rechecks in gerrit (mackonstan1, 14:09:30)
    5. Dave reporting - most rechecks root caused to failing make test l2 tests - these have been now disabled (mackonstan1, 14:10:58)
    6. Dave reporting - it appears there are less rechecks now, but not enough data to tell it for sure (mackonstan1, 14:11:18)

  3. operational status (mackonstan1, 14:11:34)
    1. no issues reported (mackonstan1, 14:11:51)
    2. agenda item "TO-BE-CLOSED - VIRL ssh timeout issues" - to be deleted, hopefully forever :) (mackonstan1, 14:12:33)

  4. CSIT project committer voting based on merit (mackonstan1, 14:13:00)
    1. ACTION: - it's for PTL - so Maciek is the party here (mackonstan1, 14:13:30)

  5. rls1707 experience (mackonstan1, 14:14:00)
    1. re Reported VPP Performance drop from 17.04 to 17.07 for l2bd-2vhost-1vm (mackonstan1, 14:28:47)
    2. csit recommendation and report reviewed on this call (mackonstan1, 14:29:02)
    3. email sent by Maciek (mackonstan1, 14:29:07)
    4. https://lists.fd.io/pipermail/csit-dev/2017-September/002218.html (mackonstan1, 14:30:34)

  6. rls1710 plan (mackonstan1, 14:35:25)
    1. https://wiki.fd.io/view/CSIT/csit1710_plan (mackonstan1, 14:35:31)
    2. need to decide when to pull csit 1710 branch for vpp RC testing - at RC1 time or RC2 time … currently aligned with RC2 time on 2017-10-11 (mackonstan1, 14:36:09)

  7. CSIT Presentation and Analytics Layer (PAL) (mackonstan1, 14:36:27)
    1. Tibor updating - PAL code status (mackonstan1, 14:38:02)
    2. Presentation - lots of work to generate tables, graphs and the overall report in a flexible manner (mackonstan1, 14:38:30)
    3. Analytics - currently very simple - calculating mean value and stdev (mackonstan1, 14:38:54)
    4. [Intel] l2fwd-cryptodev baseline/nsh_sfc - no update (mackonstan1, 14:41:49)
    5. ACTION: Maciek - ping csit-dev and vpp-dev dpdk cryptodev contacts for update (mackonstan1, 14:42:23)
    6. memif/container - Peter providing status (mackonstan1, 14:44:41)
    7. Peter - hoping to have initial memif results with docker+kubernetes+ligato+govpp in time for csit rls1710. main dependency is building docker images for csit (mackonstan1, 14:45:41)
    8. ACTION: Maciek, Peter - to driver a sustainable cross-project approach with FD.io goVPP team and github/ligato team (mackonstan1, 14:46:15)

  8. VPP functional tests - virl (mackonstan1, 14:46:33)
    1. Honeycomb functional tests - control plane interfaces over IPv6 - in review, next up - BGP (selias, 14:53:09)
    2. Honeycomb performance tests - no updates (selias, 14:53:20)


Meeting ended at 13:53:01 UTC (full logs).

Action items

  1. - it's for PTL - so Maciek is the party here
  2. Maciek - ping csit-dev and vpp-dev dpdk cryptodev contacts for update
  3. Maciek, Peter - to driver a sustainable cross-project approach with FD.io goVPP team and github/ligato team


People present (lines said)

  1. mackonstan1 (34)
  2. selias (4)
  3. collabot (4)
  4. mackonstan (2)
  5. tfherbert (1)
  6. dwallacelf (1)
  7. pmikus1 (1)
  8. tifrank (1)


Generated by MeetBot 0.1.4.