#fdio-csit: 20-Sep FD.io CSIT Project Meeting

Meeting started by mackonstan at 14:06:46 UTC (full logs).

Meeting summary

    1. Jan Gelety (jgelety, 14:07:09)
    2. Tom Herbert (tfherbert, 14:07:34)
    3. Peter Mikus (pmikus1, 14:08:19)

  1. agenda bashing (mackonstan, 14:08:36)
  2. Inputs from LF and FD.io projects: VPP (mackonstan, 14:09:00)
    1. no updates (mackonstan, 14:09:32)
    2. TLDK, NSH_SFC - status to be verified by mackonstan with contributors (mackonstan, 14:10:24)
    3. goVPP - csit will be using as part of ligato integration (mackonstan, 14:11:55)
    4. need to understand the go-lang bindings coverage of VPP APIs (mackonstan, 14:12:30)

  3. vpp high number of rechecks (mackonstan, 14:13:25)
    1. Dave reporting - Vanessa is assisting to further reduce the underlying issues by changing VM flavours to address I/O problems. (mackonstan, 14:14:19)

  4. operational status (mackonstan, 14:14:48)
    1. no issues with infra (mackonstan, 14:14:57)
    2. Peter reporting LXC and memif tests failing due to vpp crash, bisecting (mackonstan, 14:15:49)
    3. ACTION: mackonstan - facilitate csit committer voting (mackonstan, 14:16:29)

  5. l2fib with mac scale performance regression (mackonstan, 14:17:44)
    1. LXC/memif tast crashing due to commit b467b2a02be6ea7bab1a4773523afe8a8e3cfd83 (Jubmo frames implementation in Memif) (pmikus1, 14:18:09)
    2. following csit recommendation last week, vpp-dev released 17.07.01 incl. the fix (mackonstan, 14:18:59)
    3. TFH will update once things retested by RHEL team (mackonstan, 14:19:17)

  6. rls1710 plan (mackonstan, 14:19:29)
    1. https://wiki.fd.io/view/CSIT/csit1710_plan (mackonstan, 14:19:50)
    2. SRv6 performance - KWs HLDs and task list now in Jira, thanks to Tibor (mackonstan, 14:21:12)
    3. The lists are in the "description" part of new sub-tasks: - CSIT-816: Create L1 keywords - https://jira.fd.io/browse/CSIT-816 - CSIT-817: Create L2 keywords - https://jira.fd.io/browse/CSIT-817 - CSIT-818: Create traffic profiles - https://jira.fd.io/browse/CSIT-818 (tifrank_, 14:21:35)

  7. Centos7 VIRL tests (mackonstan, 14:23:25)
    1. TFH reporting - hoping to make progress with the new nested VM image (mackonstan, 14:23:43)
    2. Updated Nested VM refresh: https://gerrit.fd.io/r/#/c/8018/, ready for testing (pmikus1, 14:24:55)

  8. CSIT Presentation and Analytics Layer (PAL) (mackonstan, 14:25:48)
    1. Tibor: almost everything is coded, re-checking references, expecting 1st dry run report to be auto-gen'ed tomorrow (mackonstan, 14:26:38)

  9. Performance tests (mackonstan, 14:28:23)
  10. vnf-agent integration (mackonstan, 14:29:49)
    1. pmikus1 reporting: LLD posted, in coding (mackonstan, 14:30:10)

  11. VPP functional tests - virl (mackonstan, 14:31:02)
    1. VNF-agent (container lifecycle integration) LLD https://gerrit.fd.io/r/#/c/8141/23/docs/report/vpp_performance_tests/containers.rst (pmikus1, 14:31:05)

  12. Honeycomb tests (mackonstan, 14:31:14)
    1. selias: want to test control plane interfaces of HC over IPv6, requires VIRL to have IPv6 enabled (mackonstan, 14:32:42)

  13. Test environment updates (mackonstan, 14:34:46)
    1. NestedVM refresh (mackonstan, 14:35:11)
    2. https://gerrit.fd.io/r/#/c/8018/ (mackonstan, 14:35:19)

  14. VIRL platform (mackonstan, 14:35:34)
  15. design optimizations (mackonstan, 14:36:22)


Meeting ended at 14:36:47 UTC (full logs).

Action items

  1. mackonstan - facilitate csit committer voting


Action items, by person

  1. mackonstan
    1. mackonstan - facilitate csit committer voting


People present (lines said)

  1. mackonstan (36)
  2. pmikus1 (4)
  3. collabot (4)
  4. tifrank_ (1)
  5. jgelety (1)
  6. tfherbert (1)


Generated by MeetBot 0.1.4.