14:02:43 <mackonstan> #startmeeting FD.io CSIT project meeting
14:02:43 <collabot> Meeting started Wed Sep  5 14:02:43 2018 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:43 <collabot> The meeting name has been set to 'fd_io_csit_project_meeting'
14:02:46 <jgelety> #info Jan Gelety
14:02:56 <mackonstan> #topic Agenda bashing
14:03:58 <mackonstan> #topic Inputs from LFN and FD.io projects
14:06:23 <mackonstan> #info VPP - Marco updating: cmake updates usage concerns, vpp support for dpdk lts 18.11 and potential impact on CSIT, hyperscan intro into VPP. For detail see notes from VPP call yesterday.
14:06:31 <jlinkes> #info Juraj Linkeš
14:06:31 <pmikus> #info Peter Mikus
14:07:03 <vrpolak> #info Vratko Polak
14:08:07 <mackonstan> #info VPP-18.10 - Marco update - 4 weeks to API freeze
14:10:53 <mackonstan> #info VPP-18.10 plan wiki deliverables to complete by F0
14:10:57 <mackonstan> #link https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_18.10
14:11:47 <mackonstan> #info HC - Michal - switching to new ODL ver, may affect some CSIT tests, should be done next week.
14:12:28 <mackonstan> #topic CSIT operational status
14:16:04 <mackonstan> #info VPP make test failures - Ed updating: i) make test crashing but not stopping - still not fully resolved, some tests still failing on both x86 amd Arm, Juraj working it.
14:19:19 <mackonstan> #info VPP make test failures - Juraj updating: ii) jobs hanging on Arm, Juraj looking at it.
14:20:45 <mackonstan> #info VPP make test failures - Ed updating: iii) make test on ubuntu 18.04 - most tests pass, but some specific tests fail: MPLS , eBGP PIC, ..
14:20:47 <mackonstan> #link https://jenkins.fd.io/sandbox/job/vpp-beta-verify-master-ubuntu1804/
14:22:01 <mackonstan> #topic VPP code performance
14:28:27 <mackonstan> #info Peter: trending jobs taking now >20hrs, proposal to reduce the duration
14:28:38 <mackonstan> #link https://lists.fd.io/g/csit-dev/message/3010
14:33:16 <mackonstan> #info from email: 4 options: 1. Reduce amount of VHOST, 2. Reduce amount of Oacl, Iacl combination, 3. Reduce amount of NICs: x520 only baseline, 4. Decrease cadence of daily to run only once per day.
14:33:43 <mackonstan> #info re 3. same for xl710
14:34:14 <mackonstan> #agree
14:34:28 <mackonstan> #agree to go ahead with points 1,2 and 3.
14:35:45 <mackonstan> #info Tibor: will need to adjust PAL filters for trending pages.
14:39:41 <mackonstan> #info number of perf tests are failing over the last 14 runs
14:39:49 <mackonstan> #link https://docs.fd.io/csit/master/trending/introduction/failures.html
14:40:04 <mackonstan> #info quite a few new cases - need to investigate
14:42:16 <mackonstan> #info Alerting to csit-report mailer, Tibor to work it once Skx testbeds added to trending
14:42:27 <mackonstan> #topic CSIT Releases
14:50:17 <mackonstan> #info CSIT-18.07 known issues - VPP-1361 still being investigated led by Peter
14:51:46 <mackonstan> #info CSIT-18.10 plan wiki page got updated
14:52:27 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1810_plan
14:52:45 <mackonstan> #topic New test environments
14:53:50 <mackonstan> #info VPP_Device 1-Node - Peter: working on resolving issues with Container to PCI mappings
14:54:02 <mackonstan> #info orchestration part is working so far
14:54:16 <mackonstan> #info for detail, see TWS calls
14:54:44 <mackonstan> #link https://wiki.fd.io/view/CSIT/TWS
14:57:34 <mackonstan> #info vpp-csit virl jobs still running but not voting
14:58:12 <mackonstan> #info csit-vpp virl jobs - Vratko - reporting that often vote -1, for no clear reason
14:58:51 <mackonstan> #info take the resolution of this issue to csit-dev
15:02:59 <mackonstan> #topic Performance trending and analytics
15:05:10 <mackonstan> #info Vratko update: waiting to merge patch(es) for moving trending jobs from 1x10sec MRR to 10x1sec MRR tests.
15:05:28 <mackonstan> #topic TRex
15:05:31 <mackonstan> #info no update
15:05:40 <mackonstan> #topic FD.io CSIT lab infrastructure
15:05:59 <mackonstan> #info new Atom Denverton servers - Ray will be updating CSIT lab  design pages with details
15:06:23 <mackonstan> #info HW RMAs - Peter - no updates, apparently they have shipped, but no ETAs.
15:06:27 <mackonstan> #endmeeting