15:04:49 <mackonstan> #startmeeting FD.io CSIT project meeting 31-Oct-2018.
15:04:49 <collabot`> Meeting started Wed Oct 31 15:04:49 2018 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:49 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:49 <collabot`> The meeting name has been set to 'fd_io_csit_project_meeting_31_oct_2018_'
15:04:53 <mackonstan> #chair
15:04:53 <collabot`> Current chairs: mackonstan
15:05:04 <mackonstan> #info comms problem here, recovering.. 2min..
15:05:17 <mackonstan> #info pls type your presence here
15:05:24 <jlinkes> #info Juraj Linkeš
15:05:59 <jgelety> #info Jan Gelety
15:09:01 <tifrank> #info Tibor Frank
15:13:32 <mackonstan> #topic Agenda bashing
15:16:47 <mackonstan> #info Meeting time needs to be pegged at fixed UTC time, or clearly explain the Summer and Winter time dependencies.
15:17:59 <mackonstan> #topic Projects - VPP
15:18:33 <mackonstan> #info @mackonstan provided update to VPP project yday, CSIT-18.10 rls on target so far.
15:18:54 <mackonstan> #topic CSIT operational status
15:19:16 <mackonstan> #info LF infra - @jgelety all good
15:19:36 <mackonstan> #info Jenkins jobs - all clear
15:20:17 <mackonstan> #info Jenkins jobs for CSIT-18.10 performance test data and functional test - @jgelety - all pretty much on target
15:20:29 <mackonstan> #info @jgelety skx are good, hsw are bit behind
15:28:00 <mackonstan> #info @jgelety skx results on target for report release on published date 07-Nov-2018.
15:28:29 <mackonstan> #info @jgelety hsw results later, after >10days from today per tracking sheet <link to be posted>
15:28:54 <mackonstan> #info all on call agreed this is a rational thing to do
15:29:57 <mackonstan> #topic VPP code performance
15:34:23 <mackonstan> #info some scale tests are failing sporadically, @pmikus suspecting a VPP API related issue
15:34:38 <mackonstan> #action @pmikus to open jira ticket for above line
15:34:57 <mackonstan> #topic CSIT Releases
15:35:57 <mackonstan> #info CSIT-18.07 known issues updates - no update
15:36:17 <mackonstan> #topic CSIT-18.10 rls status
15:36:34 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1810_plan
15:41:07 <mackonstan> #info new version at the same link, updated during the call
15:41:13 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit1810_plan
15:41:21 <mackonstan> #info diff at below link
15:41:38 <mackonstan> #link https://wiki.fd.io/index.php?title=CSIT%2Fcsit1810_plan&diff=8576&oldid=8554
15:43:29 <mackonstan> #topic CSIT Developments - New test environments
15:43:52 <mackonstan> #info @pmikus need to move to VPP bionic builds, so far testing xenial builds
15:44:38 <mackonstan> #info only VPP_Device runs on bionic builds, all other incl. skx and hsw testbeds are on xenial
15:46:12 <mackonstan> #info iow xenial using gcc 4.x, bionic using gcc 7.x, so on skx actually we expect vpp source compiled with gcc-7.x to be bit faster (avx-512, few other skx machine language optimizations - not only at x85 assembler level, but also at x86 assember to Intel SKX micro-ops level too).
15:47:43 <mackonstan> #topic Arm env updates from @sirshak
15:47:46 <mackonstan> #info 1. VPP Device: We are waiting on LF/VexxHost to mount the ThunderX2 required with the 3 Intel XL710, this is required for VPP Device.
15:47:57 <mackonstan> #info 2. VPP Path: We are stuck with 3 test case failures(only seen in Cavium ThunderX and Taishan): VPP-1476 VPP-1475 VPP-1478.
15:47:57 <mackonstan> Although we have Lijian looking into it, but he is not experienced with the test suite,
15:47:57 <mackonstan> so would be of great help if anybody in community can help,
15:47:57 <mackonstan> he should be sending a mail to mailing lists, after some investigation of his own.
15:48:09 <mackonstan> #info 3. VPP performance suite: Khem will provide updates on that.
15:48:33 <mackonstan> #info above three lines are facsimile of email from Sirshak
15:49:46 <mackonstan> #info FYI Khem == Khemendra
15:50:02 <mackonstan> #topic Performance trending and analytics
15:50:05 <mackonstan> #info no updates
15:50:17 <mackonstan> #topic New graphs
15:50:52 <mackonstan> #info @tifrank running code updated
15:52:02 <mackonstan> #info draft version of report layout (note: still 18.07 data in graphs), is published here
15:52:13 <mackonstan> #link https://docs.fd.io/csit/master/report/
15:52:47 <mackonstan> #info @tifrank expecting the actual 18.10 data to show up in master draft tomorrow
15:55:50 <mackonstan> #topic TRex
15:55:54 <mackonstan> #info no update
15:56:11 <mackonstan> #topic FD.io CSIT lab infrastructure
15:56:14 <mackonstan> #info no update
15:56:24 <mackonstan> #topic DMM CSIT status
15:56:32 <mackonstan> #info no update
15:57:24 <mackonstan> #info stale CSIT-18.07 data in report… tests ok on 18.10 base
15:57:59 <mackonstan> #topic Housekeeping
15:58:04 <mackonstan> #info no updates
16:00:08 <mackonstan> #action @mackonstan to bring up request for dedicated #slack channel for fdio-csit
16:00:20 <mackonstan> #info bring it up on tomorrow TSC call.
15:35:30 <mackonstan> #endmeeting