14:00:46 <mackonstan> #startmeeting FD.io CSIT project meeting
14:00:46 <collabot`> Meeting started Wed Sep 18 14:00:46 2019 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:46 <collabot`> The meeting name has been set to 'fd_io_csit_project_meeting'
14:00:51 <mackonstan> #chair
14:00:51 <collabot`> Current chairs: mackonstan
14:01:00 <vrpolak> #info Vratko Polak
14:01:13 <tifrank> #info Tibor Frank
14:01:48 <mackonstan> #topic agenda bashing
14:01:55 <dwallacelf> #info Dave Wallace
14:02:28 <jgelety> #info Jan Gelety
14:03:03 <mackonstan> #topic FD.io CSIT physical labs
14:03:41 <mackonstan> #info no issues with Xeon, ARM, Denverton testbed
14:04:54 <mackonstan> #info CLX machines - Peter - onboarded, and ready for service, initial dry run performance tests are running
14:05:33 <mackonstan> #info Peter - will send links to completed jenkins job lobs
14:06:03 <mackonstan> #topic Inputs from LFN and FD.io projects - VPP
14:06:48 <mackonstan> #info Dave - v19.08.1 scheduled to be published
14:07:32 <mackonstan> #info Andrew - centos jobs were failing
14:07:51 <mackonstan> #info Andrew - memif zero-copy is now verifying, and should go in
14:10:28 <mackonstan> #info Andrew - v19.08.1 is special, one patch that changed API checksum, 2nd patch api types confusion also changing API checksum, plan is to put v19.08 artefacts into deferred directory in packagecloud
14:12:17 <mackonstan> #info Andrew - more cherry-picks coming to v19.08.1
14:14:43 <mackonstan> #info Andrew - currently ~100 outstanding master patches to go into stable/1908
14:15:11 <mackonstan> #info Andrew, Dave - how do we go about testing this
14:22:11 <mackonstan> #info Discussion - proposal to run trending jobs on stable/1908
14:25:33 <mackonstan> #action Maciek - propose the frequency of trending jobs on stable/1908, push patch to the job_specs file
14:25:36 <mackonstan> #link https://git.fd.io/csit/tree/docs/job_specs/perf_tests_job_specs.md#n90
14:30:20 <mackonstan> #topic Inputs from LFN and FD.io projects - TSC
14:31:12 <mackonstan> #info Vratko - new webpage approved (conditionally), to be enabled in production soon, Nexus issues to be resolved - Vanessa made a proposal
14:31:31 <mackonstan> #topic Releases
14:32:41 <mackonstan> #info rls1908 latest .38 maintenance version to be published shortly
14:32:51 <mackonstan> #link https://docs.fd.io/csit/rls1908/report/
14:39:14 <mackonstan> #info reconfig tests are experimental and we expect movement with results - to be run by vpp-dev
14:39:23 <mackonstan> #link https://docs.fd.io/csit/rls1908/report/vpp_performance_tests/reconf_tests/vnf_service_chains_reconf.html
14:40:44 <mackonstan> #info open issues - acl perf regression - Andrew looking at it
14:41:13 <mackonstan> #info open issues - acl perf regression - Andrew looking at it, with Vratko confirmed that reverting specific patch brings back the performance
14:41:25 <mackonstan> #info open issues - l2bd regression - OPEN
14:43:16 <mackonstan> #info CSIT-1908.1 report - what tests to run
14:45:40 <mackonstan> #info Maciek - proposal - usual baseline set + memif tests (due to "memif: always enable zero-copy when creating memif using AP"
14:47:11 <mackonstan> #topic CSIT-2001 plan
14:47:57 <mackonstan> #topic Operational status
14:48:41 <mackonstan> #info LF infra - Nexus issues - EdK - IT team/Vanessa adding faster disks to address connectivity outages
14:49:35 <mackonstan> #link https://jira.linuxfoundation.org/servicedesk/customer/portal/2/IT-17595
14:53:02 <mackonstan> #topic Centos CI
14:53:46 <mackonstan> #info Peter - problem with running container in Centos. Need help from Thomas F. Herbert, need to ping him.
14:56:45 <mackonstan> #topic VPP code performance
14:57:12 <mackonstan> #info some tests failing - 3 known issues apply - resolution WIP
14:57:32 <mackonstan> #topic Developments
14:58:06 <mackonstan> #info VAT to PAPI - Jan - only policer left - some incompatibility between VAT and PAPI - resolving with Ole
14:58:43 <mackonstan> #info PAPI scale test - Vratko - still WIP - changes improve the situation but tests still failing
15:00:06 <mackonstan> #info CSIT migration to Python 3+ - Jan - proposal by eow
15:00:32 <mackonstan> #endmeeting