14:52:11 <vrpolak> #startmeeting FD.io CSIT project meeting
14:52:11 <collabot> Meeting started Wed Oct 30 14:52:11 2019 UTC.  The chair is vrpolak. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:52:11 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:52:11 <collabot> The meeting name has been set to 'fd_io_csit_project_meeting'
14:52:47 <vrpolak> #help chair
14:53:21 <mackonstan> #chair
14:53:45 <mackonstan> #chair
14:53:52 <mackonstan> #chair vrpolak
14:53:55 <mackonstan> #chair
14:54:51 <vrpolak> #chair mackonstan
14:54:51 <collabot> Current chairs: mackonstan vrpolak
15:02:38 <vrpolak> #info Vratko Polak.
15:04:01 <dwallacelf> #info Dave Wallace
15:04:52 <mackonstan> #topic Agenda bashing
15:08:46 <mackonstan> #topic VPP updates
15:09:10 <mackonstan> #info Dave: v19.04.3 published, need to plan for maintenance testing.
15:09:16 <mackonstan> #info Maciek: Jan generated a summary of all lab infra resources used for 19.08.1 maintenance testing. Partially processed it, will send readout to csit-dev.
15:09:34 <mackonstan> #info DaveW: v19.08.2 - no plan yet
15:09:58 <mackonstan> #topic TSC updates
15:16:03 <mackonstan> #info Maciek: on the last call discussed issues with Nexus storage backend, Vanessa proposed live t/shooting session. So far issue hasn't reappeared since last Thursday, so keep monitoring.
15:16:24 <mackonstan> #info Maciek: Ray continues to lead the resolution of Scapy licensing issues.
15:16:59 <mackonstan> #topic HC
15:18:06 <mackonstan> #info Maciek: on one of the last few calls we have agreed to remove HC test code from CSIT repo, as it's out of sync with CSIT-1908 and VPP v19.08. Raising it here again, to capture what exactly needs to be done and who will do it.
15:20:10 <mackonstan> #action Maciek, Peter, Vratko: push a patch capturing all required changes.
15:21:20 <mackonstan> #topic Releases CSIT-2001
15:21:25 <mackonstan> #info wiki updated
15:21:33 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit2001_plan
15:22:11 <mackonstan> #topic Releases CSIT-1908
15:22:39 <mackonstan> #info Maciek: need to track status of open issues - will send email on csit-dev + vpp-dev with current status and ask for comments.
15:23:00 <mackonstan> #topic Operational status
15:23:25 <mackonstan> #info Upgrades last week - seem to have gone smoothly
15:25:34 <mackonstan> #info API test coverage - Vratko - yaml file capturing the delta updated
15:25:55 <vrpolak> #info File with comments on API coverage us up-to-date: resources/api/vpp/supported_crcs.yaml
15:28:22 <mackonstan> #info Vratko: many tests failing in 2n-tsh, due to timing, CSIT w/a to skip papi checks (show ver, … ) as these are failing by making vpp crash. Not easily reproducible. Looking to nail it and run it by vpp-dev
15:29:22 <vrpolak> #topic VPP code performance
15:30:57 <vrpolak> #info trending e-mails contain occasional regression, Vratko thinks they are just noise.
15:31:45 <vrpolak> #topic Developments
15:33:43 <vrpolak> #info Vratko works on suite generator.
15:33:58 <vrpolak> #info No big news on other developments.
15:34:30 <vrpolak> #endmeeting