14:57:12 <mackonstan> #startmeeting FD.io CSIT project meeting
14:57:12 <collabot> Meeting started Wed Nov  6 14:57:12 2019 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:57:12 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:57:12 <collabot> The meeting name has been set to 'fd_io_csit_project_meeting'
15:00:44 <mackonstan> #topic Agenda bashing
15:00:58 <mackonstan> #chair
15:00:58 <collabot> Current chairs: mackonstan
15:02:17 <vrpolak> #info Vratko Polak.
15:03:03 <mackonstan> #topic FD.io CSIT physical labs
15:03:45 <dwallacelf> #info Dave Wallace
15:03:52 <mackonstan> #info PM: one 2n-skx testbed is down, reporting read-only ssd error, similar to before.
15:04:04 <jgelety> #info Jan Gelety
15:06:32 <mackonstan> #info PM, VP: 2n-clx testbeds are fully in operation. one testbed is missing mlx5 nics. e.g. need to have a separate job for mlx5 tests.
15:07:05 <mackonstan> #action MK: ask Trishan to order 2 mlx5 NICs, matching models in the lab.
15:07:40 <mackonstan> #topic Inputs from LFN and FD.io projects - VPP
15:08:21 <mackonstan> #info DW: for 19.08 still didn't sync up with Andrew re next maintenance release.
15:12:07 <mackonstan> #info DW: lots of patches (100s) cherry-picked into stable/1908 since 19.08.1 tag. Proposing a weekly trending performance tests, with associated web-pages and notification emails to csit-report (summary of failures, regressions, progressions).
15:13:10 <mackonstan> #action DW: to review trending test with vpp community, as well as regular cadence for LTS maintenance releases.
15:14:17 <mackonstan> #info DW: re v19.04.3 maintenance release - not seeing value in executing CSIT perf tests on this minor release.
15:16:59 <mackonstan> #info JG: showing xls summary of physical testbeds used for 1908.1 - total 14 days.
15:24:11 <mackonstan> #info JG: tables already incl. minor rls and trending data, need to add major rls, impact of outages and what's left is for development (testbed-type, time)
15:25:03 <mackonstan> #topic Inputs from LFN and FD.io projects - TSC
15:26:11 <mackonstan> #info VP: missed the last TSC meeting, but wanted to share a pointer to CSIT patch covering all identified Scapy licensing issues
15:26:28 <mackonstan> #info DW: not much discussed on the last TSC call, Scapy licensing was not covered
15:26:41 <mackonstan> #topic Releases
15:28:24 <mackonstan> #topic CSIT-2001 plan
15:28:49 <mackonstan> #info JG: Python migration - proposed plan in patch
15:29:13 <mackonstan> #link https://gerrit.fd.io/r/c/csit/+/22638
15:33:46 <mackonstan> #info Agreed to target w/c 18-Nov for a big-bang week for migration to Python 3.6.8.
15:47:13 <mackonstan> #info Nidhy: asked about API coverage in device tests - list to cover is available in resources/api/vpp/supported_crcs.yaml
15:48:25 <mackonstan> #topic Operational status
15:48:50 <mackonstan> #info Peter: reporting ongoing issues with testbeds losing their mgmt IP addresses.
15:52:36 <mackonstan> #info need to have LFN ticket#
15:54:31 <mackonstan> #info Peter: DPDK tests down due to DPDK API bug that crept into VPP master. Reverted by Damjan, so should be back to normal tomorrow.
15:56:59 <mackonstan> #info Tibor: Jenkins is going down - was restarted yday, day before, see email from Vanessa on csit-dev.
15:58:57 <mackonstan> #topic Developments
15:59:38 <mackonstan> #info VP: should prioritise cleanup tasks before freezing it for Python migration
16:01:10 <mackonstan> #info set1: VIRL cleanup and related projects that only rely on VIRL: HC, nsh_sfc, dmm.
16:01:18 <mackonstan> #info set2: Ligato tests.
16:03:28 <mackonstan> #info set3: changes that are open waiting for weeks, if not merged before the python-migration-bigbang-week, they will have to be rebased post migration.
16:04:23 <mackonstan> #endmeeting