14:58:32 <mackonstan> #startmeeting FD.io CSIT project meeting
14:58:32 <collabot> Meeting started Wed Nov 20 14:58:32 2019 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:32 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:32 <collabot> The meeting name has been set to 'fd_io_csit_project_meeting'
14:58:35 <mackonstan> #chair
14:58:35 <collabot> Current chairs: mackonstan
14:58:43 <vrpolak> #info Vratko Polak.
14:58:51 <tifrank> #info Tibor Frank
14:59:31 <pmikus> #info Peter Mikus
15:00:05 <jgelety> #info Jan Gelety
15:00:25 <mackonstan> #topic Agenda bashing
15:01:33 <dwallacelf> #info Dave Wallace
15:03:10 <jlinkes> #info Juraj Linkeš
15:03:14 <mackonstan> #topic Physical labs, testbeds
15:04:29 <mackonstan> #info Peter: fixed memory on one of the vpp device testbeds.
15:05:08 <mackonstan> #topic Inputs from projects - VPP
15:05:34 <mackonstan> #topic TSC
15:06:08 <mackonstan> #info Vratko: ongoing discussion about developer centric meeting, preference for collocating with another data plane centric event
15:06:19 <mackonstan> #topic CNCF CNF Testbed
15:08:36 <mackonstan> #info Peter: CNF Testbed project is working on some papers about deployment guidelines; some progress with NSM integration with VPP; looking to standardise on unprivileged container with VPP that is now supported, work to be scheduled.
15:09:22 <mackonstan> #topic Releases CSIT-1908 maintenance
15:10:46 <mackonstan> #info still need to execute on last week action Maciek/Jan took re LTS weekly trending tests
15:11:16 <mackonstan> #info will be captured in a patch modifying this spec:
15:11:18 <mackonstan> #link https://git.fd.io/csit/tree/docs/job_specs/perf_tests_job_specs.md
15:12:19 <mackonstan> #action Maciek: need to revise known open issues from csit-1908 and report
15:15:12 <mackonstan> #info need for an interim rc0 20.01 report generation with data to get a report like view for vpp and csit
15:15:39 <mackonstan> #info looking to do this post python 3 migration, and before xmas, i.e. 1st or 2nd week of December
15:15:52 <mackonstan> #topic Operations
15:17:52 <mackonstan> #info Centos CI - Peter - working on it with Ed, making progress. Will require updating to python 3. Additional cost of maintaining Centos.
15:18:41 <mackonstan> #info Peter: suggest to have a broader discussion at FD.io level about ongoing Centos maintenance.
15:19:13 <mackonstan> #topic VPP code performance
15:24:49 <mackonstan> #info reviewing latest summary email report "[csit-report] Failed tests as of 2019-11-19 02:00:07 UTC #email" on csit-report.
15:28:26 <mackonstan> #topic Developments
15:30:53 <mackonstan> #info Migration to Python 3.x - Jan reporting
15:31:24 <mackonstan> #info Python libraries are 70% complete, expecting dev complete by Friday AM, testing starts then
15:32:04 <mackonstan> #info PAL - Tibor - on target for completion by eow
15:33:17 <mackonstan> #info optimistic scenario - unfreeze csit master on Monday 25-Nov, less optimistic few days later
15:35:40 <mackonstan> #info Peter: removed HC, Ligato.
15:35:59 <mackonstan> #info Tibor: removing DMM, NSH_SFC.
15:37:04 <mackonstan> #info Vratko: looking to remove TLDK.
15:40:35 <mackonstan> #topic Performance trending and analytics
15:43:25 <mackonstan> #info Tibor: refreshed trending pages aligned with report test coverage and graph presentation, results available in html in cisco lab sandbox and in code form in fd.io gerrit
15:44:00 <mackonstan> #topic New tests
15:45:17 <mackonstan> #info Vratko: updated suite generator, supports now multiple drivers per nic, need to update test selectors for daily trending and for report
15:46:08 <mackonstan> #action Jan/Vratko/Maciek update the tag expression files and and job specs files
15:48:22 <mackonstan> #info Nidhy: adding more tests for vpp-device to increase API coverage
15:49:37 <mackonstan> #endmeeting