15:00:52 <mackonstan> #startmeeting FD.io CSIT project meeting
15:00:52 <collabot`> Meeting started Wed Feb 26 15:00:52 2020 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:52 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:52 <collabot`> The meeting name has been set to 'fd_io_csit_project_meeting'
15:01:14 <jgelety> #info Jan Gelety
15:01:16 <tifrank> #info Tibor Frank
15:01:17 <vrpolak> #info Vratko Polak.
15:01:38 <mackonstan> #topic Agenda bashing
15:03:14 <mackonstan> #topic Physical labs, testbeds
15:10:56 <mackonstan> #info Ed - vpp-csit-api-crc job failures for not API changing patches. Vratko following up on it.
15:12:42 <vrpolak> #link https://gerrit.fd.io/r/c/vpp/+/22698  <-- This got fake +1 due to naginator, and merge broke crc checks.
15:14:59 <mackonstan> #info Peter - re 19.08 LTS tests - issue with re-provisioning the testbeds, as the execution environment has changed e.g. moved from Python 2.7 to 3.x.
15:17:56 <mackonstan> #info Peter - will start email thread on csit-dev
15:23:23 <mackonstan> #topic Inputs from projects
15:25:17 <mackonstan> #info TSC - Vratko reporting - lab access discussion, fd.io dev event co-located with dpdk dev event in Bordeaux in Sep/Oct.
15:25:30 <mackonstan> #topic Release CSIT-2001
15:28:35 <mackonstan> #info Jan - testing - finished performance selected for repeatibility on 2n-dnv (10/10), 3n-dnv (10/10), tsh (8/10), 2n-clx (5/10, 3 running ETA Fri).
15:31:23 <mackonstan> #info Jan - testing - complete set of performance tests: 2n-clx number of AVF xxv710 tests are failing (link down on TRex) and RDMA cx553a 9000B tests failing (due to TRex crash).
15:34:02 <mackonstan> #info Jan - testing - 2n-clx AVF xxv710 tests failures (link down on TRex) are observed for ip4 tests only
15:38:55 <mackonstan> #info Report content & generation - Tibor - update re latest working version on master, added test data, bug fixes.
15:40:38 <mackonstan> #info Report - Tibor - hoststack tests static content and rendering code in gerrit under review, reconfig and soak tests need 2n-skx testbeds (will be available after ucode issue is resolved).
15:45:02 <mackonstan> #info Skx tests - Maciek - based on the discussion on this call, we are shooting to release 2n-skx and 3n-skx test results by 11-Mar, 2 weeks from now, following investigation with Intel.
15:45:20 <mackonstan> #topic Release CSIT-1908
15:46:34 <mackonstan> #info CSIT needs to test VPP stable/1908 - dependency on resolving the environment dependencies as noted earlier on this call by Peter.
15:48:13 <mackonstan> #info CSIT-1908 maintenance should have a list of tests specified ahead of time, should be aligned with 19.08.1.
15:48:39 <mackonstan> #action Jan, Maciek to review the 19.08.1 test list, and produce a list for 19.08.2
15:49:03 <mackonstan> #topic Operations
15:50:47 <mackonstan> #info Peter - we would need to upgrade all skx machines to specific BIOS version once ucode issue resolution and recommendation comes from Intel. This takes a day to notify Vexxhost on-site team, and a day to upgrade all machines (14 skx hosts).
15:55:08 <mackonstan> #info Govind - kernel -72 includes spectre-meltdown fixes but no performance micro-code updates. Recommendation is to move. Peter and Juraj will coordinate the kernel upgrade.
15:55:18 <mackonstan> #topic VPP code performance
15:58:04 <mackonstan> #info Peter - number of issues with AVF initialisation, investigating.
16:00:21 <mackonstan> #info Vratko - investigating stdev increase observed for vhost tests due to different vhost rxq to worker placement.
16:01:26 <mackonstan> #endmeeting