15:05:35 <mackonstan> #startmeeting FD.io CSIT project meeting
15:05:35 <collabot`> Meeting started Wed Mar  4 15:05:35 2020 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:35 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:35 <collabot`> The meeting name has been set to 'fd_io_csit_project_meeting'
15:05:40 <jgelety> #info Jan Gelety
15:05:41 <tifrank> #info Tibor Frank
15:05:43 <dwallacelf> #info Dave Wallace
15:05:44 <vrpolak> #info Vratko Polak.
15:05:47 <mackonstan> #chair mackonstan
15:05:47 <collabot`> Current chairs: mackonstan
15:05:54 <jlinkes> #info Juraj Linkeš
15:06:04 <mackonstan> #topic Agenda bashing
15:08:32 <mackonstan> #topic DST starts
15:09:16 <mackonstan> #info keeping meeting time same for Europe/UK, PDT/EDT guys have it one hour later (local time).
15:09:28 <mackonstan> #topic Physical labs, testbeds
15:12:21 <mackonstan> #info Peter update - all Skx machines upgraded to BIOS v3.2 per Intel recommendations to address ucode issues; SSD firmware to avoid RMAs leading to some SSDs dying and needed to be replaced and OS reinstalled.
15:12:34 <mackonstan> #info All skx testbeds are now in operation.
15:14:58 <mackonstan> #info Govind from Arm is still waiting for VPN access, ticket open.
15:15:27 <mackonstan> #topic Inputs from projects
15:17:49 <mackonstan> #info Dave update: VPP - v20.05 schedule F0 06-May
15:19:38 <mackonstan> #info Maciek update: TSC - Ray presented Scapy/GPLv2 points, TSC voting expected this or next week.
15:20:33 <mackonstan> #info Maciek update: TSC - vpp dev event collocated with dpdk dev event in France in october
15:21:05 <mackonstan> #topic Releases CSIT-2001
15:22:05 <mackonstan> #info Testing - Jan update - last ndrpdr select test running for Tsh, all other performance tests are done.
15:24:13 <mackonstan> #info Testing - Jan - soak 2n-clx running (some vhost test failures), reconfig 2n-clx done, 2n-clx and 3n-hsw hoststack done
15:25:08 <mackonstan> #info Testing - Jan - only Skx tests left to close CSIT-2001. Trending cadence can be returned to normal for all but skx testbeds.
15:26:17 <mackonstan> #Report - Tibor - latest maintenance version is out, all produced test data included:
15:26:51 <mackonstan> #info Report - Tibor - latest maintenance version is out, all produced test data included:
15:27:00 <mackonstan> #link https://docs.fd.io/csit/rls2001/report/
15:27:32 <mackonstan> #info additions are recorded here:
15:27:34 <mackonstan> #link https://docs.fd.io/csit/rls2001/report/introduction/report_history.html
15:31:23 <mackonstan> #action Dave, Florin, Maciek - would be good to review the hoststack testing sections
15:31:36 <mackonstan> #link https://docs.fd.io/csit/rls2001/report/vpp_performance_tests/hoststack_testing/index.html
15:43:43 <mackonstan> #info Skx update - Maciek, Peter - BIOS upgraded to v3.2, very low NDR issue still open on all but one 2n-skx testbed. increasing NIC driver ring size elevates the issue. Under investigation with Intel, another sync tomorrow. If not line of sight to resolution, looking to go ahead with CSIT-2001 testing with increased ring sizes and compare to default setting.
15:45:54 <mackonstan> #topic Releases CSIT-1908
15:46:16 <mackonstan> #info Peter - some fixes applied, vpp-device tests are now running.
15:46:38 <mackonstan> #info Vratko - like more changes required for performance tests.
15:49:36 <mackonstan> #info Dave - will ask on the next VPP call, if any calls for v19.08.2 rls
15:49:49 <mackonstan> #topic Operations
15:50:08 <mackonstan> #info Ed Kern - all quiet, all working
15:50:43 <mackonstan> #info Ed Kern - disabling retries - patch open in ci-mgmt
15:51:47 <mackonstan> #info vpp-csit-device tests - re-enable voting - Vratko - infrequent failures still happening, needs to be investigate
15:52:20 <mackonstan> #info Ed - while Vanessa away, stand in is eball@linuxfoundation.org
15:52:33 <mackonstan> #info Centos CI - no update
15:55:47 <mackonstan> #topic VPP code performance
15:56:28 <mackonstan> #info number of issues in trending in master - see email summaries in csit-report mailer
15:56:44 <mackonstan> #topic Developments
15:57:31 <mackonstan> #info API functional test coverage - Vijay - IPsec tests, encryption works decryption doesn't
15:59:26 <vrpolak> #info Performance: No new regressions. I tried to bisect for two new failures on 3n-hsw, but results were not stable, the failure is not deterministic. Finally, there is one apparent progression on 3n-hsw I tracked to one testbed having better performance. Examining it now.
16:01:30 <mackonstan> #endmeeting