14:02:22 <mackonstan> #startmeeting FD.io CSIT project meeting
14:02:22 <collab-meetbot> Meeting started Wed Apr 29 14:02:22 2020 UTC and is due to finish in 60 minutes.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:22 <collab-meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:22 <collab-meetbot> The meeting name has been set to 'fd_io_csit_project_meeting'
14:02:26 <mackonstan> #chair
14:02:27 <collab-meetbot> Current chairs: mackonstan
14:02:31 <vrpolak> #info Vratko Polak.
14:02:46 <pmikus> #info Peter Mikus
14:03:44 <tifrank> #info Tibor Frank
14:03:51 <mackonstan> #topic Agenda bashing
14:04:08 <mackonstan> #topic Physical labs, testbeds
14:04:51 <mackonstan> #info Peter - old faulty SSDs got replaced.
14:05:25 <mackonstan> #info Peter - 3 more SSDs failed - 3n-skx, and 2 of 2n-skx
14:05:56 <jgelety> #info Jan Gelety
14:06:19 <mackonstan> #info Peter - some progress made on getting SSD spares, purchased and shipped.
14:06:39 <mackonstan> #info Peter - 10 SSDs spare
14:07:06 <mackonstan> #info Peter - 15 SSDs shipped as RMAs, no RCAs received.
14:07:36 <dwallacelf> #info Dave Wallace
14:08:40 <mackonstan> #info Peter - thread with CSIT, Vexxhost, LFN IT, missing is Intel eng contact.
14:08:55 <mackonstan> #action Maciek, Ray to pick it up from Peter and team
14:10:57 <mackonstan> #topic Inputs from projects
14:11:26 <mackonstan> #topic VPP
14:11:32 <mackonstan> #info Dave - 20.05 API freeze is May-6, next Wed
14:11:55 <mackonstan> #info Dave - RC0 is week after that May-13
14:13:01 <mackonstan> #info Dave - no schedule for v19.08.2 yet, waiting for CSIT progress and test data analysis
14:13:20 <mackonstan> #topic VSAP
14:13:20 <vrpolak> #link https://gerrit.fd.io/r/c/csit/+/26660  <-- Add test cases about VSAP project with VPP TLS to CSIT
14:13:34 <mackonstan> #info Dave - 3k patch pushed in
14:14:00 <mackonstan> #info Dave - 3 kloc patch pushed in
14:16:28 <mackonstan> #info Dave - asked for simplifying the patch, separating infra from test, for VSAP to send someone to VPP and CSIT calls, and spin up FD.io project resources
14:17:25 <mackonstan> #info Dave - it is unfeasible to expect that this patch and tests to be included in CSIT-2005. More conversation needs to happen with Ping and Ray.
14:17:48 <mackonstan> #info Dave - Ping is to be the PTL for VSAP project, once the project is actually spun up.
14:19:44 <mackonstan> #topic TSC
14:20:06 <mackonstan> #info Dave - Scapy / GPLv2 - work still ongoing
14:20:29 <mackonstan> #info Discussion about Docker image registry, as "FD.io" already taking in dockerhub
14:21:08 <mackonstan> #info Vratko - Discussion about Docker image registry, as "FD.io" already taking in dockerhub
14:21:52 <vrpolak> #link https://gerrit.fd.io/r/c/csit/+/23143  <-- GPL saga part one, move files without switching license yet.
14:21:53 <mackonstan> #info Side comments - Dave - Nomad images and code to be stored in ci-management
14:24:42 <mackonstan> #topic Releases
14:25:09 <mackonstan> #topic CSIT-2001 Release - 2n-skx, 3n-skx re-test
14:25:55 <mackonstan> #info Jan - 2n-skx - 10 runs complete, 3n-skx - 5 runs complete (SSD failures inhibit the progress here).
14:26:53 <mackonstan> #info Jan - 2n-skx - full-set tests done, 3n-skx - full-set tests not not done, will do after 6th repeatability run complete
14:27:37 <mackonstan> #info Tibor - report data publishing is ready, just awaiting updated files with RCA details.
14:29:02 <mackonstan> #info Vratko - bi-secting and RCA'ing is progressing slow, most of RCAs should be filed by next Wed May-6
14:29:54 <mackonstan> #topic CSIT-1908 Release
14:30:07 <mackonstan> #topic CSIT-1908 Release - Maintenance
14:31:38 <mackonstan> #info Jan - 2n-skx - 10 runs complete (for repeatability), all l2-patch tests are failing (checking for missing cherry-pick, as similar was observed in the vpp master post 19.08.1 rls), all other tests are passing.
14:32:03 <mackonstan> #info Tibor - 2n-skx - 19.08.2 vs. 19.08.1 is ready in master
14:32:08 <tifrank> VPP Performance changes 2n-skx-xxv710 2t1c ndr
14:32:08 <tifrank> Performance changes 2n-skx-xxv710 2t1c pdr
14:32:10 <tifrank> Performance changes 3n-skx-xxv710 2t1c ndr
14:32:13 <tifrank> Performance changes 3n-skx-xxv710 2t1c pdr
14:32:47 <tifrank> #link https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-2n-skx-2t1c-ndr.txt
14:33:18 <tifrank> #link https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-2n-skx-2t1c-pdr.txt
14:33:36 <tifrank> #link https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-3n-skx-2t1c-ndr.txt
14:33:51 <tifrank> #link https://docs.fd.io/csit/master/report/_static/vpp/performance-changes-1908_2-3n-skx-2t1c-pdr.txt
14:40:50 <mackonstan> #info Jan - 3n-skx - 2 runs completed too.
14:43:22 <mackonstan> #vote from CSIT perspective the performance data is good enough to accept the code for VPP v19.08.2 maintenance release
14:44:11 <mackonstan> #info Consensus on the call to go ahead with v19.08.2
14:44:35 <vrpolak> #link https://docs.releng.linuxfoundation.org/en/latest/meetbot.html  <-- MeetBot Guide :)
14:45:40 <mackonstan> #topic CSIT-2005 Release
14:49:19 <mackonstan> #info CSIT F0 may-6, RC1 may-13.
14:50:21 <mackonstan> #topic Operations
14:50:56 <mackonstan> #info Vratko - LF IT maintenance went well, no issues, all smooth
14:51:10 <mackonstan> #topic VPP code performance
14:51:30 <mackonstan> #info Tibor - added ndrpdr weekly comparison to the trending pages
14:51:34 <tifrank> #link https://docs.fd.io/csit/master/trending/introduction/weekly.html
14:54:48 <mackonstan> #info Vratko - some progressions and regressions are visible on MRR daily and on PDR weekly, some are not
14:56:13 <mackonstan> #info Vratko - it would be nice to compare the above weekly trending with current daily dashboard
14:56:15 <mackonstan> #link https://docs.fd.io/csit/master/trending/introduction/dashboard.html
14:58:36 <mackonstan> #info discussion - separate the weekly NDRPDR tests between single run (to see if tests pass/fail) and multiple runs for statistically meaningful data for week-by-week comparison
14:59:34 <mackonstan> #info Jan - daily trending - ipsec tests are failing, bisecting wip, offending patch to be identified shortly
15:00:16 <mackonstan> #info Jan - will use Vratko's auto-bisecting code to find the bad apple
15:00:44 <mackonstan> #topic Developments
15:01:09 <mackonstan> #info Jan - new srv6 api tests are in review, pls review before F0 next week
15:01:49 <mackonstan> #endmeeting