#fdio-csit: FD.io CSIT Project Meeting

Meeting started by mackonstan at 15:00:54 UTC (full logs).

Meeting summary

    1. mackonstan (mackonstan, 15:01:32)
    2. Vratko Polak. (vrpolak, 15:01:37)
    3. Juraj Linkeš (jlinkes, 15:01:45)

  1. Agenda bashing (mackonstan, 15:02:03)
    1. Tibor Frank (tifrank, 15:03:50)
    2. Dave Wallace (dwallacelf, 15:03:56)

  2. Inputs from projects - VPP (mackonstan, 15:05:35)
    1. Dave reporting (mackonstan, 15:05:41)
    2. vpp-dev meeting happened yday, v21.06 schedule confirmed (mackonstan, 15:06:18)
    3. Vratko, vpp api change tracking, specifically address CRC'ing backward compatible APIs, CRC check job needs a new collection of CRCs to check against (mackonstan, 15:08:18)

  3. Inputs from projects - VSAP (mackonstan, 15:10:34)
    1. Dave, 2 sets of patches 31333, 31334, by Xi Zhang, one of them changing the test environment, so considering this as higher risk item (mackonstan, 15:20:12)
    2. Maciek, it will be faster for the key parties to jump on the call, walk thru the vpp, ldp, nginx testing path, and then dive into the integration into CSIT framework - stakeholders: VSAP (Xi Zhang, Fan Zhang), VPP (Dave W, Florin), CSIT (Maciek, Peter) (mackonstan, 15:24:47)

  4. Inputs from projects - TSC (mackonstan, 15:25:50)
    1. Maciek, RayK raised the point about funding server HW for TG servers, make sure that this is included by all parties in their HW donation planning. (mackonstan, 15:27:48)

  5. CSIT-2106 (mackonstan, 15:28:06)
  6. CSIT-2101 (mackonstan, 15:29:13)
    1. Tibor, report update posted last week, added GSO tests (mackonstan, 15:34:27)
    2. Tibor, async ipsec tests to be added once analysed by Vratko/Maciek/other-volunteer (mackonstan, 15:35:35)
    3. at that will be it (mackonstan, 15:36:08)

  7. FD.io DC move in Mar 2021 (mackonstan, 15:36:35)
    1. Maciek, Vexxhost DC move of FD.io Nomad and CSIT testbed servers/HW: MTL2 (1 rack) move to YUL1 complete, MTL1 (4 racks) move to YUL1 to be scheduled (mackonstan, 15:40:59)
    2. MTL2 move verified as successful, all issues sorted (mackonstan, 15:41:23)
    3. Big thanks to Peter Mikus, Andrew Yourtchenko and Dave Wallace for assisting with the move, and working with Vexxhost to iron out some "teething issues" (mackonstan, 15:41:32)

  8. FD.io lab extension in 2021 (mackonstan, 15:45:49)
    1. Maciek, following on the discussion at TSC about TG, need to come up with a proposal about "standardised" TG platform for all testbeds (note any variations if appropriate), the practical aspects of operating it in CSIT framework (calibration, drivers, etc) (mackonstan, 15:49:09)
    2. ACTION: Maciek, Peter, Dave, develop a strawman proposal, present at the next CSIT call, drive consensus there, and then bring it up in TSC meeting (expect funding discussion there) (mackonstan, 15:50:32)

  9. Virtual Infrastructure, CI/CD (mackonstan, 15:51:00)
    1. Tibor, testbed occupancy/util for trending jobs, after optimisations longest tests are 7-8 hrs (good!) (mackonstan, 15:52:09)
    2. Tibor, above is about daily trending (mackonstan, 15:52:21)
    3. Tibor, but there are some "bloating" / growing duration weekly test jobs, 30-44 hrs. (mackonstan, 15:53:44)
    4. Maciek, need to look closer at how to control this, Maciek/Tibor (mackonstan, 15:56:46)

  10. Environment, Framework (mackonstan, 15:59:26)
    1. Dave, with Peter testing Ubuntu 20.04, looking good, but transition from 18.04 to 20.04 is going to take time, due to the volume of servers we have (60 +) (mackonstan, 16:00:30)
    2. Peter, having some issues with old Xeon Haswell servers (mackonstan, 16:02:24)

  11. Performance Tests (mackonstan, 16:05:35)
    1. Tomas, looking at trending failures, writing a summary (mackonstan, 16:08:12)


Meeting ended at 16:09:57 UTC (full logs).

Action items

  1. Maciek, Peter, Dave, develop a strawman proposal, present at the next CSIT call, drive consensus there, and then bring it up in TSC meeting (expect funding discussion there)


People present (lines said)

  1. mackonstan (35)
  2. collab-meetbot` (3)
  3. vrpolak (1)
  4. jlinkes (1)
  5. tifrank (1)
  6. dwallacelf (1)


Generated by MeetBot 0.1.4.