16:00:51 <edwarnicke> #startmeeting TSC Meeting 2016-03-10
16:00:51 <collabot`> Meeting started Thu Mar 10 16:00:51 2016 UTC.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:51 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:51 <collabot`> The meeting name has been set to 'tsc_meeting_2016_03_10'
16:00:57 <edwarnicke> #topic Roll Call
16:00:59 <edwarnicke> #info edwarnicke
16:01:03 <joelhalpern> #info joelhalpern
16:01:06 <edwarnicke> #chair joelhalpern
16:01:06 <collabot`> Current chairs: edwarnicke joelhalpern
16:01:21 <edwarnicke> #chair keith_wiles
16:01:21 <collabot`> Current chairs: edwarnicke joelhalpern keith_wiles
16:02:54 <edwarnicke> #link https://wiki.fd.io/view/TSC#Agenda <- Agenda
16:04:31 <dbarach> #info dbarach present
16:04:54 <edwarnicke> #chair barach
16:04:54 <collabot`> Warning: Nick not in channel: barach
16:04:54 <collabot`> Current chairs: barach edwarnicke joelhalpern keith_wiles
16:05:01 <edwarnicke> #chair dbarach
16:05:01 <collabot`> Current chairs: barach dbarach edwarnicke joelhalpern keith_wiles
16:06:03 <edwarnicke> #topic Agenda Bashing
16:06:41 <Venky> #info Venky
16:06:48 <edwarnicke> #chair Venky
16:06:48 <collabot`> Current chairs: Venky barach dbarach edwarnicke joelhalpern keith_wiles
16:10:04 <edwarnicke> #info added CSIT readout
16:10:17 <edwarnicke> #info added Pre-Formation Projects agenda item
16:10:21 <edwarnicke> #topic Events
16:11:24 <edwarnicke> #info fd.io Meetup at ONS - 5-5:45pm Wed 2016-03-16 - Napa Conference Room
16:11:44 <edwarnicke> #info Venky asks if we should plan a summer Training/Hackfest in Eu
16:13:02 <edwarnicke> #info suggestions that we do one Hackfest/Training a quarter, rotate locations
16:13:17 <edwarnicke> #info goal to see a couple this year
16:14:13 <edwarnicke> #info alagalah suggests ODL summit (as GBP+SFC in ODL are planning a fd.io implementation)
16:14:18 <edwarnicke> #info Venky suggets Linuxcon
16:14:51 <edwarnicke> #info alagalah suggets dockercon/containercon/any CNF initiative once we sort out our container storry
16:15:44 <edwarnicke> #info joelhalpern asks if we would like to do something at IETF hackfests
16:16:59 <edwarnicke> #topic Pre-Formation Projects
16:17:22 <edwarnicke> #info alagalah announces pre-formation on a netlink agent project
16:17:27 <alagalah> #link http://manpages.ubuntu.com/manpages/trusty/en/man7/netlink.7.html NETLINK(7)
16:18:44 <alagalah> #info netlink contact email alagalah@gmail.com
16:19:41 <edwarnicke> #info joelhalpern asks about netlink... as he'd understood it to be a way for userspace to talk to the kernel, and vpp is userspace
16:20:31 <edwarnicke> #info alagalah explains that many userspace applications have an expectation of talking to the kernel to get network services.  Could use LDPRELOAD to intercept netlink messages and hand them to VPP for the things it should handle, pass through to kernel for everything else.
16:21:31 <edwarnicke> #info joelhalpern 's question was answered :)
16:21:36 <edwarnicke> #info Venky is interested
16:22:05 <edwarnicke> #info Venky discusses some of his experiences around this
16:26:20 <edwarnicke> #info #fdio-netlink
16:26:38 <edwarnicke> #link https://wiki.fd.io/view/IRC <- please add
16:28:29 <edwarnicke> #info Ash Young suggested adding to the IRC page under proposals section
16:29:24 <edwarnicke> #info Ash Young notes he'd like to follow up with Venky about possible netlink collisions with filesystem stuff
16:29:59 <edwarnicke> #action Venky to email discuss@lists.fd.io explaining some of the subtlties he's experienced around doing netlink agents
16:30:14 <alagalah> #link https://wiki.fd.io/view/IRC#fd.io_Channels Added section for "unofficial" channels
16:30:31 <alagalah> #info Netlink project IRC channel #fdio-netlink
16:30:49 <edwarnicke> #topic Making infrastructure tickets visible to the community
16:30:57 <edwarnicke> #info cj not present to discuss
16:30:59 <edwarnicke> moving on
16:31:06 <edwarnicke> #topic Security Process
16:31:39 <edwarnicke> #info Ash Young has not yet completed the Security Process Draft
16:32:08 <edwarnicke> #action Ash Young draft of security process for next TSC call
16:32:39 <edwarnicke> #topic CSIT Readout
16:32:58 <edwarnicke> #info skobza to readout on CSIT
16:33:26 <edwarnicke> #info three labs in process
16:33:31 <edwarnicke> #info performance lab on hardware
16:33:57 <edwarnicke> #info virl setup, single server, to run jobs for larger topologies - run every test case for functionality, working for weeks now
16:34:29 <edwarnicke> #info LF VMs - Any kind of a verify/merge job with multiple VM spawning with some OpenStack provider.
16:34:56 <edwarnicke> #info Found out last night that cannot use LF VMs because OpenStack Security makes it useless, dropping any packets not preassigned by OpenStack
16:35:10 <edwarnicke> #info expecting response from LF infra today or tomorrow
16:36:39 <edwarnicke> #info dbarach opines that for VPP protocol interop testing that for control we are likely to need something like VIRL to actually test, as OpenStack is not able to actually support network testing, and the Linux limitations in terms of RFC support
16:37:25 <edwarnicke> #info skobza expects to get response from LF provider and get email out to lists in the next few days
16:37:38 <edwarnicke> #info CSIT project proposal scheduled for next week
16:38:03 <edwarnicke> #info CSIT has 18 basic tests so far
16:38:37 <edwarnicke> #topic Draw attention to Project Proposals out for public comment
16:38:56 <edwarnicke> #link https://lists.fd.io/pipermail/tsc/2016-March/000022.html <- CSIT
16:39:09 <edwarnicke> #link https://lists.fd.io/pipermail/tsc/2016-March/000029.html <- Honeycomb
16:39:22 <edwarnicke> #link https://lists.fd.io/pipermail/tsc/2016-March/000028.html <- NSH SFC
16:40:21 <edwarnicke> #endmeeting