14:01:43 <skobza> #startmeeting FD.io CSIT Weekly Project Meeting
14:01:43 <collabot`> Meeting started Wed Mar 30 14:01:43 2016 UTC.  The chair is skobza. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:43 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:43 <collabot`> The meeting name has been set to 'fd_io_csit_weekly_project_meeting'
14:01:47 <skobza> edwarnicke: yep
14:01:50 <skobza> edwarnicke:  :)
14:02:00 <edwarnicke> skobza: You can then #topic ${topic} to set topics
14:02:14 <skobza> #topic agenda bashing
14:02:52 <edwarnicke> skobza: you can chair people with #chair ${list of irc nicks}
14:02:56 <skobza> #chair edwarnicke
14:02:56 <collabot`> Current chairs: edwarnicke skobza
14:05:13 <edwarnicke> skobza: Its is often helpful to #link the agenda ;)
14:05:46 <skobza> #link https://wiki.fd.io/view/CSIT/Meeting meeting agenda
14:06:40 <skobza> Maciek says wiki went up a few days ago, contains CSIT weekly meeting information, and initial information of CSIT project
14:07:39 <skobza> ... most recent documentation and state is going to be with the CSIT code, with lagging wiki updates...
14:08:21 <skobza> #topic TSC feedback
14:08:57 <skobza> Dave Barach requests documentation on how to develop tests in standing CSIT framework
14:10:10 <skobza> To enhance documentation, CSIT will provide RFC numbers to test cases and suites to be explicit about targetted tested feature
14:11:24 <skobza> Maciek is going to go through the VPP and CSIT code, and point places where we have to identify RFC specs
14:13:31 <edwarnicke> edwarnicke: I've lost audio
14:14:02 <edwarnicke> #link https://wiki.python.org/moin/DocumentationTools <- Python documentation tools
14:18:49 <skobza> edwarnicke:  recommends doing automatic code review of some sort
14:23:15 <skobza> #action skobza and cj to add style checks for CSIT project
14:23:31 <skobza> #topic CSIT code structure
14:23:52 <skobza> no questions to current CSIT code structure
14:24:09 <skobza> Currently CSIT is getting executed on VIRL server
14:25:17 <skobza> 33 simulations of three-node-topology can be safely run on the VIRL server in concurrent manner
14:26:33 <skobza> #action Maciek & Peter to add performance test cases list to wiki
14:29:52 <skobza> #action skobza to forward Andy's e-mail to CJ
14:32:45 <skobza> #info vpp-csit-verify-virl is under supervision until friday. Then promoted to get automatically triggered.
14:36:38 <skobza> #topic most pressing issues
14:36:52 <skobza> vpp-csit-verify-virl has to be running in fully automatic manner by this Friday
14:37:02 <skobza> ... to enable vpp release
14:37:53 <skobza> CSIT team is extracting from VPP devs features that they want to address with CSIT. Discussion is going to happen over e-mail.
14:38:19 <skobza> #action Dave Wallace is going to work with Dave Barach on priorities regarding VPP testing for VPP release
14:38:59 <skobza> In near future the focus is more on functional coverage rather than line coverage.
14:40:15 <skobza> DaW is going to work on adding VPP API of VPP CLIs "show run" equivalent to enable node coverage information in test output
14:40:43 <skobza> #topic incoming code
14:41:01 <skobza> Incoming patches for QinQ, vhost-user, and honeycomb handling in tests
14:41:59 <skobza> #info CSIT is going to use Jira to track progress transparently
14:48:24 <skobza> #action CSIT team to write wiki page on how to parse / read the robot framework test results for VPP devs and CSIT participants
14:48:49 <skobza> #topic Q&A
14:50:05 <skobza> #endmeeting