17:06:47 <mackonstan> #startmeeting 161207 TWS vHost user test scenarios for CSIT
17:06:47 <collabot`> Meeting started Wed Dec  7 17:06:47 2016 UTC.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:47 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:06:47 <collabot`> The meeting name has been set to '161207_tws_vhost_user_test_scenarios_for_csit'
17:06:53 <mackonstan> #chair mackonstan
17:06:53 <collabot`> Current chairs: mackonstan
17:07:34 <ppfister> #info ppfister
17:07:59 <BillyM> #info bmcfall
17:11:35 <mackonstan> #info mackonstan - updating wiki page to reflect the discussion and consensus on TWS call
17:11:45 <mackonstan> #link https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios
17:12:06 <mackonstan> #info Alec_ Alec Hothan
17:12:59 <mackonstan> #info Alec walking thru three main points raised on [csit-dev] to reflect most common OpenStack NFV deployments
17:14:41 <mackonstan> #link https://lists.fd.io/pipermail/csit-dev/2016-November/001259.html
17:14:54 <mackonstan> #topic 2p1nic vs 1p1nic
17:15:08 <mackonstan> #info Alec - proposal to add 1p1nic topologies
17:15:18 <mackonstan> #info OpenStack ML2/VPP/VLAN will use dot1q-l2bdbase-eth-2vhost-1vm
17:15:22 <mackonstan> #info OpenStack ML2/VPP/VLAN will use dot1q-l2bdbase-eth-2vhost-1vm
17:21:17 <mackonstan> #info adding following baseline topologies
17:21:28 <mackonstan> #info 1p1nic-dot1q-l2bdbase-eth-2vhost-1vm
17:22:06 <mackonstan> #info *** 1p1nic-ethip4vxlan-l2bdbase-eth-2vhost-1vm
18:11:21 <mackonstan> #info scale topology cases: 2p1nic-ethip4vxlan-l2bdscale-<n>flows-eth-<m>vhost-<o>vm-parallel
18:11:43 <mackonstan> #action All - to agree on the most applicable combinations of <n>, <m>,<o>
18:12:04 <mackonstan> #info scale topology cases: 2p1nic-ethip4vxlan-l2bdscale-<n>flows-eth-<m>vhost-<o>vm-chain
18:12:33 <mackonstan> #action All - to agree on the most applicable combinations of <n>, <m>,<o> for VM chains
18:13:19 <mackonstan> #action Irene_ - working on optimizing and tuning testpmd in VM to work with 2vCPUs - 1vCPU for main testpmd app, and 1vCPU for pmd threads. Expecting progress on this next week, will send email to [csit-dev].
18:13:48 <mackonstan> #info need to standardize on testpmd startup parameters
18:13:57 <mackonstan> #action Irene: will send list of parameters optimized for using vpmd with virtio, and script examples
18:14:43 <mackonstan> #info review and update (nested) VM image building for vhost tests - starting point being existing CSIT VM image building: Ubuntu, Centos
18:14:53 <mackonstan> #action team of volunteers (?): Carsten, PMikus, Alec, Thomas, Irene, Maciek
18:15:23 <mackonstan> #info Thomas - For baselining the system - Replace VPP with 2x testpmd for xconnecting 2x Phy-to-Vhost
18:15:35 <mackonstan> #info requires a new DPDK patch for enabling vhost in testpmd - <add-link>
18:16:21 <mackonstan> #info Irene currently testing manually in Intel labs - can help with onboarding into CSIT.
18:18:28 <mackonstan> #info All agreed to cover remaining open points and details over email thread on csit-dev. No need for another TWS call. Will be tracking progress and coordinating using CSIT comms means: csit-dev@lists.fd.io, #fdio-csit, CSIT weekly calls every Wednesday. Maybe another technical TWS call in January per Thomas suggestion.
18:19:00 <mackonstan> #info current consensus captured on this wiki page that got updated during this TWS meeting:
18:19:08 <mackonstan> #link https://wiki.fd.io/view/CSIT/vhostuser_test_scenarios
18:19:33 <mackonstan> #link https://lists.fd.io/pipermail/csit-dev/
18:19:42 <mackonstan> #link https://wiki.fd.io/view/IRC
18:19:58 <mackonstan> #link https://wiki.fd.io/view/CSIT/Meeting
18:21:07 <mackonstan> #info thanks to All for contributions: Alec Hothan, Billy McFall, Irene Liew, Pierre Pfister, Thomas F Herbert, Maciek Konstantynowicz.
18:21:10 <mackonstan> #endmeeting