15:01:39 <DaveBarach> #startmeeting fdio-vpp
15:01:39 <collab-meetbot`> Meeting started Tue Jul 13 15:01:39 2021 UTC and is due to finish in 60 minutes.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:39 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:39 <collab-meetbot`> The meeting name has been set to 'fdio_vpp'
15:01:53 <DaveBarach> #chair dmarion
15:01:53 <collab-meetbot`> Warning: Nick not in channel: dmarion
15:01:53 <collab-meetbot`> Current chairs: DaveBarach dmarion
15:02:01 <mackonstan> #info mackonstan
15:02:49 <DaveBarach> #topic CSIT (Maciek reporting)
15:03:20 <mackonstan> #info Physical infrastructure updates
15:03:29 <mackonstan> #info New Intel Xeon ICX based testbeds - orders placed
15:03:49 <mackonstan> #info 3n-hsw testbeds are finally getting decommissioned
15:04:19 <mackonstan> #info Test breakages - daily (MRR rapid-fire tests), weekly (NDRPDR proper perf) process, sporadic unless otherwise noted:
15:04:33 <mackonstan> #info 1) rdma-core on one testbed, switching driver problem;
15:04:45 <mackonstan> #info 2) create avf interface, moving thru NIC rxq configurations;
15:05:41 <mackonstan> #info 3) nat44ed 16M sessions test, sessions not getting established in allotted time for some tests;
15:06:01 <mackonstan> #info 4) deterministic for specific (frame_size, core config): ipsec sw asyn tests, no traffic forwarded;
15:06:22 <mackonstan> #info 5) VSAP tests with MLX
15:06:47 <mackonstan> #info CSIT-2106 report to be published tomorrow
15:06:54 <mackonstan> #info Draft report available at the usual place
15:06:59 <mackonstan> #link https://docs.fd.io/csit/master/report/
15:07:05 <mackonstan> #info CSIT-2106 release deliverables
15:07:11 <mackonstan> #link https://wiki.fd.io/view/CSIT/csit2106_plan
15:08:29 <DaveBarach> #topic Host Stack (damjan)
15:08:38 <dmarion> #info TCP half-opens allocated in main thread connection pools instead of separate connection pools. Syns for half-open connections now follow established packet path.
15:08:45 <dmarion> #info Optimized cut-through fifo allocations. Fifo segments are allocated per app-pair as opposed to per session.
15:08:52 <dmarion> #info VCL epoll optimizations for level triggered and postponed events
15:08:57 <dmarion> #info Pre-release bug fixing
15:09:25 <DaveBarach> #topic Doc (no Ole, no Ray) skipping
15:09:59 <DaveBarach> #info Still working on Nexus retirement, which will affect docs. More next month.
15:10:11 <DaveBarach> #topic Release Management (Andrew, Dave W)
15:10:33 <DaveBarach> #info 21.01.1 tag tomorrow AM in Europe time
15:10:46 <DaveBarach> #info 21.06 nothing much to add
15:10:56 <DaveBarach> #info 21.10 release plan up on the wiki
15:11:43 <DaveBarach> #info 21.10 release cadence will be the same as 21.06
15:13:30 <DaveBarach> #info Coverity: report format updated, added defects by component stanzas
15:14:23 <DaveBarach> #info worth highlighting that we removed the API CRC generation crutches
15:15:01 <DaveBarach> #info also fixed crc calculation which has been wrong for a year / affects about half of the messages
15:15:45 <DaveBarach> #topic Infra Status (Dave W)
15:16:38 <DaveBarach> #info went through a bunch of changes with Vexxhost which have stabilized CI. At this point, few spurious failures.
15:17:12 <DaveBarach> #info last step: move Jenkins master to the data center which has all of the executors
15:17:49 <DaveBarach> #info Fixed a couple of nagging failures in host stack tests
15:18:11 <DaveBarach> #info Please report any intermittent test case failures to DW
15:18:40 <DaveBarach> #info "It's been quiet..."
15:19:12 <DaveBarach> #info Centos-8 jobs removed from master; still exist in older branches
15:19:47 <DaveBarach> #topic IPsec SPD flow cache (Govind)
15:20:58 <DaveBarach> #info aarch64 optimizations led to algorithmic change
15:21:51 <DaveBarach> #info test data from Thunderx2
15:24:58 <DaveBarach> #info hash-based flow cache addresses linear SPD search
15:30:45 <DaveBarach> #info 2x patches, plus unit-tests
15:36:20 <DaveBarach> #topic Next Meeting (Damjan)
15:37:30 <DaveBarach> #agreed Skip August meeting due to projected low attendance / Damjan unlikely to make it
15:38:02 <DaveBarach> #endmeeting