14:05:22 <mackonstan> #startmeeting FD.io CSIT Project Meeting
14:05:22 <collab-meetbot`> Meeting started Wed Sep  6 14:05:22 2023 UTC and is due to finish in 60 minutes.  The chair is mackonstan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:22 <collab-meetbot`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:22 <collab-meetbot`> The meeting name has been set to 'fd_io_csit_project_meeting'
14:05:33 <mackonstan> #chair dwallacelf jlinkes vrpolak mackonstan tifrank
14:05:33 <collab-meetbot`> Warning: Nick not in channel: dwallacelf
14:05:33 <collab-meetbot`> Warning: Nick not in channel: jlinkes
14:05:33 <collab-meetbot`> Warning: Nick not in channel: vrpolak
14:05:33 <collab-meetbot`> Warning: Nick not in channel: mackonstan
14:05:33 <collab-meetbot`> Warning: Nick not in channel: tifrank
14:05:33 <collab-meetbot`> Current chairs: dwallacelf jlinkes mackonstan tifrank vrpolak
14:05:41 <tifrank> #info Tibor Frank
14:06:55 <vrpolak> #info Vratko Polak.
14:07:52 <mackonstan> #info Maciek Konstantynowicz
14:08:04 <mackonstan> #topic Agenda bashing.
14:08:11 <mackonstan> #topic VPP updates
14:08:37 <mackonstan> #info Andrew - rc1 in couple of weeks, will send email reminder
14:08:46 <mackonstan> #topic TSC updates
14:10:09 <mackonstan> #info See Dave's noted actions
14:10:12 <mackonstan> #link https://ircbot.wl.linuxfoundation.org/meetings/fdio-meeting/2023/fd_io_tsc/fdio-meeting-fd_io_tsc.2023-08-31-15.00.html
14:10:21 <mackonstan> #info See minutes
14:11:11 <mackonstan> #link https://ircbot.wl.linuxfoundation.org/meetings/fdio-meeting/2023/fd_io_tsc/fdio-meeting-fd_io_tsc.2023-08-31-15.00.txt
14:12:00 <mackonstan> #info Heads-up: committer-at-large TSC membership - Nominations for comitter-at-large seats to be opened 2nd week of september
14:12:43 <mackonstan> #info ACTION: Dave to contact Arm folks about lack of funds for vpp-device servers
14:13:20 <vrpolak> #link https://lists.fd.io/g/tsc/message/1769  <-- LFN Governing Board Election: Call for Nominations
14:14:13 <mackonstan> #topic E810 flow "offload" tests
14:14:21 <mackonstan> #info Kai: staying in backlog
14:14:44 <mackonstan> #topic VPP and CSIT (not so hot) items
14:15:56 <mackonstan> #info re HW accelerator - SPR QAT2.0
14:16:43 <mackonstan> #info Kai - still working on setting up a mirror CSIT environment in Shannon, as Yulong environment is no longer available, and following recommendations and instructions from Peter.
14:17:22 <mackonstan> #info Kai - currently having some issues with container bringup and NICs, Ranjan in on PTO this week, back on this as of tomorrow.
14:17:43 <mackonstan> #info re HW accelerator - SNR QAT2.0
14:21:53 <mackonstan> #info Kai - there was a concern that processor may be replaced. Peter asked to run a set of commands, see email from Sebastian.
14:22:09 <mackonstan> #info HW accelerator - SPR DSA
14:25:01 <mackonstan> #info Kai: still waiting for BIOS release from SuperMicro - was expecting it on Intel calendar for wk35, now it's wk36. Kai is escalating it internally with John DG et to try and accelerate things.
14:25:16 <mackonstan> #info HW accelerator - E810 GTPU offload
14:26:33 <mackonstan> #info Peter: still an open item, to be investigated.
14:27:04 <mackonstan> #topic CSIT-2306 RCAs
14:27:10 <mackonstan> #info Vratko: no updates.
14:27:43 <mackonstan> #topic CSIT-2310 new release
14:28:11 <mackonstan> #info Kai: updated code for ipsec-mb for compatibility with dpdk 23.07
14:28:42 <mackonstan> #link 39224: crypto-ipsecmb: bump intel-ipsec-mb version to 1.4 | https://gerrit.fd.io/r/c/vpp/+/39224
14:30:11 <mackonstan> #info last comment from 23aug: "Indeed other changes are breaking backward compatibility. It is possible to preserve it but then further work on this patch is needed."
14:31:20 <mackonstan> #info Kai: team got a solution, working on it, should be ready for review soon, and in time for merging before rc1 on 20sep
14:31:39 <mackonstan> #topic Physical Infrastructure
14:32:06 <mackonstan> #info Peter: install of 4 SPRs is in progress. 2 going into 1n-spr for vpp-device testing.
14:33:10 <mackonstan> #topic Virtual Infrastructure, CI/CD
14:33:59 <mackonstan> #info Peter: 1n-skx vpp-device job still not voting, working with Dave to make it voting (fallout from Nomad CI being down last week).
14:35:51 <mackonstan> #info Vratko: Jenkins sandbox server is not working at the moment - https://jenkins.fd.io/sandbox/
14:35:54 <mackonstan> #link https://jenkins.fd.io/sandbox/
14:36:46 <mackonstan> #topic VPP API tracking
14:37:08 <mackonstan> #info Vratko: out of 6 API change patches, only 1 got merged.
14:37:27 <mackonstan> #info Andrew: enough waiting time, will work with Dave to merge the rest.
14:37:39 <mackonstan> #topic Trending and Test Failures
14:39:02 <mackonstan> #info Vratko: tracking some hoststack failures.
14:39:38 <mackonstan> #info nginx ldpreload tests broken by
14:39:50 <mackonstan> #link https://gerrit.fd.io/r/c/csit/+/39267/5/resources/libraries/robot/hoststack/hoststack.robot
14:39:58 <mackonstan> #info and then fixed by
14:40:14 <mackonstan> #link 39479: fix(hoststack): hardcode DUT1 for nginx | https://gerrit.fd.io/r/c/csit/+/39479
14:40:51 <mackonstan> #info dpdk udp quick vppecho tests broken by
14:41:20 <mackonstan> #link https://jira.fd.io/browse/CSIT-1930 hoststack: investigate udpquicbase failure since 2023-08-10
14:41:37 <mackonstan> #link 37858: session: async rx event notifications | https://gerrit.fd.io/r/c/vpp/+/37858
14:42:50 <mackonstan> #info Vratko: re ldpreload on 3node testbeds - I suspect something infra related, but I do not understand the pattern.
14:43:37 <mackonstan> #info Vratko: 3n-alt job error spike but was CI errors related ... (Nomad CI issue last week)
14:46:46 <vrpolak> #link https://gerrit.fd.io/r/c/vpp/+/38304
14:47:10 <mackonstan> #link 38304: interface dpdk avf: introducing setting RSS hash key feature | https://gerrit.fd.io/r/c/vpp/+/38304
14:48:01 <mackonstan> #info Vratko: is there a chance to have this completed and merged before rc1?
14:48:15 <mackonstan> #info Kai: will follow up on this.
14:48:36 <mackonstan> #info Vratko: it's a root cause behind inconsistent perf results on e810.
14:52:01 <mackonstan> #endmeeting