16:03:24 <edwarnicke> #startmeeting VPP Weekly
16:03:24 <collabot`> Meeting started Tue Feb 16 16:03:24 2016 UTC.  The chair is edwarnicke. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:24 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:03:24 <collabot`> The meeting name has been set to 'vpp_weekly'
16:03:55 <alagalah> Hello all
16:04:06 <alagalah> tfherbert: hey there
16:04:23 <alagalah> joelhalpern: ! Hey there.... shall we discuss port-mirror abuse ?
16:04:55 <alagalah> DaveBarach:  hey hey
16:05:07 <DaveBarach> Hey Keith...
16:05:18 <edwarnicke> #chair alagalah
16:05:18 <collabot`> Current chairs: alagalah edwarnicke
16:05:25 <edwarnicke> #chair DaveBarach
16:05:25 <collabot`> Current chairs: DaveBarach alagalah edwarnicke
16:05:30 <alagalah> #unchair alagalah
16:05:30 <collabot`> Current chairs: DaveBarach edwarnicke
16:05:32 <edwarnicke> #chair afredette
16:05:32 <collabot`> Current chairs: DaveBarach afredette edwarnicke
16:05:36 <alagalah> #chair alagalah
16:05:52 <edwarnicke> #topic Agenda Bashing
16:05:59 <edwarnicke> #link https://wiki.fd.io/view/VPP/Meeting#Agenda
16:06:37 <edwarnicke> #chair alagalah
16:06:37 <collabot`> Current chairs: DaveBarach afredette alagalah edwarnicke
16:06:40 <cdl> morning everyone
16:06:53 <edwarnicke> #chair joelhalpern
16:06:53 <collabot`> Current chairs: DaveBarach afredette alagalah edwarnicke joelhalpern
16:07:24 <edwarnicke> Call for any missing agenda items folks would like to see covered
16:07:28 <edwarnicke> Please speak up :)
16:10:01 <alagalah> afredette: tfherbert not to put you on the spot or anything :-P
16:10:19 <alagalah> #topic Getting Involved
16:10:31 <tfherbert> alagalah: Thats OK.
16:10:48 <alagalah> #info edwarnicke Sharing "Getting involved" page
16:11:06 <alagalah> #link https://wiki.fd.io/view/Main_Page#Get_Involved Getting Involved
16:11:58 <alagalah> #info edwarnicke implores folks to proliferate channels but please document them.
16:12:52 <alagalah> #info alagalah preference is keep convention of #fdio- be kept for official projects, and ##fdio- for anything else but... its just a convention
16:13:16 <alagalah> #info mailman hasn't been behaving and we have reverted from mailman3 to mailman2
16:13:56 <alagalah> #link https://lists.cloudfoundry.org/archives/ CF mailer lists
16:14:11 <alagalah> https://lists.cloudfoundry.org/archives/list/cf-dev@lists.cloudfoundry.org/
16:14:33 <alagalah> #info edwarnicke notes that this looks like mailman3 which isn't working for fd.io
16:14:42 <tfherbert> #info searchability is good.
16:15:11 <alagalah> #link https://wiki.fd.io/view/Project_Proposals Project Proposal
16:15:17 <alagalah> tfherbert: oooooh yeah
16:16:43 <alagalah> #topic Consumability
16:17:25 <alagalah> #info Upstreaming .. we have afredette tfherbert from RedHat who maybe able to give us insight on upstreaming ... and potentially if folks on from Canonical could make themselves known ...
16:17:35 <alagalah> tfherbert: Whats the process ?
16:18:06 <KeithWiles> Need to have a page with the proposed projects too and if they have been approved, just to make it simple to see them all. Did I miss this suggestion
16:18:15 <alagalah> KeithWiles: Great call
16:18:22 <edwarnicke> KeithWiles: Good point :)
16:19:41 <alagalah> #info tfherbert afredette Committed to making VPP work with CentOS et al but not 100% on the process
16:20:09 <alagalah> #action afredette (RedHat) to find out process/checklist for upstreaming RPM package
16:20:17 <alagalah> #undo
16:20:17 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x218dbd0>
16:20:32 <edwarnicke> KeithWiles: We do have a section on the project proposals page for  listing project proposals (and instructions to list your proposal there : )
16:20:35 <alagalah> #action afredette (RedHat) to find out process/checklist for upstreaming RPM package. Next week. Email pointers to RTM good enough
16:23:38 <cdl> BTW - the wiki says the TSC meetings are Thursday on the first logisitics line, and Tuesday on the second logistics line...
16:25:08 <edwarnicke> #info call for volunteers to getting rpms building as part of verify/merge
16:25:17 <KeithWiles> On my new install of 15.10 I had to revert to upstart from systemd
16:25:22 <edwarnicke> #info call for volunteers to get rpms pushed to yum repos are part of merge
16:25:44 <edwarnicke> KeithWiles: Any interest in making the deb packages smart enough to use systemd if installed on 15.10 ?
16:26:23 <edwarnicke> #info call for volunteers to get deb packages working well on Ubuntu 15.10 (upstart -> systemd, uio_igb -> uio-pci-generic
16:27:14 <edwarnicke> #chair ashyoung
16:27:14 <collabot`> Current chairs: DaveBarach afredette alagalah ashyoung edwarnicke joelhalpern
16:28:05 <alagalah> #info dmarion CLANG works
16:28:05 <edwarnicke> #info DaveBarach describes gcc 5.2 issues
16:29:13 <edwarnicke> #chair cj
16:29:13 <collabot`> Current chairs: DaveBarach afredette alagalah ashyoung cj edwarnicke joelhalpern
16:29:48 <KeithWiles> I used clang for DPDK all of the time, but it can have a minor performance reduction in some cases. I have not noticed the performance, but I have not been doing a lot of testing.
16:30:58 <alagalah> DaveBarach: Have we considered manpages too ?
16:31:07 <alagalah> DaveBarach: At least for CLI/API ?
16:31:45 <ashyoung> alagalah: Good idea
16:33:19 <edwarnicke> alagalah: I think manpages is a part of a larger question
16:33:24 <edwarnicke> alagalah: We have two kinds of docs we need
16:33:28 <edwarnicke> a) Dev docs
16:33:30 <edwarnicke> b) user docs
16:35:03 <KeithWiles> In DPDK the .rst files do have a lot text to describe details beyond APIs in the doxygen
16:35:43 <ashyoung> manpages are kind of a staple
16:36:05 <ashyoung> And I use doxygen in every project I touch
16:36:24 <ashyoung> Everything else is extra credit :)
16:36:27 <alagalah> edwarnicke: yes
16:36:46 <alagalah> Developers on, developers in, consumers (install;provision)
16:37:04 <ashyoung> Just started working with .rst
16:37:48 <edwarnicke> #info we need docs for "vpp developers" "vpp api users (like control plane)" "vpp deployers (people who just want to install and run it)"
16:38:10 <KeithWiles> DPDK got away from wiki as docs because you need to be online to view, so all of the docs are in the project and viewable without a network connection
16:38:56 <tfherbert> #info probably both a control plane and a data plane section at hackathon?
16:40:35 <ashyoung> agreed
16:41:48 <alagalah> tfherbert: What sort of split do you think ?
16:42:27 <alagalah> tfherbert: Gut feel is fine... 30 CP/ 70 DP ?
16:42:34 <alagalah> 20/80 ?
16:43:20 <tfherbert> tfherbert: CP requires a fare amount of learning curve.
16:43:38 <edwarnicke> tfherbert: Depends
16:43:47 <alagalah> tfherbert: Yeah... I'd humbly suggest that VPP isn't the place to come learn CP, but if you already know it ...
16:44:00 <edwarnicke> tfherbert: I think about it as three pieces : deveopment in the dataplane, development in the managemenet agent, development in the controller
16:44:27 <tfherbert> alagalah: I don't know what the split should be. They each have different issues. Right, but CP VPP specific. Dave covered it at session but we need more in depth I think.
16:46:06 <edwarnicke> tfherbert: Say more :)
16:46:19 <KeithWiles> Hyperscan is open source and could be used for a very good regex engine
16:46:49 <edwarnicke> #link https://gerrit.fd.io/r/#/c/327/ - tcp/udp checksum disabling patch mentioned
16:48:04 <KeithWiles> https://github.com/01org/hyperscan
16:50:25 <alagalah> joelhalpern: Why Joel, whatever are you referring to? :-P
16:53:34 <edwarnicke> #info joelhalpern points out we would be doing he world a service by talking about SFC SFF and SF correctly as we look at NSH
16:53:54 <edwarnicke> #info joelhalpern and edwarnicke spend some time agreeing emphatically about other subtleties ;)
16:54:02 <joelhalpern> Thanks Ed.
16:54:23 <edwarnicke> #link https://www.openhub.net/p/fdio -> commit velocity documentation
16:55:25 <alagalah> #info Very interested in the NETLINK project
16:56:16 <mdgray> +1 on Netlink project :)
16:56:25 <alagalah> mdgray: :)
16:56:56 <alagalah> mdgray: Is there a NETLINK proposal underway ? If not, lets start one... mdgray ?
16:58:16 <tfherbert> #info: I agree on packaging first+1
16:58:24 <mdgray> alagalah: I could help review any project but I don't have much time to commit to it
16:59:25 <edwarnicke> #info https://wiki.fd.io/view/Mature_Release_Process <- link to mature release processes
16:59:32 <afredette> edwarnicke : Is Honeycomb itself a project?
16:59:43 <edwarnicke> afredette: It will be :)
17:00:08 <edwarnicke> mdgray: You reviews are welcome :)
17:00:32 <edwarnicke> mdgray: Anyone can review patches :)
17:00:56 <edwarnicke> I would actually favor closer to a two month release cadence for VPP itself
17:01:01 <edwarnicke> Turn the crank fast and agile
17:01:57 <tfherbert> alagalah: afredette: hackfest Control plane breakout would be largely about Honecomb?
17:02:17 <alagalah> tfherbert: dunno I guess....
17:02:21 <mdgray> Is there any collateral available to reproduce the benchmarks that Maciek has done?
17:02:49 <edwarnicke> #info alagalah asks about how we number versions
17:03:20 <edwarnicke> #info alagalah suggests sematic versioning
17:04:41 <edwarnicke> #link https://datasift.github.io/gitflow/Versioning.html <- semantic versioning explained
17:04:51 <mdgray> edwarnicke: :)
17:04:56 <edwarnicke> #info other suggestions involved YY.MM versioning
17:05:53 <alagalah> #info edwarnicke No, I wasn't advocating it. I twas seeing Relase 1.0.0 on the Mature Relase Process and had questions
17:06:31 <alagalah> KeithWiles: Yeah... that was what I should have said to be clear... ABI
17:06:36 <alagalah> Within VPP
17:07:50 <alagalah> KeithWiles: Good with time based release numbering
17:08:09 <KeithWiles> Yes, I agree :-)\
17:08:16 <KeithWiles> Thanks
17:08:18 <tfherbert> Thanks everyone
17:08:26 <edwarnicke> #endmeeting