#fdio-vpp: vpp Weekly Meeting

Meeting started by edwarnicke at 16:00:37 UTC (full logs).

Meeting summary

  1. Agenda (edwarnicke, 16:02:54)
    1. https://wiki.fd.io/view/VPP/Meeting#Agenda <- Agenda link (edwarnicke, 16:02:59)

  2. Automated Functional / Performance Test update (edwarnicke, 16:06:09)
    1. mackonstan1 introduces himself (edwarnicke, 16:06:18)
    2. Functional Regression test overview (edwarnicke, 16:08:05)
    3. By end of this week, every vpp merge will run a regression (edwarnicke, 16:10:11)
    4. Will also plug into verify (edwarnicke, 16:10:18)
    5. https://jenkins.fd.io/view/csit/job/csit-vpp-functional-virl/ <- CSIT tests (edwarnicke, 16:12:37)
    6. test suites: https://jenkins.fd.io/view/csit/job/csit-vpp-functional-virl/68/robot/ (edwarnicke, 16:13:47)
    7. Performance Test overview (edwarnicke, 16:14:01)
    8. https://gerrit.fd.io/r/gitweb?p=csit.git;a=summary <- CSIT repo (edwarnicke, 16:16:58)
    9. question about dpdk integration (edwarnicke, 16:18:20)
    10. DaveBarach suggested just push a patch pointing to a different DPDK tarball, and the verify job should check it (edwarnicke, 16:18:38)
    11. https://lists.fd.io/mailman/listinfo/csit-dev <- csit mailer (edwarnicke, 16:20:56)

  3. Open Items for Review (edwarnicke, 16:21:10)
    1. any progress on process for upstreaming an rpm (edwarnicke, 16:21:26)
    2. afredette has talked to dfarrel07 from RH and he has expressed interest there (edwarnicke, 16:21:45)
    3. process for upstreaming Ubuntu debian packaging (edwarnicke, 16:22:46)
    4. request for volunteers for netlink project (edwarnicke, 16:25:16)
    5. https://nexus.fd.io/#nexus-search;quick~vpp <- nexus.fd.io with vpp deb pkgs - currently csit functional regression executed against build 1.0.0-185~gca0f3b3 (mackonstan1, 16:26:21)
    6. request for states in jira: INFO, JUNK, CLOSED, etc (edwarnicke, 16:26:50)
    7. ACTION: DaveBarach to email list about Jira states (edwarnicke, 16:27:08)
    8. https://jenkins.fd.io/view/vpp/job/vpp-merge/174/console <- first priority for csit job triggers are vpp-merge jobs, here is the latest (mackonstan1, 16:28:00)
    9. https://confluence.atlassian.com/adminjiraserver070/defining-status-field-values-749382903.html <- Bug Status can be done (edwarnicke, 16:28:15)

  4. Staticly linking vpp executable against network stack (edwarnicke, 16:28:43)
    1. https://jenkins.fd.io/view/vpp/job/vpp-verify/ <- we are then looking to plug into vpp-verify jobs (mackonstan1, 16:28:51)
    2. https://jenkins.fd.io/view/csit/job/csit-vpp-functional-virl/ <- here latest csit functiona tests executed on LF hosted VIRL 3-node topology (mackonstan1, 16:30:16)
    3. static linking of network stack under consideration, would have to be tested heavily to make that switch (edwarnicke, 16:30:52)
    4. execution time of csit-vpp-functional-virl tests - currently < 3.5min (mackonstan1, 16:31:18)

  5. Code Base Activity report (edwarnicke, 16:39:06)
    1. Patch Cisco VIC (enic) PMD TX path (edwarnicke, 16:42:13)
    2. Add MTU info to binary API (sw_interface_dump) (edwarnicke, 16:42:23)
    3. Fix vpp handling of DPDK-2.2.0 buffer metadata bits [ip6 pkts ending up in ip4 path] (edwarnicke, 16:42:32)
    4. Per-interface, per address-family fast packet whitelist / blacklist (edwarnicke, 16:42:44)
    5. Jumbo frame support for non-dpdk (vhost) interfaces (edwarnicke, 16:42:55)
    6. Show dpdk EAL arguments in "show version verbose" (edwarnicke, 16:43:05)

  6. Consumability (edwarnicke, 16:43:12)
    1. DPDK tarball download failures (edwarnicke, 16:43:30)
    2. tfherbert is seeing it too (edwarnicke, 16:43:40)
    3. suggestion to put dpdk tarball in git repo (edwarnicke, 16:45:13)
    4. ACTION: edwarnicke to see about mirroring dpdk tarball to fd.io nexus server (edwarnicke, 16:45:32)
    5. suggestion made to clone dpdk and set tag to desired release (edwarnicke, 16:46:31)
    6. DaveBarach suggested possibly retry logic for downloading dpdk tarball (edwarnicke, 16:46:47)
    7. ACTION: jmcnamara will look into DPDK download site (edwarnicke, 16:48:02)
    8. idea of netlink agent project is to provide a netlink agent so that existing user space tools via a LDPRELOAD hack can talk to vpp (edwarnicke, 16:53:38)


Meeting ended at 16:54:21 UTC (full logs).

Action items

  1. DaveBarach to email list about Jira states
  2. edwarnicke to see about mirroring dpdk tarball to fd.io nexus server
  3. jmcnamara will look into DPDK download site


Action items, by person

  1. DaveBarach
    1. DaveBarach to email list about Jira states
  2. edwarnicke
    1. edwarnicke to see about mirroring dpdk tarball to fd.io nexus server
  3. jmcnamara
    1. jmcnamara will look into DPDK download site


People present (lines said)

  1. edwarnicke (61)
  2. collabot` (8)
  3. ashyoung_ (6)
  4. mackonstan1 (6)
  5. tfherbert (3)
  6. keith_wiles (3)
  7. jmcnamara (2)
  8. KeithWiles (0)
  9. afredette (0)
  10. dmarion (0)
  11. DaveBarach (0)


Generated by MeetBot 0.1.4.