#fdio-vpp: VPP Weekly Call

Meeting started by edwarnicke at 14:59:52 UTC (full logs).

Meeting summary

    1. https://wiki.fd.io/view/VPP/Meeting#Agenda <- Agenda (edwarnicke, 15:00:17)

  1. CSIT testing (edwarnicke, 15:04:59)
    1. skobza reports on CSIT state (edwarnicke, 15:05:33)
    2. I'm present but not going to join audio (alagalah, 15:13:04)
    3. https://wiki.fd.io/view/Project_Proposals/CSIT (edwarnicke, 15:15:30)
    4. https://wiki.fd.io/view/TSC#2016-03-17 <- Scheduled for TSC Creation Review Thursday Mar 17, 2016 (edwarnicke, 15:16:42)
    5. [csit] Test suites currently present for functional tests: bridge domain, l2 xconnect, V4, V6, VXLAN with BD, VXLAN with L2 xconnect. All tests only Eth, no dot1.q (skobza, 15:19:16)
    6. [csit] Test suites currently present for performance tests: short_bridge_domain, short_ipv4, short_xconnect and proposed long_bridge_domain (https://gerrit.fd.io/r/#/c/515/) (skobza, 15:19:54)
    7. ACTION: cj to file Debian ITP (Intent to Package) as first step to getting into Debian (edwarnicke, 15:27:32)
    8. https://wiki.fd.io/view/TSC#Future_Agenda_Items <- Future Agenda Items of the TSC (edwarnicke, 15:28:11)

  2. dpdk changes (edwarnicke, 15:32:29)
    1. dpdk in release candidate stage, so only things that went in after that are going in (edwarnicke, 15:32:47)
    2. headroom changes will not make it into 16.04, might make it into the next release (edwarnicke, 15:33:11)

  3. things being worked on (edwarnicke, 15:34:38)
    1. sharing adjacencies in fib (edwarnicke, 15:34:48)
    2. For DPDK changes the normal method is to submit a patch for that change and allow the group to discuss, then ACK or NAK the patch. (keith_wiles, 15:36:27)

  4. consumability (edwarnicke, 15:38:41)
    1. changing the HEADROOM size is most likely a ABI change, which takes two releases to get into the code base. The first release is a ABI change notice then it can be added to the next release. If you get the notice in 16.04 then 16.07 could be the next release with the change. Not sure if we have missed the deadline for ABI changes in 16.04. (keith_wiles, 15:38:52)


Meeting ended at 15:54:45 UTC (full logs).

Action items

  1. cj to file Debian ITP (Intent to Package) as first step to getting into Debian


Action items, by person

  1. cj
    1. cj to file Debian ITP (Intent to Package) as first step to getting into Debian


People present (lines said)

  1. edwarnicke (43)
  2. collabot` (7)
  3. keith_wiles (5)
  4. cj (4)
  5. skobza (2)
  6. alagalah (2)
  7. dmarion (0)
  8. DaveBarach (0)


Generated by MeetBot 0.1.4.