#fdio-vpp: VPP 4/26

Meeting started by alagalah at 15:03:31 UTC (full logs).

Meeting summary

  1. Sign in :D (alagalah, 15:03:38)
    1. Chris Luke (Chrisy, 15:03:40)
    2. Keith Wiles (keith_wiles, 15:03:41)
    3. Markus Magnusson (MarkusMagnusson, 15:03:48)
    4. Dave Barach (DaveBarach, 15:03:50)
    5. alagalah (Keith Burns) (alagalah, 15:03:55)
    6. https://wiki.fd.io/view/VPP/Meeting#Agenda Agenda (alagalah, 15:04:32)

  2. CSIT - dpdk-16.04 success story ( (alagalah, 15:05:47)
    1. DaveBarach made change for migrating from DPDK 2.02 to 16.04 (alagalah, 15:06:13)
    2. mackonstan1 Discusses publishing CSIT code release ( ???) (alagalah, 15:07:02)
    3. mackonstan1 Clarifies above, discussion within project to create a CSIT Release Plan (alagalah, 15:07:41)
    4. mackonstan1 will discuss at CSIT Project meeting tomorrow (alagalah, 15:07:57)
    5. https://jira.fd.io/secure/RapidBoard.jspa?rapidView=1 CSIT KanBan in JIRA (alagalah, 15:08:58)
    6. https://wiki.fd.io/view/CSIT/FuncTestPlan CSIT VPP functional test cases (mackonstan1, 15:10:00)
    7. Honeycomb readout from marek_ (alagalah, 15:10:03)
    8. gerrit patches in there JNI (alagalah, 15:10:28)
    9. ACTION: alagalah and Dwallace will review hc related vpp patches this morning (alagalah, 15:11:02)
    10. NSH_SFC readout. Pulling NSH specific things out of VPP and into NSH_SFC this week. Simplistic design below (alagalah, 15:12:43)
    11. https://wiki.fd.io/view/NSH_SFC/Docs/Designs NSH into NSH_SFC (alagalah, 15:12:53)

  3. TWS meeting next week (alagalah, 15:14:02)
    1. https://lists.fd.io/pipermail/discuss/2016-April/000061.html Documentation is next week (alagalah, 15:14:09)
    2. email coming from alagalah to discuss/tsc to get some ideas going pre-TWS next week (alagalah, 15:15:13)

  4. Using JIRA (alagalah, 15:16:06)
    1. how do we track what folks are working on. (alagalah, 15:16:15)
    2. Dave and Chris discuss how to tackle CLI patches (florinc, 15:18:38)

  5. VPP release 16.06 planning (florinc, 15:19:13)
    1. CJ and Ed working on building repo for Ubuntu (florinc, 15:19:55)
    2. repository should be available sometime later this week (florinc, 15:20:26)
    3. Damjan thinks RIB updates are too risky before the release (florinc, 15:24:10)
    4. switched to DPDK 16.04 as of this morning (florinc, 15:24:38)
    5. CLI improvements will probably get in before freeze (florinc, 15:25:19)

  6. upcoming changes (alagalah, 15:25:53)
    1. florinc discusses pushing his LISP ONE changes by end of week (pursuant with F0) (alagalah, 15:26:17)
    2. dave barach comments that folks are getting patchsets in (alagalah, 15:26:50)
    3. Chris would like everyone to exercise the CLI once merged. There is plenty of opportuinty for off-by-one issues. (Chrisy, 15:26:51)
    4. alagalah and DaveWallace to review Honeycomb (alagalah, 15:27:43)
    5. John Lo has reviewed Gerrit 873 by Chrisy (alagalah, 15:28:14)
    6. https://gerrit.fd.io/r/#/c/873/ John reviewing after meeting for his +1 (alagalah, 15:29:06)
    7. alagalah has a generalised zero memcpy packet replicator as part of his ip6 SR multicast spray case (alagalah, 15:33:38)
    8. ACTION: alagalah to make a table of committers on vpp wiki with their self-identified areas of review-expertise. Committers please update (alagalah, 15:37:08)
    9. https://jira.fd.io/browse/HONEYCOMB-25 JIRA VPP ticket for Java7 has a HC JIRA related: (alagalah, 15:41:30)
    10. Java7 is a blocker for the HC project so they are motivated to address this (alagalah, 15:41:58)

  7. code base activity (alagalah, 15:51:09)
    1. as per agenda https://wiki.fd.io/view/VPP/Meeting#Agenda no major issues with these. (alagalah, 15:51:45)
    2. JLo talked about a code-fix for BVI not on the list that was kind of nice (alagalah, 15:51:59)
    3. https://gerrit.fd.io/r/#/c/851/ Cool BVI change merged (alagalah, 15:52:29)


Meeting ended at 15:58:49 UTC (full logs).

Action items

  1. alagalah and Dwallace will review hc related vpp patches this morning
  2. alagalah to make a table of committers on vpp wiki with their self-identified areas of review-expertise. Committers please update


Action items, by person

  1. alagalah
    1. alagalah and Dwallace will review hc related vpp patches this morning
    2. alagalah to make a table of committers on vpp wiki with their self-identified areas of review-expertise. Committers please update


People present (lines said)

  1. alagalah (41)
  2. florinc (8)
  3. collabot` (8)
  4. Chrisy (3)
  5. tmonjalo (2)
  6. MarkusMagnusson (1)
  7. mackonstan1 (1)
  8. DaveBarach (1)
  9. keith_wiles (1)
  10. ppfister (0)
  11. dbarach (0)


Generated by MeetBot 0.1.4.