14:55:55 <DaveBarach> #startmeeting fdio vpp
14:55:55 <collabot> Meeting started Tue Aug  9 14:55:55 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:55:55 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:55:55 <collabot> The meeting name has been set to 'fdio_vpp'
15:03:22 <DaveBarach> #info maciek giving CSIT status
15:03:49 <DaveBarach> #info 82599 patch fixed gross perf hit (no packet classification)
15:04:09 <DaveBarach> #info 2.5% slower w/ dpdk-16.07 vs dpdk-16.04, csit guys investigating
15:05:55 <DaveBarach> #info Florin looking into lisp fail on cdp coding standards cleanup
15:07:02 <DaveBarach> #info maciek away for 2.5 weeks (PTO), Dave Wallace and Miro Miklus will act as CSIT PTL
15:07:34 <dwallacelf> #info dwallacelf on PTO 8/23 - 8/30
15:07:44 <DaveBarach> #info Marek reporting on Honeycomb
15:08:14 <DaveBarach> #info Honeycomb to intro support for ACL, L2, L3
15:09:13 <DaveBarach> #info Keith reports on NSH / SFC.
15:10:40 <DaveBarach> #info Intel folks needing some Honeycomb changes to be pushed
15:11:51 <DaveBarach> #info Honeycomb commit in progress to use NSH jar-file
15:12:18 <DaveBarach> #action Marek to write description how to test
15:12:44 <DaveBarach> #info Florin reporing on one/LISP
15:13:03 <DaveBarach> #info working through Jira list - multihoming patch expected soon
15:13:14 <DaveBarach> #info control-plane impl for source/dest
15:13:17 <DaveBarach> #info code hardening
15:13:45 <DaveBarach> #info Pierre reporting on sandbox
15:13:50 <DaveBarach> #info new committers
15:14:00 <DaveBarach> #info Keith pushed demo framework to sandbox
15:14:22 <DaveBarach> #info new project(s) on tap interfaces expected soon
15:14:51 <DaveBarach> #info TDLK and DPDK packaging ed catching up after PTO
15:15:17 <cpaelzer> let me know if you want an interim update on DPDK packaging
15:15:25 <DaveBarach> #info Time for the Keith Burns show... (:-)...
15:16:20 <DaveBarach> #info TWS cancelled for today
15:16:41 <DaveBarach> #info hoping to hear from small-form-factor dpdk conference demo guys e.g. next time
15:17:11 <DaveBarach> #info calico integration underway. Matt Johnson working on multi-host ipv6 support
15:17:28 <DaveBarach> #info calico/vpp demo at Linux Conference in Toronto in two weeks
15:18:14 <DaveBarach> #info Contiv integration complete; Nikos B. had surgery to deal with appendicitis
15:20:05 <DaveBarach> #info vpp 16.09 release planning
15:20:27 <DaveBarach> #info Ed documented release process "paint by numbers"
15:20:38 <DaveBarach> #info which bits can we test beforehand?
15:22:06 <DaveBarach> #info dry-runing release repo creation is problematic
15:22:32 <DaveBarach> #info create / delete / recreate on nexus repos is almost certain to cause issues
15:22:37 <DaveBarach> #info "so don't do that..."
15:24:00 <DaveBarach> #info 18 to-do items on the Kanban board, 16 in progress
15:24:33 <DaveBarach> #info doxygen and coding style cleanups in progress, as agreed
15:25:15 <DaveBarach> #info please jump in and help!
15:47:57 <edwarnicke> #link https://gerrit.fd.io/r/#/c/2235/ <- script that will enable checkstyle on verify
15:49:43 <DaveBarach> #info coding style process review w/ Keith
15:50:26 <edwarnicke> alagalah: If you will provide links, I'll put them in the error echo from the verify checkstyle.sh script
15:54:02 <DaveBarach> #action Keith to send links to "how to fix coding style" wiki page to Ed
15:55:49 <DaveBarach> #info keith asks if we can avoid re-running verify when patches move from draft to public
15:55:58 <DaveBarach> #info Ed replies that he doesn't know
16:00:26 <DaveBarach> #info keith mentions that we should schedule a design session for early in the 16.12 release cycle
16:01:13 <DaveBarach> #info discuss tools to support design sessions, breakouts
16:02:56 <DaveBarach> #endmeeting