15:02:14 <alagalah> #startmeeting VPP
15:02:14 <collabot> Meeting started Tue Sep 20 15:02:14 2016 UTC.  The chair is alagalah. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:14 <collabot> The meeting name has been set to 'vpp'
15:02:14 * Chrisy gives up :)
15:02:21 <alagalah> #info alagalah #link https://www.youtube.com/watch?v=StTqXEQ2l-Y
15:02:29 <alagalah> #topic CSIT
15:02:50 <DaveBarach> #topic CSIT report from Maciek
15:02:53 <alagalah> #info mackonstan1 states that he needs min. 3 CSIT Perf Runs  to get results cIST needs
15:03:13 <alagalah> #info this will take 3 days (target Thu) barring infra incident
15:03:13 <DaveBarach> #info draft 16.09 CSIT perf report should be available weds-thurs
15:03:19 <alagalah> ok .. I'll stop
15:03:28 <DaveBarach> no, please go ahead
15:03:32 <alagalah> ack
15:04:16 <alagalah> #info DaveBarach asks for diff between 16.06 v 16.09 performance
15:05:05 <alagalah> #info mackonstan1 16.09 for IPv6 from 8-10Mpps to 10-12 Mpps core XL520 but don't have XL710 ...
15:05:25 <alagalah> #info CPU not that relevant as its comparative on same baseline... but normally one would quote the CPU specs
15:06:06 <alagalah> #topic Honeycomb
15:06:45 <alagalah> #info marek gradzki reports that infra issues they were experiencing yesterday appear to have alleviated... so can plan for release tomorrow... needs NSH JAR
15:07:04 <alagalah> #info edwarnicke NSH_SFC 16.09 JAR is being pushed into the repo (LF Infra).
15:07:50 <DaveBarach> #topic NSH/SFC report from Keith
15:08:06 <DaveBarach> #info thanks to Ed for a variety of infra work
15:09:12 <DaveBarach> #info hongjun will be testing nsh/sfc artifacts
15:10:44 <DaveBarach> #topic Florin reports on ONE-LISP
15:10:58 <DaveBarach> #info work w/ honeycomb on l2 integration
15:11:09 <DaveBarach> hey alagalah wanna take notes?
15:12:04 <DaveBarach> #topic Keith reporting on Sandbox
15:12:28 <DaveBarach> #info demo app gui pushed [thanks to Arris]
15:12:31 <alagalah> :)
15:14:40 <alagalah> #topic TLDK
15:14:54 <alagalah> #info edwarnicke reports patches coming soon, project is moving forward
15:15:04 <alagalah> #topic DPDK Deb packaging
15:15:19 <alagalah> #info edwarnicke folks are contributing but I must admit I missed the comment completely
15:15:33 <alagalah> #topic re-hash of Pierre's work with vhost-user
15:15:45 <alagalah> #info ray asks about more context as the DPDK folks are also testing
15:15:53 <edwarnicke> #info deb_dpdk project is setting up jenkins jobs for verify and merge
15:16:11 <alagalah> #info dmarion reports that they are testing and optimising the exiting vpp vhost implementation
15:16:45 <alagalah> #info ray reports that some DPDK folks are testing/coding to modify DPDK vhost-user with a goal of deprecating VPP vhost-user
15:17:36 <alagalah> #info ray asks if there can be a meeting regarding the direction of VPP and DPDK vhost-user to co-ordinate resource efforts
15:19:14 <alagalah> #info DaveBarach points out that converged effort makes sense, but need to ensure that there's communication. ie last release vhost-user implementation in DPDK was a bit of a surprise. Ray agrees, lesson learned, and we should now co-ordinate...
15:19:34 <alagalah> #info Agreed that there should be a more co-ordinated effort.
15:21:27 <tfherbert> #info but ultimately we agree that we should converge to upstream DPDK providing vhost-user, don't we?
15:23:00 <alagalah> #action DaveBarach and ray to organise a follow up call re: vhost-user in VPP and DPDK
15:26:39 <alagalah> #topic FIB2.0
15:27:07 <alagalah> #info Neale making progress on API changes to things relying on existing FIB... but he is traveling on business next week ...
15:27:43 <alagalah> #info dmarion says his preference this patch goes in sooner rather than later (not clear as to who needs this in now?) but ...
15:28:12 <alagalah> #info DaveBarach suggests that we have a follow up meeting or make a decision as to merge before Neale goes on biz travel... or after....
15:32:31 <alagalah> #info Decided that patch will be merged after short-perf-run
15:47:26 <alagalah> #topic fdio mini-summit
15:47:37 <alagalah> #info Chrisy is going... that is all... carry on :)
15:47:40 <alagalah> #info Register soon!
15:49:46 <alagalah> #topic Release NEXT
15:50:07 <alagalah> #info dmarion is release manager for "17.01" ... discussing 16.12 v 17.01
15:50:37 <alagalah> #info general discussion last week was 17.01 makes more sense from a risk perspective than 16.12 since DPDK 16.11 is a target dependency... and there is typical Christmas slowdown/shutdown
15:51:02 <alagalah> #link https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_17.01 Proposed Release Plan
15:53:05 <alagalah> #topic Docs
15:53:43 <alagalah> #link https://docs.fd.io/vpp/16.09/md_RELEASE.html Docs
15:53:55 <alagalah> #undo
15:53:55 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2da3090>
15:54:11 <alagalah> #link https://docs.fd.io/vpp/16.09/ Docs
15:56:25 * alagalah respin == force choke
16:02:03 <DaveBarach> #endmeeting
16:02:13 * alagalah drops mic
16:02:15 <alagalah> :)
16:02:30 <alagalah> Hmmmm
16:02:33 <alagalah> No link spew ?
16:02:36 <alagalah> #endmeeting