14:59:53 <DaveBarach> #startmeeting fdio vpp
14:59:53 <collabot> Meeting started Tue Oct 11 14:59:53 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:53 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:59:53 <collabot> The meeting name has been set to 'fdio_vpp'
15:00:18 <dwallacelf> #info Dave Wallace
15:01:41 <DaveBarach> #topic Maciek reporting on CSIT
15:01:54 <DaveBarach> #info in the process of upgrading to Ubuntu 16.04
15:02:31 <DaveBarach> #info hoping to switch to 16.04 to production tomorrow
15:02:56 <DaveBarach> #info operating at reduced capacity due to upgrade, patience requested
15:03:45 <DaveBarach> #info unit test framework draft in Gerrit (damjan reporting)
15:03:46 <tfherbert> #info TFHerbert
15:04:24 <DaveBarach> #info doxygen issues w/ Python code
15:05:16 <DaveBarach> #info looking for agreement on how to document tests
15:05:36 <DaveBarach> #info Chris says "doxygen wasn't designed for Python"
15:09:10 <edwarnicke> #info looks like Sphinx is the cool kid for Python API documentation
15:09:28 <edwarnicke> #info and there are some rumblings about getting Sphinx and doxygen to play nice
15:09:56 <DaveBarach> #info Take discussion to the "discuss" list.
15:10:25 <DaveBarach> #info dpdk uses Sphinx
15:10:43 <DaveBarach> #topic Marek Gradzki on Honeycomb
15:11:21 <DaveBarach> #info infra issues largely resolved
15:11:26 <DaveBarach> #info snat support in review
15:11:48 <DaveBarach> #topic Keith Burns NSH/SFC report
15:12:01 <DaveBarach> #info trying to move the project call
15:12:21 <DaveBarach> #info Classifier discussions, would like to tie into vpp policy epic
15:12:44 <DaveBarach> #info multiple policy efforts, would like to unify as best we can
15:12:59 <DaveBarach> #info need to sort out CSIT
15:13:12 <DaveBarach> #topic Florin reports on ONE-LISP
15:13:20 <DaveBarach> #info fixing APIs for HC
15:13:46 <DaveBarach> #info ODL integration in process, should complete soon
15:14:04 <DaveBarach> #info integration more complicated than originally anticipated
15:14:22 <DaveBarach> #info no sandbox report this week
15:14:39 <DaveBarach> #topic Keith Wiles reporting on TLDK
15:14:50 <DaveBarach> #info code push this week, meeting tomorrow at normal time
15:15:20 <DaveBarach> #topic Ed reporting on DPDK packaging
15:15:32 <DaveBarach> #info polishing packages
15:16:06 <DaveBarach> #topic RPM packaging Tom Herbert reporting
15:16:20 <DaveBarach> #info working on vpp packaging for CentOS
15:17:08 <DaveBarach> #info various changes required to upstream, mostly minor by the sound of it
15:18:34 <DaveBarach> #info need source RPM, diffs, build-from-scratch from .gzip file
15:20:29 <DaveBarach> #topic LF infra status, Ed reporting
15:22:55 <DaveBarach> #info ssh timeouts resolved by turning on tcp keepalives
15:22:56 <DaveBarach> #info ed monitoring job queues
15:22:57 <DaveBarach> #info Honeycomb merge job failures under investigation
15:23:03 <DaveBarach> #topic Damjan on 17.01 release planning
15:24:02 <DaveBarach> #action dbarach to update doc wiki on minor poit
15:26:09 <DaveBarach> #info new global functions, CLI commands, VLIB_CONFIG_FUNCTIONs all need doc strings
15:28:28 <DaveBarach> #info Chris working on straightening out Coverity run
15:31:40 <DaveBarach> #topic Consumability
15:32:06 <DaveBarach> #info Ed trying to switch to more automated infra monitoring
15:33:13 <DaveBarach> #info if you remove fd.io jjb and +1 verify a patch, the merge job report won't happen
15:34:24 <DaveBarach> #endmeeting