14:58:22 <DaveBarach> #startmeeting fdio vpp
14:58:22 <collabot`> Meeting started Tue Nov  1 14:58:22 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:22 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:22 <collabot`> The meeting name has been set to 'fdio_vpp'
14:58:47 <dwallacelf> #info Dave Wallace
14:59:02 <tfherbert> #info TF Herbert
15:02:52 <DaveBarach> #info public holiday today in much of Europe
15:03:06 <DaveBarach> #topic CSIT Maciek Reporting
15:05:54 <DaveBarach> #info most perf metrics increased w/ csit transition from 14.04 -> 16.04
15:06:02 <mackonstan> #link https://wiki.fd.io/view/CSIT/VPP-ubuntu-compare-1404to1604
15:20:14 <DaveBarach> #topic nsh/sfc
15:21:13 <DaveBarach> #info request to cherry-pick / re-cut 16.09 release, none of the players on the call
15:23:23 <DaveBarach> #info commmunity policy meeting upcoming (Keith, Ole, Hongjun)
15:23:56 <DaveBarach> #topic Florin reports on ONE-LISP
15:24:07 <DaveBarach> #info control-plane protocol work in progress
15:24:44 <DaveBarach> #topic Keith reports on sandbox
15:25:39 <DaveBarach> #info flowlet switching patch uploaded to sandbox
15:26:53 <DaveBarach> #topic TLDK report
15:27:20 <DaveBarach> #info dwallace reports that last week's TLDK mtg was very short
15:27:59 <DaveBarach> #info keith burns reports on a Friday follow-up with Ray K.; interesting DDoS mitigation design
15:28:38 <DaveBarach> #topic DPDK packaging Tom Herbert reporting
15:29:00 <DaveBarach> #info initial commit done
15:29:40 <DaveBarach> #info build diff .gzip, which could help w/ upstream tarball download
15:33:44 * alagalah lots of telnet :7 :D
15:35:35 <DaveBarach> #topic Documentation
15:36:22 <alagalah> #info alagalah commented that we made big improvements in Docs in general in VPP 16.09 but its necessary but not sufficient to meet the punters needs.
15:36:58 <alagalah> #info For instance, we have a great doxygen generation system but folks need a decent User Guide and we need an API Users Guide
15:37:28 <alagalah> #info we have lots of tutorials etc for Developers IN VPP (YouTube, DevBoot etc) but we need to address consumability
15:38:16 <alagalah> #info the broader question is do we want VPPCTL to be the interface of record for these User Guides or should we be looking at things like HoneyComb to provide some user docs from a RESTCONF perspective
15:38:26 <alagalah> #topic API refactor
15:38:59 <alagalah> #info DaveBarach notes that he has been addressing the vpe.api size ... this is a common cause of patch git conflict
15:39:27 <alagalah> #info DaveBarach Notes that there is a DRAFT patch that folks can view on request, it isn't published due to it not building and not wanting to waste build cycles.
15:40:51 <alagalah> #topic Coverity static analysis
15:41:05 <alagalah> #info we have 55 issues ... there is a JIRA ticket (looking it up)
15:43:57 <alagalah> #link https://jira.fd.io/browse/VPP-486 Coverity JIRA 17.01
15:44:01 <tfherbert> #info +1 on user guide.
15:44:05 <alagalah> #topic consumability
15:47:56 <alagalah> #action alagalah needs to follow up with DPDK team to see if they still want VPP to present at DPDK devboot this month
15:48:11 <alagalah> DaveBarach: you want to end meeting ?
15:48:17 <DaveBarach> #endmeeting