16:00:57 <DaveBarach> #startmeeting fdio vpp
16:00:57 <collabot> Meeting started Tue Dec 20 16:00:57 2016 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:57 <collabot> The meeting name has been set to 'fdio_vpp'
16:01:11 <tfherbert> #info Tom Herbert
16:03:47 <DaveBarach> #topic Jan G reporting on CSIT
16:03:55 <DaveBarach> #info working on "make test"
16:04:14 <mortderire> morning folks
16:05:37 <DaveBarach> #topic Marek Gradzki on Honeycomb
16:05:43 <DaveBarach> #info API freeze last week
16:05:49 <DaveBarach> #info RC1 in ~2 weeks
16:05:58 <DaveBarach> #info ACL plugin support should be there
16:08:40 <DaveBarach> #info Ed describing honeycomb branch pull in general
16:08:48 <DaveBarach> #action marek to ping Ed Warnicke offline
16:10:32 <DaveBarach> #action Damjan to work with Ed on vpp RC1 throttle pull mechanics
16:11:30 <DaveBarach> #topic no NSH/SFC report
16:11:41 <DaveBarach> #topic Florin reports on ONE-LISP
16:11:48 <DaveBarach> #info not much to report, bugfixes, everything OK
16:12:02 <DaveBarach> #topic sandbox no report Pierre not on call
16:12:32 <DaveBarach> #topic TLDK Dave B reporting
16:18:52 <DaveBarach> #topic DPDK packaging Tom H reporting
16:19:03 <DaveBarach> #info working on CentOS virl image
16:19:32 <DaveBarach> #info work out details w.r.t. patches, what happens in fd.io repo vs. CentOS repo
16:19:43 <DaveBarach> #info hope to resolve questions by 1/1
16:20:15 <DaveBarach> #topic Ed reporting on LF infra
16:20:48 <DaveBarach> #info switchover to packer took longer than expected
16:22:32 <DaveBarach> #info things actually have gone smoothly, back working now
16:23:28 <DaveBarach> #topic Damjan on 17.01 release planning
16:26:09 <DaveBarach> #info everything on track for the RC1 pull
16:26:29 <DaveBarach> #info backlog of commits to go into master after the release throttle pull
16:29:28 <DaveBarach> #action Jan G to work with Damjan on csit for 17.01 release throttle
16:30:51 <DaveBarach> #info Damjan describes MAINTAINERS file approach
16:31:09 <DaveBarach> #info area experts to provide +1 prior to patch merge
16:35:35 <DaveBarach> Ed, pls chuck into IRC...
16:35:55 <DaveBarach> #link https://wiki.fd.io/view/VPP/Committers/SMEs
16:41:09 <DaveBarach> #action Damjan to email dev list on MAINTANERS file or other scheme to endure timely patch reviews
16:41:44 <DaveBarach> #topic "make test"
16:41:56 <DaveBarach> #info stability changes required
16:42:10 <DaveBarach> #info tests tripping over ipv6 / MLD packets
16:42:54 <DaveBarach> #info Klement: describing issues
16:43:35 <DaveBarach> #info MPLS when pg started, clear trace can crash vpp due to timing
16:45:29 <DaveBarach> #info discussion about %s vs %v => garbage characters in output
16:46:31 <DaveBarach> #topic Vagrant status, Ed reporting
16:46:44 <DaveBarach> #info ongoing problems
16:46:59 <DaveBarach> #info real requirement: rapid onboarding
16:47:23 <DaveBarach> #info Vagrant works badly on windows, OK on Macs, not really useful on Linux
16:49:53 <DaveBarach> #info Ray observes that even prebuilt OVAs, boxes aren't a panacea
16:51:13 <DaveBarach> #info Tom H observes Vagrant is an 80% solution
16:52:11 <DaveBarach> #info Tom suggests a TWS call to discuss alternatives
16:53:04 <DaveBarach> #info Dave Wallace sent email: summary.. Packer seems like a reasonable way to generate a reproducible environment
16:54:01 <DaveBarach> #info Tom H observes that the learning-curve for Packer is non-zero
16:55:42 <DaveBarach> #info DaveBarach suggests picking one environment and supporting it
17:00:07 <DaveBarach> #link https://wiki.fd.io/view/VPP/Pulling,_Building,_Running,_Hacking_and_Pushing_VPP_Code
17:01:41 <DaveBarach> #info Dave Wallace suggest using packer to generate template images
17:02:21 <DaveBarach> #info Ed mentions that ci-management already has a working packer setup for vpp
17:03:11 <DaveBarach> #info multiple folks +1 on leveraging the ci-managment packer setup
17:05:11 <DaveBarach> #agreed to figure out how to leverage the ci-management packer setup
17:05:40 <DaveBarach> #action Dave Wallace to investigate
17:07:48 <DaveBarach> #action Damjan to ping people to finish cleaning up Coverity warnings
17:08:32 <DaveBarach> #action Marek to check outstanding Coverity warnings in java code
17:09:51 <DaveBarach> #endmeeting