#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 14:51:41 UTC (full logs).

Meeting summary

  1. agenda additions (DaveBarach, 14:51:59)
    1. Dave Wallace (dwallacelf, 14:59:09)

  2. csit Dave Wallace reporting (DaveBarach, 15:01:50)
    1. 17.07 report 90% automatically generated (DaveBarach, 15:02:05)
    2. ACTION: Dave Wallace to ask csit team about deprecating virl testing (DaveBarach, 15:04:38)
    3. virl needs dpdk patch to avoid MSIX interrupt hassle (DaveBarach, 15:05:28)
    4. topic Honeycomb - Marek reporting (jong_, 15:06:11)
    5. HC 17.07 released, without major issues (DaveBarach, 15:06:27)
    6. working on NAT64, LISP improvements (DaveBarach, 15:06:38)
    7. some issues with ODL integration (DaveBarach, 15:06:48)
    8. ACTION: dbarach ask ray about NSH / SFC info from Danny (DaveBarach, 15:07:52)
    9. map server fallback if > 1 server configured (DaveBarach, 15:09:03)
    10. adding apis for 17.10 (DaveBarach, 15:09:13)

  3. TCP / host stack (DaveBarach, 15:09:51)
    1. active-open thread-safe data structures, multi-thread builtin active-open client (DaveBarach, 15:10:25)
    2. session / transport layer cleanups (DaveBarach, 15:10:54)
    3. tx buffer allocation cleanup (DaveBarach, 15:11:00)
    4. horizontal session scaling result: 2x core (client, server) 2M sessions, 200K setups/sec (DaveBarach, 15:17:49)

  4. DPDK packaging Tom H reporting (DaveBarach, 15:18:11)
    1. now building 17.08-rc0 (DaveBarach, 15:18:20)
    2. want these packages to work with Centos, Rel (DaveBarach, 15:18:46)
    3. don't want to break legacy build system (DaveBarach, 15:19:29)
    4. enable folks to build local packages for local install (DaveBarach, 15:19:42)
    5. 17.07.1 will ship when ACL plugin work (Andrew Y) is ready (DaveBarach, 15:21:22)
    6. 17.10 release plan added (DaveBarach, 15:22:02)
    7. some deliverables listed, please give Florin a list of expected features (DaveBarach, 15:22:29)
    8. container POC: hard drive failure, need to reimage (DaveBarach, 15:23:14)
    9. Marek on Coverity complaints re: java API (DaveBarach, 15:26:36)
    10. ACTION: dbarach to write email re: coverity java complaints (DaveBarach, 15:27:05)
    11. we tried to disable coverity for java built artifacts, bug supposedly "to be fixed..." (DaveBarach, 15:28:24)
    12. will try zoom for next meeting (jong_, 15:30:18)
    13. 17.10 release plan: https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_17.10 (florinc_, 15:31:32)

  5. Billy H on internal performance (DaveBarach, 15:34:41)
    1. l2-bridge testing - PVP - 0.002% Drop Rate (BillyM, 15:34:53)
    2. VPP-17.04: 256 Flow 7.8 MP/s 10k Flow 7.3 MP/s 1m Flow 5.2 MP/s (BillyM, 15:34:53)
    3. VPP-17.07: 256 Flow 7.7 MP/s 10k Flow 2.7 MP/s 1m Flow 1.8 MP/s (BillyM, 15:34:53)
    4. https://docs.fd.io/csit/rls1707/report/vpp_performance_tests/packet_throughput_graphs/l2.html#ndr-throughput (florinc_, 15:38:46)


Meeting ended at 15:45:11 UTC (full logs).

Action items

  1. Dave Wallace to ask csit team about deprecating virl testing
  2. dbarach ask ray about NSH / SFC info from Danny
  3. dbarach to write email re: coverity java complaints


People present (lines said)

  1. DaveBarach (32)
  2. jong_ (13)
  3. BillyM (4)
  4. collabot (3)
  5. florinc_ (2)
  6. dwallacelf (1)


Generated by MeetBot 0.1.4.