14:55:27 <DaveBarach> #startmeeting fdio vpp
14:55:27 <collabot> Meeting started Tue Sep 19 14:55:27 2017 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:55:27 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:55:27 <collabot> The meeting name has been set to 'fdio_vpp'
15:02:18 <DaveBarach> #topic host stack (Florin reporting)
15:02:56 <DaveBarach> performance, high-scale work
15:03:02 <DaveBarach> #topic ONE-LISP
15:03:13 <DaveBarach> #info fixing routing issues
15:03:21 <DaveBarach> #info added LISP neighbor discovery
15:03:28 <DaveBarach> #topic TCP stack
15:03:36 <DaveBarach> #info horizontal perf-scale improvements
15:03:54 <DaveBarach> #info stable at 10M connections on a dual-core (or greater) server
15:04:22 <DaveBarach> #info improving preallocated pool/segment handling
15:04:46 <DaveBarach> #info syn burst sent in aggregated frames, etc.
15:07:38 <DaveBarach> #topic Release 17.10 (Florin reported)
15:07:51 <DaveBarach> #info past API freeze, pls do not merge changes without committer vote
15:08:16 <DaveBarach> #info RC1 throttle pull next Weds
15:11:20 <Jong_> #topic Infra
15:11:29 <DaveBarach> #topic infrastructure status
15:13:33 <DaveBarach> #info now using 4-core minions, may switch to 8-core jenkins minions
15:15:33 <Jong_> #topic API, Distro Lifecycle Discussion (Jerome T, Dave, Ole)
15:19:44 <Jong_> #info Automatic change detection, draft patch in for 17.07
15:21:06 <DaveBarach> #info add suffix to api message names, e.g. "_v1,""_v2", etc.
15:25:54 <DaveBarach> #info Ray K suggests messages output w/ client library linked against old messages
15:34:14 <DaveBarach> #info question whether we can deprecate APIs from the POV of downstream distros
15:34:46 <DaveBarach> #info Tom H: API stabiliity a big issue for RedHat
15:35:43 <DaveBarach> #action Tom H to consult within RH and report
15:36:28 <DaveBarach> #info Ray K upstream LTS distro locked in APIs
15:37:26 <DaveBarach> #info Jerome mentions Honeycomb APIs are super-stable, built over binary APIs
15:38:24 <DaveBarach> #info Chris L: we need to get a lot better at documenting API changes
15:39:48 <DaveBarach> #info Jerome: example: netconf ACL model far more stable than native API
15:42:32 <DaveBarach> #topic 17.10 release contents (tom h)
15:43:26 <DaveBarach> #info Fedora patch shouldn't break anything (ssl dependency)
15:44:46 <DaveBarach> #info openssl 1.1 patch
15:46:09 <DaveBarach> #info second patch: bug in specfile w/ simple workaround
15:47:57 <Jong_> #topic Static analysis
15:48:09 <Jong_> #info very close to zero
15:49:24 <Jong_> #topic Open source summit report - Ed W reporting
15:50:06 <DaveBarach> #info really good turnout
15:50:25 <DaveBarach> #info lots on interest in containers
15:51:55 <DaveBarach> #info nice talk by hongjun at networking mini-summit
15:52:08 <DaveBarach> #info using vpp to accelerate kube-proxy
15:52:52 <Jong_> #topic API message re-registration noise (Dave)
15:55:40 <DaveBarach> #endmeeting