#fdio-vpp: fd.io vpp

Meeting started by DaveBarach at 16:00:56 UTC (full logs).

Meeting summary

  1. agenda additions? (DaveBarach, 16:03:18)
  2. CSIT (Peter Mikus reporting) (DaveBarach, 16:03:58)
    1. expect measurement data tomorrow (DaveBarach, 16:04:10)

  3. NSH/SFC (DaveBarach, 16:05:50)
    1. PTL election in progress, hope to hear soon (DaveBarach, 16:05:58)

  4. ONE/LISP (Florin) (DaveBarach, 16:06:11)
    1. maintenance mode for the moment (DaveBarach, 16:06:18)
    2. ACTION: dbarach remove ONE/LISP from weekly agenda (DaveBarach, 16:06:42)

  5. host stack (Florin) (DaveBarach, 16:06:59)
    1. binary API / vlibmemory work on socket transport refactoring (DaveBarach, 16:07:26)
    2. can now connect via socket and bootstrap a pairwise shared-memory connection to vpp (DaveBarach, 16:07:46)
    3. big patch pending to refactor vlibmemory in simple ways (DaveBarach, 16:08:45)
    4. better client/server isolation (DaveBarach, 16:08:58)
    5. separate vlib API code from (memory,socket) transport (DaveBarach, 16:09:39)
    6. https://gerrit.fd.io/r/#/c/9976/ (florinc, 16:10:07)
    7. Dave Wallace on LD_PRELOAD work (DaveBarach, 16:10:59)
    8. elog events added by Keith (DaveBarach, 16:11:20)
    9. Dave Wallace refactoring LD_PRELOAD: make the library stateless (DaveBarach, 16:11:45)
    10. 4KLOC removed (DaveBarach, 16:12:13)
    11. "no more hash tables!" (DaveBarach, 16:12:34)
    12. mixed vpp/kernel select, epoll: split bitmaps, etc. (DaveBarach, 16:13:59)
    13. better tracing so people will find out that "X is unimplemented" in an obvious way (DaveBarach, 16:15:17)
    14. Keith will be updating wiki with elog info (DaveBarach, 16:15:49)
    15. demo at Kubecon - thanks to Ed, Jan - native integration with Envoy in progress (DaveBarach, 16:16:20)
    16. working on native VCL integration into apps (DaveBarach, 16:16:36)
    17. discussion around Spectre and Meltdown perf implications (DaveBarach, 16:19:40)

  6. arm / aarch64 (Tina T reporting) (DaveBarach, 16:20:43)
    1. CSIT added support for aarch64 (DaveBarach, 16:21:26)
    2. next two weeks, continue w/ testing, perf benchmarking (DaveBarach, 16:21:55)

  7. 18.01 release (Dave Wallace) (DaveBarach, 16:22:43)
    1. RC1 branch cut last week (DaveBarach, 16:22:51)
    2. OpenSUSE artifacts not being published yet (DaveBarach, 16:23:36)
    3. request to Marco: don't build old branches since they won't work (DaveBarach, 16:24:17)

  8. Coverity SA currently broken (DaveBarach, 16:26:45)
    1. seems like disk breakage knock-on effects (DaveBarach, 16:27:26)
    2. not in bad shape, we'll see if we can "get to zero" before final release (DaveBarach, 16:27:59)

  9. fd.io events (Ed, Ray) (DaveBarach, 16:29:44)
    1. Ray mentions 4 vpp talks at FOSDEM (Feb, Brussels) (DaveBarach, 16:30:07)
    2. ONS 2018 CFP opaque. Ed working to construct an fd.io minisummit (DaveBarach, 16:31:19)
    3. Kubecon Europe (May) CFP closes Jan 12 (DaveBarach, 16:32:07)
    4. ACTION: Ed to add Kubecon Europe details to wiki (DaveBarach, 16:32:21)

  10. Damjan on native driver for Macchiato (DaveBarach, 16:34:39)
    1. use Marvell user-mode SDK. Driver working, need to resolve shared-memory base VA issue (DaveBarach, 16:35:26)
    2. vpp overusing prefetch slots. vpp 3.5 mpps vs. sample app 9 mpps (DaveBarach, 16:36:42)

  11. Damjan on tap v2 driver (DaveBarach, 16:45:34)
    1. ring size tuning may be required. Default 256 is intended to keep older kernels happy (DaveBarach, 16:46:02)


Meeting ended at 16:46:52 UTC (full logs).

Action items

  1. dbarach remove ONE/LISP from weekly agenda
  2. Ed to add Kubecon Europe details to wiki


People present (lines said)

  1. DaveBarach (47)
  2. collabot (3)
  3. florinc (1)


Generated by MeetBot 0.1.4.