#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 16:01:49 UTC (full logs).

Meeting summary

  1. csit (Maciek reporting) (DaveBarach, 16:03:43)
    1. a number of csit jobs stopped working yesterday (DaveBarach, 16:04:05)
    2. missing dependencies, being fixed (DaveBarach, 16:04:32)
    3. "api-segment { gid vpp }" in startup.conf, not recognized (mackonstan, 16:06:13)
    4. ... I'm not seeing the "api-segment..." issue, TBH... (DaveBarach, 16:08:24)

  2. Honeycomb (Marek reporting) (DaveBarach, 16:17:10)
    1. merged vpp-1184, including api generation fixes (DaveBarach, 16:17:27)

  3. host stack (Keith, Florin) (DaveBarach, 16:18:16)
    1. async event handling in VCL (DaveBarach, 16:18:22)
    2. make-test added cuth-through and host-to-host testing (DaveBarach, 16:19:20)
    3. basic + extended tests (DaveBarach, 16:19:37)
    4. test script can run iperf - should we add to make test dependencies? (DaveBarach, 16:22:43)

  4. host stack TLS implementation (DaveBarach, 16:25:39)
    1. early version in master/latest now (DaveBarach, 16:25:48)
    2. TLS "recursive application" support (DaveBarach, 16:26:25)
    3. using mbedTLS at this point (DaveBarach, 16:26:37)
    4. CentOS downstream packaging pain w/ mbedTLS (DaveBarach, 16:30:50)

  5. 18.04 2 weeks from API freeze! (DaveBarach, 16:33:14)
  6. infrastructure (DaveBarach, 16:35:01)
    1. merge job fails due to make-test multiple vpp instance detection, found workaround (DaveBarach, 16:35:20)
    2. ACTION: Ed and Dave W to set up email when merge job fails (DaveBarach, 16:36:46)

  7. encryption algorithms (DaveBarach, 16:42:11)
    1. crypto algorithm need list of algorithms used and coded (DaveBarach, 16:44:27)

  8. Ubuntu 18.04 LTS (DaveBarach, 16:52:10)
    1. need to decide what/when to support it (DaveBarach, 16:52:36)


Meeting ended at 16:58:03 UTC (full logs).

Action items

  1. Ed and Dave W to set up email when merge job fails


People present (lines said)

  1. DaveBarach (26)
  2. collabot` (3)
  3. Chrisy (2)
  4. mackonstan (1)


Generated by MeetBot 0.1.4.