15:02:12 <DaveBarach> #startmeeting fdio vpp
15:02:12 <collabot> Meeting started Tue Jul 10 15:02:12 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:12 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:12 <collabot> The meeting name has been set to 'fdio_vpp'
15:02:55 <mackonstan> #topic CSIT
15:03:00 <DaveBarach> #topic CSIT (Maciek K reporting)
15:03:09 <DaveBarach> #info infra work in progress
15:03:13 <mackonstan> #info Progressing with CSIT infra work and new integration tests:
15:03:20 <mackonstan> #info i) Xeon Skylake servers onboarding - some delays due to HW/firmware issues - still targetting initial results for rls1807, both trending and in report.
15:03:36 <mackonstan> #info ii) VIRL test porting to VPP_make_test - P0 tests almost done, completion ETA this week.
15:03:41 <DaveBarach> #info skylake servers delayed, still plan to issue skylake report w/ 18.07 report
15:03:55 <DaveBarach> #info virl transition P0 tests expect to complete this week
15:04:01 <mackonstan> #info iii) New functional tests on hardware [VPP_Device] - dedicated two 1-Node Xeon Skylake servers are live, CSIT framework work started.
15:04:21 <mackonstan> #info New anomaly detection scheme in operation on main trending pages.
15:04:27 <mackonstan> #info New alias being setup for reporting trending failures and regressions: csit-report@lists.fd.io.
15:04:41 <DaveBarach> #info new alias on the way for trending report emails, approved, in progress w/ LF
15:05:09 <mackonstan> #info re dpdk18.05 regression on x520 NICs - patch merged making dpdk18.05 a default, no regressions detected in trending jobs
15:05:37 <DaveBarach> #info dpdk 18.05 regression: will merge, still looking for patches from dpdk community
15:05:39 <mackonstan> #info but we do see regression in testpmd and l3fwd tests - awaiting more feedback from dpdk folks/Ray
15:07:56 <DaveBarach> #topic Honeycomb no report this week
15:08:08 <DaveBarach> #topic Host Stack (Florin reporting)
15:08:36 <DaveBarach> #info VCL refactoring in progress, no more pushes due to F0 code freeze
15:10:33 <DaveBarach> #topic Documentation (John D., Ray K. reporting)
15:15:28 <DaveBarach> #info minor "checkstyle.sh" change to avoid verifying doc-only patches
15:18:32 <DaveBarach> #action Ed Kern to fix checkstyle.sh to "fail" doc-only patches in an obvious way
15:20:16 <DaveBarach> #action Ed Kern to investigate adding doc reviewers to patches above a certain size
15:21:57 <DaveBarach> #topic ARM (Tina Tsou reporting)
15:22:31 <DaveBarach> #info ip4 forwarding work in progress
15:23:29 <DaveBarach> #info hard to hear...
15:25:57 <DaveBarach> #topic 18.07 release - on schedule, need to clean up coverity warnings
15:26:02 <DaveBarach> #topic infra status
15:26:44 <DaveBarach> #info build system seems stable for the last 2 weeks
15:26:52 <DaveBarach> #info merge jobs backing up
15:28:02 <DaveBarach> #info LF reboot / updates coming this afternoon
15:33:39 <DaveBarach> #endmeeting