#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:59:15 UTC (full logs).

Meeting summary

  1. CSIT (Maciek) (DaveBarach, 15:03:57)
    1. re Intel Xeon Skylake testbeds running (mackonstan, 15:05:01)
    2. data will be in report, including comparison between Intel Xeon Haswell and Skylake testbeds (mackonstan, 15:05:24)
    3. had some issues with HW, 3 motherboards RMAed, 2 testbeds affected. (mackonstan, 15:05:40)
    4. re VIRL migration to VPP_make_test (mackonstan, 15:05:47)
    5. once ecmp ip4 ip6 tests are merged, all VIRL P0s are done (mackonstan, 15:05:58)
    6. ipfix tests downgraded from P0 to P1, as similar functionality covered by test_flowprobe.py (mackonstan, 15:07:13)
    7. CSIT switched to new MLRsearch algorithm for NDR/PDR measurements (mackonstan, 15:07:37)
    8. Multiple Loss Ratio search - test code refactor done, verifying results, applying MTU fixes (mackonstan, 15:07:46)
    9. re automated alerting to csit-report@lists.fd.io (mackonstan, 15:08:12)
    10. postponed to after rls1807, as we've been preoccupied with getting the Skylake testbeds productized (mackonstan, 15:08:20)
    11. CSIT rls1807 branch created, vpp18.07-rc2 tests started (mackonstan, 15:08:27)
    12. rls1807 report updates in progress (mackonstan, 15:08:35)

  2. Honeycomb (Marek reporting) (DaveBarach, 15:08:54)
    1. RC1 released today (DaveBarach, 15:09:03)
    2. release in two weeks from today (DaveBarach, 15:09:10)
    3. re CSIT Performance dashboard: observing some regressions mainly in L2 paths (mackonstan, 15:09:24)
    4. https://docs.fd.io/csit/master/trending/introduction/index.html (mackonstan, 15:09:34)

  3. Host Stack (Florin reporting) (DaveBarach, 15:10:28)
    1. working on master/latest, refactoring VCL (DaveBarach, 15:10:48)
    2. incremental approach - try not to break it. (DaveBarach, 15:11:11)
    3. message rings to exchange both control and i/o events (DaveBarach, 15:11:32)
    4. change read/write/epoll/select to use message queues in the next couple of days (DaveBarach, 15:11:53)

  4. Documentation (John DeNisco reporting) (DaveBarach, 15:12:20)
    1. move to vpp repo in the near future (DaveBarach, 15:13:06)
    2. near future = this week, for master/latest (DaveBarach, 15:16:13)

  5. ARM (Tina T reporting) (DaveBarach, 15:17:57)
    1. driver work in progress (DaveBarach, 15:18:14)
    2. https://review.openstack.org/Documentation/user-search.html#path <- How to use gerrit to query by path (edwarnicke, 15:18:46)
    3. armv8 crypto changes upstreaming (DaveBarach, 15:19:38)

  6. 18.07 release (Ed W) (DaveBarach, 15:20:25)
    1. release scheduled for next Monday (DaveBarach, 15:20:37)

  7. (Infra/build) (DaveBarach, 15:22:26)
    1. bionic repo problems fixed (DaveBarach, 15:22:39)
    2. few small outages due to security patching (DaveBarach, 15:22:53)

  8. fd.io events (Ed W reporting) (DaveBarach, 15:24:51)
    1. need to update the agenda (DaveBarach, 15:24:59)
    2. Kubecon Seattle CFP open until 8/12, absolutely worth getting talk(s) into it (DaveBarach, 15:25:28)
    3. we WILL have a fd.io mini-summit in December (DaveBarach, 15:25:44)
    4. ACTION: Ed W to clean up agenda (DaveBarach, 15:26:08)
    5. big fat flows question from Nitin (DaveBarach, 15:28:08)
    6. packet reordering considered harmful (DaveBarach, 15:31:30)


Meeting ended at 15:32:17 UTC (full logs).

Action items

  1. Ed W to clean up agenda


People present (lines said)

  1. DaveBarach (30)
  2. mackonstan (14)
  3. collabot (3)
  4. edwarnicke (1)


Generated by MeetBot 0.1.4.