14:58:48 <DaveBarach> #startmeeting fdio-vpp
14:58:48 <collabot> Meeting started Tue Sep 18 14:58:48 2018 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:48 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:48 <collabot> The meeting name has been set to 'fdio_vpp'
15:01:57 <DaveBarach> #info agenda additions
15:02:42 <DaveBarach> #topic CSIT (Maciek reporting)
15:03:10 <DaveBarach> #info packetcloud working, congrats to Ed & Ed
15:04:16 <DaveBarach> #info as of 18.10, will have proper driver tests
15:04:30 <DaveBarach> #info skylake perf trending jobs online
15:05:07 <DaveBarach> #info question: would like to do more automated comparisons
15:05:27 <DaveBarach> #info question: what else would the community like to have A-B compared?
15:05:52 <DaveBarach> #info fib scaling, ACL scaling as examples
15:07:58 <DaveBarach> #info Ray K: rx/tx loopback test, already in according to Maciek
15:08:53 <DaveBarach> #info patch-to-patch trending job results being analyzed by humans, currently too many false positives to enable voting
15:11:46 <DaveBarach> #info dbarach suggests chi-square testing
15:12:03 <DaveBarach> #topic Honeycomb (Michal C reporting)
15:12:23 <DaveBarach> #info a couple of failing tests, expect fixed this week
15:12:36 <DaveBarach> #info issues adding L2 fib table entries, Neale looking at it
15:13:05 <DaveBarach> #topic Host Stack (Florin reporting)
15:13:28 <DaveBarach> #info multiple worker bind support working
15:13:44 <DaveBarach> #info improving stability and performance (vcl, plus host stack)
15:13:45 <mortderire> folks - I need to drop for a few minutes, will be back in 10.
15:14:10 <DaveBarach> #info merged patch to do multi-arch support for svm fifos, specifically to improve memcpy performance
15:14:34 <DaveBarach> #topic Documentation (John D, Ray K)
15:14:54 <DaveBarach> #info met w/ LF about main website
15:15:29 <DaveBarach> #info will need help from Ed Kern, Vanessa to upload per-patch docs
15:15:48 <DaveBarach> #action John D and Ed Kern to discuss building / moving docs
15:16:29 <DaveBarach> #info working with LF marketing folks to change top-level site
15:17:59 <DaveBarach> #topic aarch64 (Tina T reporting)
15:18:18 <DaveBarach> #info mellanox library has issues w/ cmake
15:18:33 <DaveBarach> #info VPP-1391 make verify failure
15:18:46 <DaveBarach> #info ken from Huawei looking at this failure
15:19:01 <DaveBarach> #info vectorization work - patch submitted
15:19:21 <DaveBarach> #info dual vs. quad loop worth ~3% in performance
15:20:09 <DaveBarach> #info still waiting for power-cycler cost estimate for macciato-bin systems
15:21:02 <DaveBarach> #topic 18.07 release
15:21:09 <DaveBarach> #info 18.07.1 point release done
15:21:48 <DaveBarach> #topic 18.10 (Marco reporting)
15:22:05 <DaveBarach> #info two-week warning email to go out
15:24:10 <DaveBarach> #action Marco V to send 2-week warning email at midweek
15:25:15 <DaveBarach> #info Maciek asks for heads-up on incompatible API changes
15:29:45 <DaveBarach> #topic LTS releases (Marco V,  Damjan)
15:30:34 <DaveBarach> #info Suggestion: vpp should stick with dpdk LTS releases (default build)
15:31:21 <DaveBarach> #info Damjan says we can start w/ 18.11 (next DPDK LTS release)
15:32:17 <DaveBarach> #info Ray asks how do we track dpdk fixes in LTS releases?
15:33:01 <DaveBarach> #info Marco: patches make it back into DPDK LTS releases
15:37:15 <DaveBarach> #topic CentOS / RH Rel toolchain issues (Damjan, DaveB, Tom H, Billy McF)
15:38:42 <DaveBarach> #info Tom H: can we see what happens w/ csit if we try gcc-4
15:39:04 <DaveBarach> #info Maciek: csit is Ubuntu-based
15:41:20 <DaveBarach> #info Tom H: supposedly CentOS + gcc-4 builds working vpp binaries
15:58:47 <DaveBarach> #topic Infra
15:59:12 <DaveBarach> #info packagecloud transition making progress, nexus still being used
16:01:35 <DaveBarach> #info will reenable arm voting for builds but not "make test"
16:03:21 <DaveBarach> #info Marco V will be at ONS, who else
16:03:26 <DaveBarach> #info Billy McFall will be there
16:03:49 <DaveBarach> #endmeeting