16:03:00 <DaveBarach> #startmeeting fdio-vpp
16:03:00 <collabot`> Meeting started Tue Feb  5 16:03:00 2019 UTC.  The chair is DaveBarach. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:00 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:03:00 <collabot`> The meeting name has been set to 'fdio_vpp'
16:03:19 <mackonstan> #topic CSIT update
16:03:28 <mackonstan> #info CSIT-1901 release complete
16:03:37 <mackonstan> #info VPP-19.01 tests collecting data for report are running
16:03:49 <mackonstan> #info three known issues being worked on
16:04:05 <mackonstan> #info i) VPP IPSec AES-GCM cipher broken, issue with dpdk ipsec backend (openssl ciphers work fine)
16:04:27 <mackonstan> #info ii) link bonding tests sporadically fail due to VPP crash, under investigation
16:04:46 <mackonstan> #info iii) VM vhost tests fail sporadically due to QEMU bug, workaround being applied
16:05:27 <mackonstan> #info otherwise good :)
16:06:39 <DaveBarach> #topic Honeycomb (Michal)
16:06:53 <DaveBarach> #info release is tomorrow, waiting for article upload
16:07:17 <DaveBarach> #topic Host Stack (Florin)
16:07:28 <DaveBarach> #info experimental support for multi-thread applications
16:07:52 <DaveBarach> #info threads which share sessions, that is.
16:08:19 <DaveBarach> #info passive listener support (for ngingx), start session, listen in main worker, then fork
16:08:46 <DaveBarach> #info and collect the session
16:09:20 <DaveBarach> #info "spring cleanup" underway; transport now session soon. Please yell if e.g. compile build-breaks occur
16:09:33 <DaveBarach> #info renaming things, this is the right time for the cleanup
16:10:10 <DaveBarach> #topic Documentation (John D reporting)
16:10:35 <DaveBarach> #info main page, landing page prototypes look good, waiting on the LF to do a (marketing) walkthrough
16:10:57 <DaveBarach> #action John D. to give go-live date at next meeting
16:11:58 <DaveBarach> #topic ARM-64 / aarch64 (Tina T reporting)
16:12:16 <DaveBarach> #info Happy Lunar New Year!
16:12:36 <DaveBarach> #info memcpy optimization, iperf3 perf w/ host stack
16:12:47 <DaveBarach> #info ip4 quad-loop under investigation
16:13:17 <DaveBarach> #info focus on arch-specific vectorization work
16:13:58 <DaveBarach> #info 128-byte cache-line size investigations
16:14:21 <DaveBarach> #info making 128-byte cache line size packages
16:15:10 <DaveBarach> #info svm fifo experiments to see if relaxed memory order will help
16:18:06 <DaveBarach> #topic 19.01 Release (Andrew Y)
16:18:50 <DaveBarach> #info upstream python packages released at the same moment, good for some confusion
16:19:19 <DaveBarach> #info LF folks clock out earlier than expected for the PST time zone
16:23:49 <DaveBarach> #action Dave Wallace to be Release Mgr for 19.04
16:25:14 <DaveBarach> #endmeeting