#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 16:01:38 UTC (full logs).

Meeting summary

    1. mackonstan (mackonstan, 16:03:09)

  1. csit (maciek reporting) (DaveBarach, 16:03:17)
    1. CSIT-1901 maintenance report published last week, main delta is addition of VPP link bonding test results after two fixes applied (mackonstan, 16:03:37)
    2. https://docs.fd.io/csit/rls1901/report/index.html (mackonstan, 16:03:53)
    3. 1-button install for csit testing (yay!) (DaveBarach, 16:05:11)
    4. CSIT work in progress: test suite auto-generation (adding NIC variations, throughput methodologies), testbed auto-installer, VAT to PAPI migration. (mackonstan, 16:05:12)
    5. VPP IPSec tests went broken after API changes, now fixed (mackonstan, 16:05:44)
    6. Looking for an automated way to address the client-side VPP API versions and change awareness, started to work with Dave W. on a proposal (mackonstan, 16:06:16)
    7. try to catch API changes which break CSIT tests (DaveBarach, 16:06:20)
    8. Some VPP master trending failures, working on root causing that (mackonstan, 16:06:33)
    9. https://docs.fd.io/csit/master/trending/introduction/failures.html (mackonstan, 16:06:46)
    10. New testbeds: Arm and Atom testbeds are still onboarding, LFN DC dependencies (mackonstan, 16:07:07)

  2. Honeycomb (Michal reporting) (DaveBarach, 16:07:25)
    1. working on bionic jobs for HC / jvpp (DaveBarach, 16:07:39)
    2. now have official bionic images (DaveBarach, 16:07:53)

  3. Host Stack (Florin reporting) (DaveBarach, 16:08:41)
    1. session layer cleanups (DaveBarach, 16:08:47)
    2. refactor of local sessions into a cut-through transport (DaveBarach, 16:09:09)
    3. helps unify interaction between apps and sessions (DaveBarach, 16:09:24)

  4. Documentation (John D. reporting) (DaveBarach, 16:09:44)
    1. not heard anything this week (DaveBarach, 16:09:52)

  5. ARM (Sirshak reporting) (DaveBarach, 16:10:29)
    1. svm fifo rework / review in progress (DaveBarach, 16:10:42)
    2. summary: change from cursize -> head/tail manipulation (DaveBarach, 16:11:34)

  6. 19.01 release (DaveBarach, 16:12:13)
    1. a couple of fixes which necessitate a dot release (DaveBarach, 16:12:35)
    2. iommu patch (DaveBarach, 16:12:45)
    3. crypto-dev / ipsec patch (DaveBarach, 16:12:54)
    4. cherry-picks are done for these (DaveBarach, 16:13:10)
    5. ACTION: dbarach to ask andrew when we can cut a 19.01.01 release (DaveBarach, 16:13:47)
    6. ACTION: dwallace to cut 19.01.01 point release (backup for Andrew) (DaveBarach, 16:16:53)

  7. 19.04 release (Dave W) (DaveBarach, 16:17:37)
    1. please update wiki feature list (DaveBarach, 16:17:45)
    2. approx 4 week from FC0 (api freeze) (DaveBarach, 16:18:20)

  8. Python 3.0 transition (Dave Wallace) (DaveBarach, 16:18:53)
    1. test framework, packaging in progress (DaveBarach, 16:19:18)
    2. Paul V owns most of the work, not clear we'll be able to switch for 19.04 (DaveBarach, 16:19:58)
    3. ACTION: Ole to ask Paul V to update vpp-dev w/ current status (DaveBarach, 16:20:30)
    4. test framework support for Python-2 can end soon, but probably not 19.04 (DaveBarach, 16:21:08)

  9. Coverity (DaveBarach, 16:25:02)
    1. please clean up ipsec (DaveBarach, 16:25:08)

  10. Infra / patch validation (Ed Kern) (DaveBarach, 16:26:02)
    1. 2x jenkins "accidents" fixed by Vexhost migrating the jenkins vm (DaveBarach, 16:26:44)
    2. this led to two bursts of rechecks. (DaveBarach, 16:27:31)


Meeting ended at 16:33:42 UTC (full logs).

Action items

  1. dbarach to ask andrew when we can cut a 19.01.01 release
  2. dwallace to cut 19.01.01 point release (backup for Andrew)
  3. Ole to ask Paul V to update vpp-dev w/ current status


People present (lines said)

  1. DaveBarach (37)
  2. mackonstan (9)
  3. collabot (3)


Generated by MeetBot 0.1.4.